Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need Help! Vlan problem

I set up three vlans on 3560 switch(using command:switchport access vlan #) But when I connect my PC to any port assigned to those vlans including vlan1(default), my PC cannot obtain the IP address automaticlly. How can I solve this problem? Many thanks!

5 REPLIES

Re: Need Help! Vlan problem

Hi,

In which VLAN does the DHCP server reside ?

BR,

Mohammed Mahmoud.

New Member

Re: Need Help! Vlan problem

VLAN1(the default one)

New Member

Re: Need Help! Vlan problem

Hi,

(config)#int vlan

(config-if)#ip helper-address

Hope that helps.

-Chris

New Member

Re: Need Help! Vlan problem

hi,

make sure that your server is reachable and if there is any snooping configured on your switch.

could you post the config of your switch will help better

thanks

New Member

Re: Need Help! Vlan problem

Current configuration : 3202 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

no aaa new-model

ip subnet-zero

ip routing

!

ip multicast-routing distributed

ip igmp snooping vlan 1 static 239.1.1.14 interface Fa0/4

ip igmp snooping vlan 1 static 239.1.1.14 interface Fa0/6

ip igmp snooping vlan 1 static 239.1.1.13 interface Fa0/3

ip igmp snooping vlan 1 static 239.1.1.13 interface Fa0/6

ip igmp snooping vlan 1 static 239.1.1.12 interface Fa0/2

ip igmp snooping vlan 1 static 239.1.1.12 interface Fa0/6

ip igmp snooping vlan 1 static 239.1.1.11 interface Fa0/1

ip igmp snooping vlan 1 static 239.1.1.11 interface Fa0/6

ip igmp snooping vlan 3 static 239.1.1.15 interface Fa0/15

ip igmp snooping vlan 3 static 239.1.1.15 interface Fa0/17

ip igmp snooping vlan 3 static 239.1.1.18 interface Fa0/17

ip igmp snooping vlan 3 static 239.1.1.17 interface Fa0/15

ip igmp snooping vlan 3 static 239.1.1.17 interface Fa0/17

ip igmp snooping vlan 3 static 239.1.1.16 interface Fa0/15

ip igmp snooping vlan 3 static 239.1.1.16 interface Fa0/17

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

!

vlan internal allocation policy ascending

!

!

interface FastEthernet0/1

switchport mode access

!

interface FastEthernet0/2

switchport mode access

!

interface FastEthernet0/3

switchport mode access

!

interface FastEthernet0/4

switchport mode access

!

interface FastEthernet0/5

switchport mode access

!

interface FastEthernet0/6

switchport mode access

!

interface FastEthernet0/7

!

interface FastEthernet0/8

switchport mode access

!

interface FastEthernet0/9

!

interface FastEthernet0/10

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/14

no switchport

no ip address

!

interface FastEthernet0/15

switchport access vlan 3

switchport mode access

ip access-group 1 in

!

interface FastEthernet0/16

no switchport

no ip address

!

interface FastEthernet0/17

switchport access vlan 3

switchport mode access

ip access-group 1 in

!

interface FastEthernet0/18

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/21

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/22

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

!

interface Vlan2

no ip address

no ip mroute-cache

!

interface Vlan3

no ip address

!

interface Vlan4

no ip address

!

ip classless

ip route 192.168.10.34 255.255.255.255 FastEthernet0/14

ip route 192.168.10.40 255.255.255.255 FastEthernet0/16

ip http server

!

!

access-list 1 deny any

!

control-plane

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

end

Thanks a lot!

113
Views
4
Helpful
5
Replies