Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need help

Hi there,

I was trying to create a new VLAN on my core switch but after creating,I cannot ping to the new VLAN. Attached with my new VLAN config;

Core1#conf t

Core1(config)#interface Vlan171

Core1(config)#ip address 10.19.22.2 255.255.255.0

Core1(config)#no ip redirects

Core1(config)#standby ip 10.19.22.1

Core1(config)#router ospf 100

Core1(config)#passive-interface Vlan171

Core1(config)#end

19 REPLIES
Cisco Employee

Re: Need help

Hi Friend,

Where are you trying to ping from, I mean which vlan/subnet? Also can you check if your vlan 171 is up and up with "sh interface vlan 171"?

Do you have any clients physically connected to vlan 171? Or do you have any trunk carrying vlan 171? can you also check the status of vlan database with "sh vlan" command?

Regards,

Ankur

Re: Need help

What do you mean by "I cannot ping to the new VLAN? Does it mean you cannot ping the core addresses 10.19.22.1 and 10.19.22.2?

Do you have routing in your distribution layer? If so, can you see 10.19.22.0/24 in the routing tables there? Maybe you have prevented the distribution layer knowing about the VLAN SVI by making the VLAN interface passive.

Has the new layer-2 VLAN been propagated down to the distribution layer? Do a show vlan on the distribution layer.

Also, you may need to do a no shut on the new SVI interface.

Please could you supply some more information about your architecture, otherwise it will not be easy to know what is going on.

Kevin Dorrell

Luxembourg

New Member

Re: Need help

Hi there,

I was trying to ping within the core switch, say ping 10.19.22.2 (which is the newly created VLAN ID)which no reply.

I did a sh int vlan171 and this is what I gotten ;

Vlan171 is up, line protocol is down

Hardware is EtherSVI, address is 0006.2ad8.980a (bia 0006.2ad8.980a)

Description: SharePoint Vlan (CR20071378)

Internet address is 10.19.22.2/24

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

ARP type: ARPA, ARP Timeout 04:00:00

Last input never, output 00:31:56, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 2 pkt, 128 bytes

L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast

L3 out Switched: ucast: 0 pkt, 0 bytes

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts (0 IP multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

6 packets output, 384 bytes, 0 underruns

0 output errors, 3 interface resets

0 output buffer failures, 0 output buffers swapped out

I also did a sh vlan and I couldn't find this VLAN there.

I also noticed I have a spanning-tree configuration, how do I add in vlan171 into the following spanning-tree ?

spanning-tree mode mst

spanning-tree vlan 1,3,11,17,19,21,23,25,27,29,31,33,37,241,243,245 priority 1

spanning-tree vlan 247,249,251,253,255,257,259,261,263,265,267,269 priority 1

spanning-tree vlan 999 priority 1

spanning-tree vlan 4,10,14,18,20,22,24,26,28,30,34,36,50,56,100,240 priority 2

spanning-tree vlan 242,244,246,248,250,252,254,256,258,260,262,264 priority 2

spanning-tree vlan 266,268,270,280 priority 2

!

spanning-tree mst configuration

name ABC

revision 1

instance 1 vlan 1, 3, 11, 17, 19, 21, 23, 25, 27, 29, 31, 33, 37, 241

instance 1 vlan 243, 245, 247, 249, 251, 253, 255, 257, 259, 261, 263

instance 1 vlan 265, 267, 269, 999

instance 2 vlan 4, 10, 14, 18, 20, 22, 24, 26, 28, 30, 34, 36, 50, 56

instance 2 vlan 100, 240, 242, 244, 246, 248, 250, 252, 254, 256, 258

instance 2 vlan 260, 262, 264, 266, 268, 270, 280, 501

!

spanning-tree mst 0-1 priority 4096

spanning-tree mst 2 priority 12288

Cisco Employee

Re: Need help

Hi Friend,

This means you have not created vlan 171 in your vlan database so first create that using a command

switch(config)#vlan 171

Once done you can see this vlan 171 in your vlan database and you can verify with command "sh vlan".

Then allow this vlan on your trunk port and you should be able to ping vlan 171 interface ip address.

HTH

Ankur

*Pls rate all helpfull post

New Member

Re: Need help

Hi, how do I allow the vlan on my trunk port ? the command line ? Thanks !

Cisco Employee

Re: Need help

Hi Friend,

The command is "switchport trunk allowed vlan add 171"

HTH

Ankur

*Pls rate all helpfull post

Re: Need help

First of all, can you see the VLAN on the core switch when you do a show vlan. If not, then then the VLAN does not exist yet, so trying to enable it on the trunk will do nothing.

If it does exist, then can we see the trunk configuration? Does it allow only sepcific VLANs?

If you are using MST, be careful about which trunk you add it to, otherwise you will end up with an incosistent topology. Have you decided which instance you will add it to?

Kevin Dorrell

Luxembourg

Cisco Employee

Re: Need help

Hi Kevin,

Sorry to interrupt here but if you see original poster second reply when I asked him for the outputs he mentioned clearly "I also did a sh vlan and I couldn't find this VLAN there"

Also my next post updated him to create vlan first and then i asked him to verify again with "sh vlan" command and finally add it to some trunk port.

Regards,

Ankur

New Member

Re: Need help

Hi there,

Thanks for helping. I have added the vlan 171 and I am able to ping to vlan 171.

With regards to MST, I would like to include vlan 171 as the following;

spanning-tree mode mst

spanning-tree vlan 1,3,11,17,19,21,23,25,27,29,31,33,37,241,243,245 priority 1

spanning-tree vlan 247,249,251,253,255,257,259,261,263,265,267,269 priority 1

spanning-tree vlan 999 priority 1

spanning-tree vlan 4,10,14,18,20,22,24,26,28,30,34,36,50,56,100,171,240 priority 2

spanning-tree vlan 242,244,246,248,250,252,254,256,258,260,262,264 priority 2

spanning-tree vlan 266,268,270,280 priority 2

!

spanning-tree mst configuration

name ABC

revision 1

instance 1 vlan 1, 3, 11, 17, 19, 21, 23, 25, 27, 29, 31, 33, 37, 241

instance 1 vlan 243, 245, 247, 249, 251, 253, 255, 257, 259, 261, 263

instance 1 vlan 265, 267, 269, 999

instance 2 vlan 4, 10, 14, 18, 20, 22, 24, 26, 28, 30, 34, 36, 50, 56

instance 2 vlan 100, 171, 240, 242, 244, 246, 248, 250, 252, 254, 256, 258

instance 2 vlan 260, 262, 264, 266, 268, 270, 280, 501

!

If you notice, vlan 171 is in the list, so how do I get about adding vlan 171 into the list ?

Need the commands too...Thanks !! Sorry me admin noob...

Cisco Employee

Re: Need help

Hi Friend,

Good to know it started pinging. Now I see that vlan 171 is already added in your spanning tree configuration so what exactly you are looking now?

Regards,

Ankur

Re: Need help

OK Ankur. Sorry, it was me who was interrupting.

Kevin

New Member

Re: Need help

Hi there,

Maybe missed this part....

Thanks for helping. I have added the vlan 171 and I am able to ping to vlan 171.

With regards to MST, I would like to include vlan 171 as the following;

spanning-tree mode mst

spanning-tree vlan 1,3,11,17,19,21,23,25,27,29,31,33,37,241,243,245 priority 1

spanning-tree vlan 247,249,251,253,255,257,259,261,263,265,267,269 priority 1

spanning-tree vlan 999 priority 1

spanning-tree vlan 4,10,14,18,20,22,24,26,28,30,34,36,50,56,100,171,240 priority 2

spanning-tree vlan 242,244,246,248,250,252,254,256,258,260,262,264 priority 2

spanning-tree vlan 266,268,270,280 priority 2

!

spanning-tree mst configuration

name ABC

revision 1

instance 1 vlan 1, 3, 11, 17, 19, 21, 23, 25, 27, 29, 31, 33, 37, 241

instance 1 vlan 243, 245, 247, 249, 251, 253, 255, 257, 259, 261, 263

instance 1 vlan 265, 267, 269, 999

instance 2 vlan 4, 10, 14, 18, 20, 22, 24, 26, 28, 30, 34, 36, 50, 56

instance 2 vlan 100, 171, 240, 242, 244, 246, 248, 250, 252, 254, 256, 258

instance 2 vlan 260, 262, 264, 266, 268, 270, 280, 501

!

If you notice, vlan 171 is in the list, so how do I get about adding vlan 171 into the list ?

Need the commands too...Thanks !! Sorry me admin noob...

Cisco Employee

Re: Need help

Hi Friend,

May be I am not able to understnd your question here but I see vlan 171 is already present in the list ..

spanning-tree vlan 4,10,14,18,20,22,24,26,28,30,34,36,50,56,100,171,240 priority 2

instance 2 vlan 100, 171, 240, 242, 244, 246, 248, 250, 252, 254, 256, 258

I see vlan 171 is alreday there in your MST config so what exactly you are looking for ?

Do you mean that this is not the output from the switch and you want vlan 171 to be like this?

REgards,

Ankur

New Member

Re: Need help

Hi Ankur,

Yup, thats the ideal list that I would like to have...

So, I would like to include the vlan 171.

New Member

Re: Need help

Any1 helping me ? =X

Re: Need help

I think you are asking how do you add the VLAN to the trunks so it is seen by the other switches. You need the new VLAN 171 to be allowed on all the trunks that carry the other VLANs in MST instance 2.

So, do a show spanning-tree mst 2. (I think you added 171 into instance 2, didn't you?). In the list of interfaces, identify the ones that are trunks, and have a look at their configuration. They are likely to have commands such as switchport trunk allowed vlan l,m,n etc. If so, (and only if so, and only if 171 is not in the list already) you need to add VLAN 171 into that list. switchport trunk allowed vlan add 171.

You may need to do the same on the connecting switches.

Kevin Dorrell

Luxembourg

Re: Need help

Just wanted to add a warning. Be very very careful not to forget the add keyword. If you forget it, you will lose the VLANs that are already on the trunk.

Kevin Dorrell

Luxembourg

Re: Need help

ftallet - Francois, if you are reading this ...

Is there any chance in future versions we could have a command like switchport trunk allowed vlan [add] mst n, to allow/add all the VLANs in MST instance n? Wouldn't it make MST configuration easier?

Kevin Dorrell

Luxembourg

New Member

Re: Need help

hi there,

I was trying the command " switchport trunk allowed vlan " but it don't work in Cisco 6509...any advise ?

166
Views
5
Helpful
19
Replies