Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Need review on My QOS config On ASR 1002 Platform

Hi ,

 

im doing QOS based on ALC based , not on NBAR.

 

i can see that  QOS is matching the traffic as i need

but im still wondering if it working fine or not

still wondering if my config is the optimal or not

=============================

anyway , let me post my config :

intrnet-----------gi0/0/0--(router ASR)---gI0/0/2-------------------LAN

my goal is to apply QOS on download side not on upload

plz note i have subinterface on 0/0/2 where i applied the QOS , not sure if that may lead to degredation ???

 

 

anyway ,

here  is my config :

Gateway-ASR1002#sh running-config 

!
!

!
!
class-map match-any VOIP
 match protocol skype
 match protocol sip
class-map match-all FACEBOOKVIDEOS
 match access-group name facebookvideos
class-map match-all DNSQOS
 match access-group name dnsqos
class-map match-all HTTP
 match access-group name browsing
class-map match-all HTTP3
 match protocol http url "*.png*"
class-map match-all YOUTUBE
 match access-group name youtube
class-map match-all HTTPS
 match protocol secure-http
class-map match-any CIR
 match access-group name CIR
class-map match-all HTTPE
 match protocol http mime "image/jpeg"
!
policy-map LLQX
 class YOUTUBE
  priority 490000
 class FACEBOOKVIDEOS
  priority 80000
 class DNSQOS
  bandwidth 5000
 class HTTPE
  bandwidth 30000
 class HTTP
  bandwidth 200000
 class HTTPS
 class VOIP
 class CIR
  priority 15000
 class class-default
  random-detect
!
!

!
!
!
!
!
!
!
!
!
!
!
!

!
interface GigabitEthernet0/0/0
 description Internet
 ip address xxxxxxxx 255.255.255.252
 load-interval 30
 negotiation auto
!
interface GigabitEthernet0/0/1
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/2
 description ASR-7600
 ip address xxxxxxx1 255.255.255.252
 load-interval 30
 negotiation auto
 service-policy output LLQX
!
interface GigabitEthernet0/0/2.99
 encapsulation dot1Q 99
 ip address xxxxxxxx 255.255.255.252
!
interface GigabitEthernet0/0/3
 no ip address
 shutdown
 negotiation auto
!

!

ip access-list extended CIR
 permit ip any host xxxxxxx

ip access-list extended browsing
 permit tcp any eq www xxxx 0.0.15.255
 permit tcp any eq www xxxx 0.0.3.255
 permit tcp any eq www xxx 0.0.7.255
ip access-list extended dnsqos

 permit ip any host xxxx
 permit ip any host xxx
 permit ip host 8xxx any
 permit ip host 8xxx any

ip access-list extended facebookvideos
  permit ip xxxx 0.0.255.255 zzzz 0.0.15.255
 permit ip xxx 0.0.255.255 zzz 0.0.3.255


ip access-list extended youtube
 permit ip xxxx 0.0.255.255 zzz 0.0.15.255
 permit ip xxx 0.0.255.255 zzzz 0.0.3.255

!
!

==========================

here is verififcation :

Gateway-ASR1002#sh policy-map interface gigabitEthernet 0/0/2
 GigabitEthernet0/0/2 

  Service-policy output: LLQX

    queue stats for all priority classes:
      Queueing
      queue limit 512 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 76021368/99525084686

    Class-map: YOUTUBE (match-all)  
      65463494 packets, 86473406803 bytes
      30 second offered rate 301312000 bps, drop rate 0000 bps
      Match: access-group name youtube
      Priority: 490000 kbps, burst bytes 12250000, b/w exceed drops: 0
      

    Class-map: FACEBOOKVIDEOS (match-all)  
      10557617 packets, 13051633484 bytes
      30 second offered rate 42420000 bps, drop rate 0000 bps
      Match: access-group name facebookvideos
      Priority: 80000 kbps, burst bytes 2000000, b/w exceed drops: 0
      

    Class-map: DNSQOS (match-all)  
      1258804 packets, 245086235 bytes
      30 second offered rate 841000 bps, drop rate 0000 bps
      Match: access-group name dnsqos
      Queueing
      queue limit 64 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 1258804/245086235
      bandwidth 5000 kbps

    Class-map: HTTPE (match-all)  
      1844480 packets, 2568851992 bytes
      30 second offered rate 10306000 bps, drop rate 0000 bps
      Match: protocol http mime "image/jpeg"
      Queueing
      queue limit 124 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 1844480/2568851992
      bandwidth 30000 kbps

    Class-map: HTTP (match-all)  
      34589083 packets, 46331789909 bytes
      30 second offered rate 163123000 bps, drop rate 0000 bps
      Match: access-group name browsing
      Queueing
      queue limit 833 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 34589083/46331789909
      bandwidth 200000 kbps

    Class-map: HTTPS (match-all)  
      1369438 packets, 1274370938 bytes
      30 second offered rate 4461000 bps
      Match: protocol secure-http

    Class-map: VOIP (match-any)  
      7229377 packets, 2364851452 bytes
      30 second offered rate 9489000 bps
      Match: protocol skype
      Match: protocol sip

    Class-map: CIR (match-any)  
      257 packets, 44399 bytes
      30 second offered rate 0000 bps, drop rate 0000 bps
      Match: access-group name CIR
      Priority: 15000 kbps, burst bytes 375000, b/w exceed drops: 0
      

    Class-map: class-default (match-any)  
      100211441 packets, 89459753423 bytes
      30 second offered rate 325118000 bps, drop rate 0000 bps
      Match: any 
      
      queue limit 4166 packets
      (queue depth/total drops/no-buffer drops) 1/0/0
      (pkts output/bytes output) 108810057/93098961087
        Exp-weight-constant: 4 (1/16)
        Mean queue depth: 2 packets
        class       Transmitted         Random drop      Tail drop          Minimum        Maximum     Mark
                pkts/bytes            pkts/bytes       pkts/bytes          thresh         thresh     prob
        
        0       108752097/93092617084      0/0              0/0               1041          2083  1/10
        1            1676/180763          0/0              0/0               1171          2083  1/10
        2              82/4468            0/0              0/0               1301          2083  1/10
        3             158/58799           0/0              0/0               1431          2083  1/10
        4               1/60              0/0              0/0               1561          2083  1/10
        5           34072/4227684         0/0              0/0               1691          2083  1/10
        6           21971/1872229         0/0              0/0               1821          2083  1/10
        7               0/0               0/0              0/0               1951          2083  1/10
Gateway-ASR1002#  

 

 

any help ??

 

i found the class CIR is not working ??!!!

i mean i could make gurantee for a specific host ??!!!

 

any help ?

90
Views
0
Helpful
0
Replies
CreatePlease login to create content