Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Need to connect Avaya Phones to Cisco 3750x

Hi.  i need to connect avaya phones to the Cisco 3750x switch. if i connect the phone on an independent port it works. but if i want to connect the ophone and dassy chained the phone with a PC , the Avaya Phone will get the ip address of the Data VLAN.

Why? --- >See the config below.

note:

- IOS version c3750e-universalk9-mz.122-55.SE5.bin

-Data VLAN 100

- Voice VLAN 200

 

....

... truncated config ...

....

switch 1 provision ws-c3750x-48p

switch 2 provision ws-c3750x-48p

switch 3 provision ws-c3750x-48p

switch 4 provision ws-c3750x-48p

switch 5 provision ws-c3750x-48p

switch 6 provision ws-c3750x-48p

switch 7 provision ws-c3750x-48p

switch 8 provision ws-c3750x-24p

system mtu routing 1500

ip routing

no ip dhcp conflict logging

ip dhcp excluded-address 192.168.27.230 192.168.27.254

ip dhcp excluded-address 192.168.28.1 192.168.28.20

ip dhcp excluded-address 192.168.28.230 192.168.28.254

ip dhcp excluded-address 192.168.27.1 192.168.27.35

ip dhcp ping packets 3

!

ip dhcp pool VOICE-VLAN200

   network 192.168.28.0 255.255.255.0

   default-router 192.168.28.1

   domain-name hq.uha.local

   option 242 ascii "MCIPADD=192.168.28.7,MCPORT=1719,HTTPSRVR=192.168.28.8"

   dns-server 172.16.6.124

   lease 3

vlan 100

name UHA-DATA_VLAN100

!

vlan 200

name UHA-VOICE-VLAN200

interface GigabitEthernet2/0/38

switchport access vlan 100

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100,200

switchport mode trunk

switchport voice vlan 200

no cdp enable

spanning-tree portfast

! note ---> if i connect a phone on port 2/0/38 it DOES NOT WORK. Phone register on vlan 100. WHY ?

!                  what configuration changes I need to performed for the Avaya phone be sense on the correct Voice VLAN 

!                  and it can work with a PC on the DATA VLAN simultaneously on port 2/0/38.  kindly advice.

!                  Note that the Data VLAN DHCP is on another router  10.172.198.126 and is working fine.

!                  Kindly advice ASAP.

!

interface GigabitEthernet2/0/39

switchport access vlan 200

switchport mode access

speed 100

duplex full

spanning-tree portfast

spanning-tree bpduguard enable

!   note  ---> if i connect a phone on port 2/039 it works. but it can only support one vlan.

....

...truncated config ...

....

interface Vlan100

description UHA-DATA_VLAN100

ip address 192.168.27.254 255.255.254.0

ip helper-address 10.172.198.126

!

interface Vlan200

description UHA-VOICE_VLAN200

ip address 192.168.28.1 255.255.255.0

4 REPLIES
Bronze

Need to connect Avaya Phones to Cisco 3750x

Hello Victor,

AVAYA phones do not use CDP to discover the voice VLAN (or if a voice VLAN is being used at all) and we have to tell them to tag the packets by using DHCP options (this is configured on the DHCP server).

We need to create a custom option.

The option 176 will have to reside in the data VLAN DHCP server as well as the voice VLAN DHCP server.

L2Q=1,L2QVLAN=XXX (XX being the voice vlan)

Note: Use option 176 for 46xx models or option 242 for 96xx models.

Haihua

New Member

Need to connect Avaya Phones to Cisco 3750x

hello Haihua

I am unclear of what i need to do. I tried this statement in diferent location and it did not worked

Can you please paste an example ASAP

thank you for your generosity

Need to connect Avaya Phones to Cisco 3750x

Victor,

You can trunk the ports that the phones connect to if you're connecting pc to phone and phone to data jack. The phone is told how to tag packets as Haihua stated above. You put the option 242 in your dhcp scope. Workstations will ignore the option, but the phone will pick it up. If you're connecting it the way I stated above, you need to put the scope in the data vlan and the voice vlan. The data vlan is configured exactly as stated above, but the voice vlan scope needs to have other options like:

MCIPADDR=x.x.x.x,MCPORT=1719,HTTPSRVR=,L2Q=1,L2QVLAN=

When the phone gets an address from the data vlan, it will get the string to tell it to move to the voice vlan. After it moves, it will pull another address and this new 242 string to tell it where to find the call server, voice vlan, http server for updates to the bin file, etc.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Bronze

Need to connect Avaya Phones to Cisco 3750x

Hello Victor,

Under the interface for data:

option 242 ascii "MCIPADD=192.168.28.7,MCPORT=1719,HTTPSRVR=192.168.28.8,L2Q=1,L2QVLAN=40"

Haihua

908
Views
0
Helpful
4
Replies