Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Net Flow Difficulty

Hi,

I'm trying to send some netflow info to Solarwinds. This is the config I applied to my router but am still not able to see the device on the netflow page. Any ideas for troubleshooting?

ip flow-export destination 172.20.8.211 9995
no ip http server
no ip http secure-server
!
logging 172.20.8.211
access-list 60 remark - Solarwinds only
access-list 60 remark - SNMP RO ACL
access-list 60 permit 172.20.8.211
access-list 60 deny   any log
cdp run
!

snmp-server community XXXXX RO 60
snmp-server location HQ

Solarwinds appears to be hitiing the router.

Standard IP access list 60

    10 permit 172.20.8.211 (31113966 matches)

    20 deny   any log

Thanks, Pat.

Everyone's tags (2)
7 REPLIES
Super Bronze

Re: Net Flow Difficulty

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

You realize NetFlow export (to a NetFlow collector) is different from a NMS doing SNMP access?  It's also different from syslog server.  Although, of course, one server might support all 3, but is your SolarWinds server configured as a NetFlow collector?  If it is, any more NetFlow configuration on your router other than NetFlow collector's IP?

New Member

Re: Net Flow Difficulty

This is my config on SolarWinds.

Edit Properties of the following selected nodes:
  • MK-1001-VPN1.pcc.int
Name:
IP Address: Type correct IP Address

SNMP

SNMP Version:SNMPv2c is used for network devices that support SNMP but where SNMPv3 is not required or supported.
SNMP Port:
Community StringxxxxxxPress down arrow to view all
Read/Write Community String:

Test Successful!

Polling

Node Status Polling:*(10-1200) seconds
Collect Statistics Every:* (1-600)
New Member

Re: Net Flow Difficulty

Yes our Solarwinds server is configured for netflow and there are devices currently sending to it. I've looked at the configs of the routers sending to netflow but, don't see any difference. Is there someting missing in my config I have pasted? To be honest, I wasn't aware that netflow was not snmp. I though it was snmp on steroids.

Thanks, Pat.

New Member

Net Flow Difficulty

Also added ip flow ingress qnd ip flow egress to tunn0 and also to the physical interface that connects to the Internet.

MK-1001-VPN1#sh run int tunn0
Building configuration...

Current configuration : 521 bytes
!
interface Tunnel0
bandwidth 2000
ip address 172.20.68.1 255.255.252.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 99
ip flow ingress
ip flow egress
ip pim sparse-dense-mode
ip nhrp authentication XXXXXXXX

ip nhrp map multicast dynamic
ip nhrp network-id 301
ip nhrp redirect
ip tcp adjust-mss 1360
ip ospf network point-to-multipoint
delay 1000
qos pre-classify
tunnel source GigabitEthernet0/0/1
tunnel mode gre multipoint
tunnel key 1000
tunnel protection ipsec profile cvo-profile
end

Purple

Net Flow Difficulty

  What kind fo cisco device is this ?

New Member

Re: Net Flow Difficulty

ASR1001

thanks

New Member

Re: Net Flow Difficulty

Do I need to supply a source interface to the config?

Thanks, Pat.

297
Views
10
Helpful
7
Replies
CreatePlease to create content