Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

NetFlow/NetQOS on a 3750x switch

Hello, I have 3750x running c3750e-universalk9-mz.122-55.SE5 layer 3 capable. Im trying to enable net flow on the switch but for some reason the flow commands dont appear to be available in config t mode. Are there some other global commands that have to be enabled first in order for the netflow commands to be available or is it  the image that doesnt support netflow?

 

Andy

1 ACCEPTED SOLUTION

Accepted Solutions

Hey Andy,The license on the

Hey Andy,

The license on the box is ipbase:

StoreIndex: 1   Feature: ipbase                            Version: 1.0
        License Type: Permanent
        License State: Active, In Use <<<<<< look here
        License Priority: Medium
        License Count: Non-Counted

So it should support netflow, however only other thing required is the network servie module, so have a look on this link for more information:

http://www.cisco.com/c/en/us/products/collateral/switches/catalyst-3750-x-series-switches/white_paper_c11-691508.html

HTH.

Regards,

RS.

6 REPLIES

Hey Andy,Regarding your

Hey Andy,

Regarding your question, Flexible NetFlow is supported only on the Catalyst 3750-X and 3560-X switch running the IP base or IP services feature set and equipped with the network services module. It is not supported on switches running the NPE or the LAN base image.

So check the running feature set with command "show license all" and change if required.

HTH.

Regards.

RS.

New Member

Thanks Rajeevsh,I ran the

Thanks Rajeevsh,

I ran the command I got the output below, i do see ipbase in there but dont know if that means its active..

Maybe it needs to have IP services as you pointed out..

Thanks for looking at this..

andy

 

inmu-tcs-inet1-sw#sh license all
License Store: Primary License Storage
StoreIndex: 0   Feature: lanbase                           Version: 1.0
        License Type: Permanent
        License State: Active, Not in Use
        License Priority: Medium
        License Count: Non-Counted

StoreIndex: 1   Feature: ipbase                            Version: 1.0
        License Type: Permanent
        License State: Active, In Use
        License Priority: Medium
        License Count: Non-Counted

License Store: Evaluation License Storage
StoreIndex: 0   Feature: ipservices                        Version: 1.0
        License Type: Evaluation
        License State: Active, Not in Use, EULA not accepted
            Evaluation total period: 8  weeks 4  days 
            Evaluation period left: 8  weeks 4  days 
        License Priority: None
        License Count: Non-Counted

 

 

I also ran it on another 3750x where netflow commands seem to work and the output is different..see below:

 

dmz-srvdist1a-sw#sh license all
License Store: Primary License Storage
StoreIndex: 0   Feature: ipbase                            Version: 1.0
        License Type: Permanent
        License State: Active, In Use
        License Priority: Medium
        License Count: Non-Counted

License Store: Evaluation License Storage
StoreIndex: 0   Feature: ipservices                        Version: 1.0
        License Type: Evaluation
        License State: Active, Not in Use, EULA not accepted
            Evaluation total period: 8  weeks 4  days 
            Evaluation period left: 8  weeks 4  days 
        License Priority: None
        License Count: Non-Counted

 

 

 

Hey Andy,The license on the

Hey Andy,

The license on the box is ipbase:

StoreIndex: 1   Feature: ipbase                            Version: 1.0
        License Type: Permanent
        License State: Active, In Use <<<<<< look here
        License Priority: Medium
        License Count: Non-Counted

So it should support netflow, however only other thing required is the network servie module, so have a look on this link for more information:

http://www.cisco.com/c/en/us/products/collateral/switches/catalyst-3750-x-series-switches/white_paper_c11-691508.html

HTH.

Regards,

RS.

New Member

Perfect Thanks for your help.

Perfect Thanks for your help..

 

Andy

Always happy to help :) 

Always happy to help :)
 

Also i checked that minimum

Also i checked that minimum IOS requirement for this service module to work is 15.(0)1SE and you are running 12.2(55)SE5 so I believe you need a hardware upgrade as well.

Regards,
RS.

69
Views
0
Helpful
6
Replies
CreatePlease to create content