Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Network Design (BGP)

Looking for a routing solution so traffic will pass over the primary MPLS circuit (ISP A) on Site A, and use the secondary MPLs circuit (ISP B) as a backup solution only)

Site A

EIGRP routing running between all switches and routers (SW1_A, SW2_A, R1_A & R2_A).

HSRP running between switches (SW1_A & SW2_A).

Should I change the metric for the BGP routes for the backup circuit on site A & B.

9 REPLIES
New Member

Re: Network Design (BGP)

Network diagram attached.

Thanks

Hall of Fame Super Blue

Re: Network Design (BGP)

Colm

1) Are you redistributing BGP into EIGRP

2) Are you redistributing EIGRP into BGP

3) Are you running IBGP between R1_A & R2_A

4) Are you running IGBP between R1_B and R2_B

If you are redistributing BGP into EIGRP then at first glance the easiest solution would be to have R2_A generate a default route into EIGRP in site A and stop R2_A redistributing BGP into EIGRP.

On R1_A continue to redistribute BGP into EIGRP.

Then under normal circumstances the more specific routes from BGP that are redistributed into EIGRP will be used and only if that link fails will the default route via R2_A be utilised.

Jon

New Member

Re: Network Design (BGP)

Jon,

1) Are you redistributing BGP into EIGRP

Yes, all BGP routes from remote sites are being redistributed into EIGRP (Site A)

2) Are you redistributing EIGRP into BGP

No, I'm using the network command under BGP, to advertise selected networks from the routing table over BGP (Site A)

3) Are you running IBGP between R1_A & R2_A

No. I cant run IBGP between R1_A & R2_A because the MPLS circuits are provided by different ISPs and therefore use different BGP AS numbers

4) Are you running IGBP between R1_B and R2_B

Same as 3.

Regards,

Colm

New Member

Re: Network Design (BGP)

i encountered the same situation a while back. what i did was to advertise the specific networks from site A and the overall summary from site b.

http://theciscotech.blogspot.com/2008/11/dual-carriers-dual-connections-and-dual.html

New Member

Re: Network Design (BGP)

Jon,

Could you explan the below with an example config. See below for current configuration for Site A.

If you are redistributing BGP into EIGRP then at first glance the easiest solution would be to have R2_A generate a default route into EIGRP in site A and stop R2_A redistributing BGP into EIGRP.

On R1_A continue to redistribute BGP into EIGRP.

Then under normal circumstances the more specific routes from BGP that are redistributed into EIGRP will be used and only if that link fails will the default route via R2_A be utilised.

###########################

Site A

### R1_A ###

interface GigabitEthernet0/0

description "LAN"

ip address 10.1.20.5 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

description "MPLS (Primary)"

ip address 89.124.200.6 255.255.255.252

router eigrp 90

redistribute bgp 70000 metric 128 50 255 100 1500

network 10.1.20.0 0.0.0.255

no auto-summary

router bgp 70000

no synchronization

bgp log-neighbor-changes

network 10.1.20.0 mask 255.255.255.0

network 10.1.21.0 mask 255.255.255.0

neighbor 89.124.200.5 remote-as 3000

no auto-summary

### R2_A ###

interface GigabitEthernet0/0

description "LAN"

ip address 10.1.20.6 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/1

description "MPLS (Backup)"

ip address 89.124.100.6 255.255.255.252

router eigrp 90

redistribute bgp 65000 metric 128 50 255 100 1500

network 10.1.20.0 0.0.0.255

no auto-summary

router bgp 65000

no synchronization

bgp log-neighbor-changes

network 10.1.20.0 mask 255.255.255.0

network 10.1.21.0 mask 255.255.255.0

neighbor 89.124.100.5 remote-as 2500

no auto-summary

### SW1_A ###

interface Vlan20

description "LAN_1"

ip address 10.1.20.2 255.255.255.0

standby 20 ip 10.1.20.1

standby 20 priority 105

standby 20 preempt

standby 20 authentication C1sc0

standby 20 track GigabitEthernet1/1

interface Vlan21

description "LAN_2"

ip address 10.1.21.2 255.255.255.0

standby 21 ip 10.1.21.1

standby 21 priority 105

standby 21 preempt

standby 21 authentication C1sc0

standby 21 track GigabitEthernet1/1

router eigrp 90

netork 10.1.20.0 0.0.0.255

netork 10.1.21.0 0.0.0.255

no auto-summary

### SW2_A ###

interface Vlan20

description "LAN_1"

ip address 10.1.20.3 255.255.255.0

standby 20 ip 10.1.20.1

standby 20 priority 105

standby 20 preempt

standby 20 authentication C1sc0

standby 20 track GigabitEthernet1/1

interface Vlan21

description "LAN_2"

ip address 10.1.21.3 255.255.255.0

standby 21 ip 10.1.21.1

standby 21 priority 105

standby 21 preempt

standby 21 authentication C1sc0

standby 21 track GigabitEthernet1/1

router eigrp 90

netork 10.1.20.0 0.0.0.255

netork 10.1.21.0 0.0.0.255

no auto-summary

Regards,

Colm

Hall of Fame Super Blue

Re: Network Design (BGP)

Colm

R2_A

ip route 0.0.0.0 0.0.0.0 89.124.100.5 (this is the ISP next-hop interface)

router eigrp 90

redistribute static

network 10.1.20.0 0.0.0.255

no auto-summary

the above config would advertise a default-route back into Site A.

There are other ways this could be done by using an EIGRP summary address but the above should work fine.

Jon

New Member

Re: Network Design (BGP)

Jon,

Let me get this straight, just a bit confused. On R2_A I only need the addition config for the static route.

Therefore: If R1_A failes all traffic will use the backup circuit (ingress/egress)

ip route 0.0.0.0 0.0.0.0 89.124.100.5

router eigrp 90

redistribute static

network 10.1.20.0 0.0.0.255

no auto-summary

router bgp 65000

no synchronization

bgp log-neighbor-changes

network 10.1.20.0 mask 255.255.255.0

network 10.1.21.0 mask 255.255.255.0

neighbor 89.124.100.5 remote-as 2500

no auto-summary

Hall of Fame Super Blue

Re: Network Design (BGP)

Colm

You will need to do the same on R2_B so that traffic coming back to site A will use the primary link under normal conditions and only use the backup link if the primary link fails.

Apart from that your config above is fine.

Jon

New Member

Re: Network Design (BGP)

Hi Jon,

Would it be possible to use iBGP between the two router in site A (R1_A and R2_B) using a Local Preference Attribute.

Is this a good idea when EIGRP redistribution is also configured on both routers.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#localpref

182
Views
0
Helpful
9
Replies