Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

'Network error: software caused connection abort' when typing into Putty

I'm having a strange problem with one of a number of 2960 switches. When I try to telnet into the switch, i'm able to connect and I get the correct prompt for the login credentials. however as soon as I try typing the login credentials, it gives the error 'Network error: software caused connection abort' and knocks me out.

Additional points:

I've checked 'line vty' commands on config and it is fine.

I don't believe it is the case of adjusting the seconds of keepalives on putty because I've also tried using telnet client from Windows cmd and have the same problem.

 

Any suggestions please?

5 REPLIES
Cisco Employee

Hi Martino,I assume that the

Hi Martino,

I assume that the VTY terminal sessions are stuck and have not cleared up. Could you post the output of the following commands?

* show user

* show tcp brief

If in case you see the VTY terminal sessions to be stuck and in IDLE state, could you issue the command clear line vty <vty_no> and attempt a TELNET once again to the box.

Also, could you configure the exec-timeout under the line vty configuration to 5 minutes so that an IDLE user will be disconnected if in case he is inactive for 5 minutes? This could be achieved as follows.

E.g:

line vty 0 5

exec-timeout 5 0

Hope this helps...

 

Regards,

Arun

 

New Member

Hi Narun,Thanks for your

Hi Narun,

Thanks for your reply. I don't have access to the switch via console today and will check the outputs you have suggested on Monday and let you know what I find. 

Access via telnet is knocking me straight off once I type the first letter of login credentials.

Cisco Employee

Hi Martino,You could reload

Hi Martino,

You could reload the box to forcefully kill all the hung telnet sessions and try once again.

New Member

Hi Narun,Nothing unusual from

Hi Narun,

Nothing unusual from the Telnet sessions. I've also tried restarting it and nothing changes. I did notice that i can't log in with aaa authentication credentials and I have to login with the local default credentials. I am able to ping the aaa server though. Any thoughts?

New Member

I am experiencing the same

I am experiencing the same issue.  Did you ever get a resolution this problem? 

3821
Views
0
Helpful
5
Replies