Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Network redistribution in OSPF

   Hi All ,

I need your help .

Switch running with two OSPF  process  100 and 200 .    interface VLAN configured  on the same switch  10.200.81.1/24 advertised under process OSPF process 100

The segment 10.200.81.0/24 which is advertised  under process 100 connected to diffrent network . 

The  requirment  is   need to advertise 2 /32  10.200.81.100 & 101 network address  in to the OSPF process 200 which is connected to again diffrent vendor

currently I am advertising remote networks  through static redistribution in OSPF porcess 200 .

here I cannot use static redistribution since  advertise newtork is belongs to the same device  ,also I cannot configure under OSPF 200  ,network statement   "network 10.200.81.0 0.0.0.255 area x."

router ospf 100

network 10.200.81.0 0.0.0.255 area 6

router ospf 200

redistribute static subnets route-map TEST

     6509-Core#sh route-map TEST

route-map TEST, permit, sequence 10
  Match clauses:
    tag 250
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes

switch (config)# ip route 10.1.84.11 255.255.255.255 10.100.11.1 tag 250

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Network redistribution in OSPF

Hello Santos,

you can consider redistributing of OSPF process 100 into OSPF process 200 using a route-map, but this can work only for existing routes and you need also to provide a return path.( may be generating a default route into process 100 if acceptable)

example:

router ospf 200

redistribute ospf 100 subnets type 1 metric 10 route-map selected

route-map selected permit 10

match ip address prefix selroutes

ip prefix-list selroutes permit 5 10.10.20.0/24

Hope to help

Giuseppe

1 REPLY
Hall of Fame Super Silver

Re: Network redistribution in OSPF

Hello Santos,

you can consider redistributing of OSPF process 100 into OSPF process 200 using a route-map, but this can work only for existing routes and you need also to provide a return path.( may be generating a default route into process 100 if acceptable)

example:

router ospf 200

redistribute ospf 100 subnets type 1 metric 10 route-map selected

route-map selected permit 10

match ip address prefix selroutes

ip prefix-list selroutes permit 5 10.10.20.0/24

Hope to help

Giuseppe

300
Views
0
Helpful
1
Replies