Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Network Teaming Configuration

Hello,

Here is a quick overview of our setup.

We have a 4 NIC Port on our NAS server which are Intel Pro 1000 PT connectors. They support teaming and vlan and some advanced features.

ALL 4 are connected to port 41,42,43 and 44 of our Cisco WS-C2960G-48TC-L

Now, when we configure the teaming on the NAS, it says whether we want to use a static link aggregation (SLA) or Dynamic which is 802.3ad

What we did is a Static Link Aggregation for now and the switch config is setup like that for the ports:

interface GigabitEthernet0/41

switchport access vlan 100

switchport mode access

speed 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet0/42

switchport access vlan 100

switchport mode access

speed 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet0/43

switchport access vlan 100

switchport mode access

speed 1000

duplex full

channel-group 1 mode on

!

interface GigabitEthernet0/44

switchport access vlan 100

switchport mode access

speed 1000

duplex full

channel-group 1 mode on

Now we ran some tests and we get about 1.6 GBPS throughput, but that should be a 4 GB aggregate link. We want to get the maximum throughput possible.

1. Are our configs exactly how they should be to have everything optimized?

2. What other Network Adapter settings in the server should be set in order for it to be perfectly setup ?

3. Anything else that you might think of that should be configured in order to have that 4 port aggregate work perfectly ?

Really appreciate the help

Thanks

8 REPLIES
Hall of Fame Super Blue

Re: Network Teaming Configuration

Depends on the load-balancing method used. The 2960 is not included in the attached link but you could try this command

2960(config)# port-channel load-balance ?

and you will see the options. Bear in mind that etherchannel on the Cisco switch will always use the same link for the same src or dst mac (depends on which method youy have chosen). Basically you need to work out which load-balancing type will give you the most variation in source and destination.

If the 2960 follows the 2955 then you are limited to mac-address only, whereas other switches can use src/dst IP as well and the 6500 or example can use all these plus src/dst ports.

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml#cat2950_3550

Jon

New Member

Re: Network Teaming Configuration

Hello,

Thanks, but we do not want to Load Balance, basically we have other servers which communicate to the NAS on a 1 GBPS link they have. We want that when those machines transfer data to the NAS, that the 4 ports act as one big port of 4 GBPS... possible? If so, what are the settings to put on the switch and server for the NIC's...

Hall of Fame Super Blue

Re: Network Teaming Configuration

But that's exactly what etherchannel does on a Cisco switch ie. it uses all the physical links within the bundle and it uses load-balancing across those links so it utilises all links within the bundle.

Maybe i am not understanding your question.

Jon

New Member

Re: Network Teaming Configuration

Basically I am just wondering with the setup we provided in the first post, if there is anything else we should do on the cisco or server to make sure this is a perfect team of 4 X 1 GBPS network cards, since as I said when we tested multiple writes, it always gets to about 1.6 GBPS and not higher, unless something else is limiting it (os, disks etc...) but as far as the disks goes, we carefully chose our hardware so that it would easily take 3 GBPS speeds...

Please let me know

New Member

Re: Network Teaming Configuration

Anything on this please?

Hall of Fame Super Blue

Re: Network Teaming Configuration

Please read what i wrote about load-balancing. You may not want to load-balance but that is what etherchannel does and there is no way round this. You need to choose whether load-balancing on src or dst mac will give you a greater variety. The more different src or dst mac's the better.

If you find that the only way to get that range is on src and dst IP then you need a different switch.

Note - this is assuming the 2960 only load-balances on src/dst mac. See previous post as to how to find out.

Jon

New Member

Re: Network Teaming Configuration

ok so if basically, we have a bunch of servers who all process and write the data on the NAS, then it is better to load balance on SOURCE MAC right? so that packets coming from different sources (the servers) will take different paths... is that correct?? or am I missing something...

Hall of Fame Super Blue

Re: Network Teaming Configuration

That is correct.

394
Views
0
Helpful
8
Replies