Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

New thread on Cisco VRF route leak

The purpose of this thread is to seek clarifications. The previous thread posted was too long and difficult to understand. So I thought I made the problem even simpler for understanding.

Following is how the switch, Sw1 is connected to the Core Sw.

Sw1 ----- Core Sw

Following contains the configuration :

** Sw1 **

ip classless

interface GigabitEthernet1/0/14

description TestVRF1

no switchport

ip address 192.168.1.1 255.255.255.0

end

ip route 192.168.3.0 255.255.255.0 192.168.1.2

Core sw

ip vrf clientA

rd 100:110

route-target export 100:110

route-target import 100:110

interface GigabitEthernet1/0/2

description 192.168.1.2

no switchport

ip vrf forwarding clientA

ip address 192.168.1.2 255.255.255.0

no cdp enable

end

ip route 192.168.1.0 255.255.255.0 GigabitEthernet1/0/2

ip route vrf clientA 192.168.3.0 255.255.255.0 lo1 192.168.3.1

What I do not understand is why I can't ping 192.168.3.1 from Sw1. Help appreciated.

  • LAN Switching and Routing
4 REPLIES
Cisco Employee

Re: New thread on Cisco VRF route leak

Try "ip route vrf clientA 192.168.3.1 255.255.255.255 lo1" instead. It works for me.

Regards

New Member

Re: New thread on Cisco VRF route leak

Curious,when I tried the proposed solution:

ip route vrf clientA 192.168.3.1 255.255.255.255 lo1

I got this error message:

% For VPN routes, must specify a next hop IP address if not a point-to-point interface

Does a Cisco 3750 have anything to do the error?

Anyway, I tried another way which also did not work:

ip route vrf clientA 192.168.3.0 255.255.255.0 Loopback1 192.168.3.1

Any clue?

Cisco Employee

Re: New thread on Cisco VRF route leak

Alan,

My mistake. This is indeed the normal behavior. I had run my test using an IOS image of mine that didn't have this restriction.

Given this restriction, you will not be able to ping the loopback residing in the global. May I ask what it is that you are trying to achieve with that test?

Regards

New Member

Re: New thread on Cisco VRF route leak

This was a simple set up to test the behaviour of VRF. In the actual set up, the loopback interface will not be there, rather, it will be a physcial interface. And what I was planning to achieve was to be assured that I easily diagnose issues with just ping test alone. However, it seems that the global interfaces cannot be ping-ed from the VRF zone. Which may make my diagnostic job a little tougher.

406
Views
5
Helpful
4
Replies
This widget could not be displayed.