Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

New to VLAN Tagging

Hello,

I have a CISCO 3750E. All of the ports are currently configured as access ports so there is no tagging.

We are trying to configure the fiber port to connect to an extreme network switch which uses vlan tagging.

Their tag id is 96. How do I configure our switch to accept vlan tagging? I am new to tagging so I am kind of lost.

Here is our config right now. Also I have never configured a fiber port on cisco switch so I am assuming i need to configure

gigabitethernet1/1/1?

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

vlan internal allocation policy ascending

!

ip ssh time-out 90

!

!

interface FastEthernet0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

!

interface GigabitEthernet1/0/1

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/2

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/3

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/4

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/5

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/6

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/7

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/8

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/9

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/10

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/11

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/12

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/13

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/14

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/15

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/16

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/17

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/18

switchport access vlan 46

switchport mode access

!

interface GigabitEthernet1/0/19

switchport access vlan 55

switchport mode access

!

interface GigabitEthernet1/0/20

switchport access vlan 60

switchport mode access

!

interface GigabitEthernet1/0/21

switchport access vlan 46

switchport mode access

!

interface GigabitEthernet1/0/22

switchport access vlan 46

switchport mode access

!

interface GigabitEthernet1/0/23

switchport access vlan 60

switchport mode access

!

interface GigabitEthernet1/0/24

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/1/1

!

interface GigabitEthernet1/1/2

!

interface GigabitEthernet1/1/3

!

interface GigabitEthernet1/1/4

!

interface TenGigabitEthernet1/1/1

!

interface TenGigabitEthernet1/1/2

!

interface Vlan1

no ip address

!

interface Vlan46

ip address 192.168.24.254 255.255.255.0

!

interface Vlan55

ip address 192.168.59.254 255.255.255.0

!

interface Vlan60

ip address 192.168.40.254 255.255.255.0

!

interface Vlan95

ip address 192.168.99.230 255.255.255.0

!

interface Vlan100

ip address 192.168.101.197 255.255.255.0

!

  • LAN Switching and Routing
6 REPLIES
Hall of Fame Super Bronze

New to VLAN Tagging

Tagging is done when multiple Vlans are being sent via the physical link. If the extreme switch is only sending one Vlan (Vlan 96) and this is a native Vlan, you can leave you access ports are they are.

If they are sending multiple Vlans, you need to configure trunk in your switchport facing the extreme switch and configure Vlan 96 in your Vlan Database.

New Member

New to VLAN Tagging

There vlan has a tag of 96 and no ip address set on it.

It is just configured for 3 ports to run over the fiber link to the cisco switch.

Here is how I would think it should be configured but i am not sure.

interface GigabitEthernet1/1/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 96

switchport mode trunk

!

The 3 ports on the extreme switch will be connected to 3 linux workstations that right now are on my vlan 55 as noted in the configuration above.

New Member

New to VLAN Tagging

also if they take the tag off and it is just connected to the access port it works fine but they want to keep their vlan tags.

thanks

Re: New to VLAN Tagging

Hi,

so the Extreme switch is sending frames tagged as VLAN96 from its access port?

And it also requires you to send the frames tagged for that VLAN?

In that case, IMHO you need to configure a trunk on your side the way you showed above.

But remove the

switchport trunk native vlan 96

command, as it would cause your switch to send the VLAN96 frames untagged to the Extreme switch and it might not accept them.

(Or you could try vlan dot1q tag native global configuration command to enable tagging of native VLAN frames.

But that would change ALL your trunks.)

I'd also recommend switchport nonegotiate  command on your side, as the Extreme switch does not support DTP probably.

You also need to configure VLAN96 on your switch and put your devices to it if they need to communicate via L2 with the devices connected to VLAN96 on the Extreme switch.

Another issue might be STP:

As you are using Cisco PVTSP it might not be compatible with Extreme STP implementation.

So if you are connected via multiple ports (from different Cisco switches especially) to the Extreme switch, you might create an STP loop possibly.

Best regards,

Milan

New Member

Re: New to VLAN Tagging

Hello,

So would i need to remove any devices off of vlan 55 to vlan 96 in order to talk to those?

Re: New to VLAN Tagging

Hi,

yes, that's my understanding.

Otherwise you would need to use different IP subnets in VLANs 55 and 96 and configure routing somewhere.

Another possibility would be interconnecting VLAN 55 and VLAN96 by access (untagged) ports somewhere but that might be quite confusing.

Best regards,

Milan

322
Views
0
Helpful
6
Replies
This widget could not be displayed.