Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Newbe on OSPF

Hi,

I am trying to configure ospf on the network. I have collapsed core design, users are connected to the 4500 switch and servers are connected to 3750 switches. 4500 switch is connected to the two 6500 switch via Layer3 and 3750 switches are connected via Layer2. I have also 10 different VLANs configured on the network. here is my configuration:

4500 Switch L3 config:

Int gig1/0/20

no switchport

ip address 10.1.1.2 255.255.255.252

no shut

ip route 0.0.0.0 0.0.0.0 gig1/0/20

6500 Switch Config:

Int gig1/0/20

no switchport

ip address 10.1.1.1 255.255.255.252

no shut

ip route 0.0.0.0 0.0.0.0 gig1/0/20

int vlan 800

Ip address 10.1.80.1 255.255.255.0

int vlan 700

ip address 10.1.70.1 255.255.255.0

int vlan 600

ip address 10.1.60.1 255.255.255.0

!

!

So if I want to configure OSPF routing protocol, what is the best way to configure OSPF on the network. Do I still need to configure static route on L3 interface between 4500 to 6500? Your expert opinion will help.

Thanks

1 REPLY
Hall of Fame Super Blue

Re: Newbe on OSPF

You wouldn't need the static routes if you are merely concerned with routing between the 6500's, 4500's and 3750's.

So on your 4500

router ospf 10

network 10.1.1.2 0.0.0.0 area 0

on your 6500

router ospf 10

network 10.1.1.1 0.0.0.0 area 0

network 10.1.80.0 0.0.0.255 area 0

network 10.1.70.0 0.0.0.255 area 0

network 10.1.60.0 0.0.0.255 area 0

you can then remove the default routes BUT

the above config only covers what you have shown in your post. If your 6500 or 4500 or both have additional subnets you need to include these in your OSPF configuration or you will lose connectivity to these subnets.

Also not sure why you have default-route on 6500 pointing to 4500 as well as on 4500 pointing to 6500 - this could cause routing loop.

Jon

261
Views
0
Helpful
1
Replies