Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 3048 port-channel to 3750G issues.

I am trying to bring up a trunk between a 3750G stack and (2) Nexus 3048. The uplinks on the 3048's are using 1gig MM SFP. The ports on the 3750 stack are configured as a port channel. I have checked the SFPs, they are valid. I had swapped out fiber patch cables, SFPs. I have included the configurations below, so any help is appreciated!

Configuration on the 3750 stack:

!

interface GigabitEthernet4/0/7

description ***To C1R2NX3048-1***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,255

switchport mode trunk

channel-group 11 mode active

end

!

interface GigabitEthernet5/0/7

description ***To C1R2NX3048-2***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,255

switchport mode trunk

channel-group 11 mode active

end

!

interface Port-channel11

description *** To C1C2NX3048***

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,255

switchport mode trunk

end

Nexus #1 Configuration:

interface Ethernet1/49

  description TO-C1R2CS3750-1

  switchport mode trunk

  switchport trunk allowed vlan 1,255

  speed 1000

  channel-group 101 mode active

!

interface port-channel101

  description L2-TO-WLS1C1R1CS3750-2

  switchport mode trunk

  vpc 101

  switchport trunk allowed vlan 1,255

  spanning-tree port type normal

  speed 1000

port-channel101 is down (No operational members)

vPC Status: Down, vPC number: 101

  Hardware: Port-Channel, address: 0000.0000.0000 (bia 0000.0000.0000)

  Description: TO-C1R1CS3750-2

  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  auto-duplex, auto-speed

  Beacon is turned off

  Input flow-control is off, output flow-control is off

  Switchport monitor is off

  EtherType is 0x8100

  Members in this channel: Eth1/49

  Last clearing of "show interface" counters never

  30 seconds input rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  30 seconds output rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

  RX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 input packets  0 bytes

Ethernet1/49 is down (Link not connected)

  Hardware: 1000/10000 Ethernet, address: c08c.603d.4f98 (bia c08c.603d.4f98)

  Description: TO-C1R2CS3750-1

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  auto-duplex, 1000 Mb/s, media type is 1G

  Beacon is turned off

  Input flow-control is off, output flow-control is off

  Rate mode is dedicated

  Switchport monitor is off

  EtherType is 0x8100

  Last link flapped never

  Last clearing of "show interface" counters 22:13:17

  30 seconds input rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  30 seconds output rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

  RX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 input packets  0 bytes

Nexus #2 Configuration

interface Ethernet1/49

  description TO-C1R2CS3750-1

  switchport mode trunk

  switchport trunk allowed vlan 1,255

  speed 1000

  channel-group 101 mode active

interface port-channel101

  description TO-C1R1CS3750-2

  switchport mode trunk

  vpc 101

  switchport trunk allowed vlan 1,255

  speed 1000

Ethernet1/49 is down (Link not connected)

  Hardware: 1000/10000 Ethernet, address: c08c.603d.51d8 (bia c08c.603d.51d8)

  DescriptionTO C1R2CS3750-1

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  auto-duplex, 1000 Mb/s, media type is 1G

  Beacon is turned off

  Input flow-control is off, output flow-control is off

  Rate mode is dedicated

  Switchport monitor is off

  EtherType is 0x8100

  Last link flapped never

  Last clearing of "show interface" counters 02:31:20

  30 seconds input rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  30 seconds output rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

  RX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 input packets  0 bytes

    0 jumbo packets  0 storm suppression packets

    0 giants  0 input error  0 short frame  0 overrun   0 underrun

    0 watchdog  0 if down drop

    0 input with dribble  0 input discard(includes ACL drops)

    0 Rx pause

  TX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 output packets  0 bytes

    0 jumbo packets

    0 output errors  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble

    0 Tx pause

  0 interface resets

port-channel101 is down (No operational members)

vPC Status: Down, vPC number: 101

  Hardware: Port-Channel, address: 0000.0000.0000 (bia 0000.0000.0000)

  Description: TO-C1R1CS3750-2

  MTU 1500 bytes, BW 100000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is trunk

  auto-duplex, auto-speed

  Beacon is turned off

  Input flow-control is off, output flow-control is off

  Switchport monitor is off

  EtherType is 0x8100

  Members in this channel: Eth1/49

  Last clearing of "show interface" counters never

  30 seconds input rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  30 seconds output rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

  RX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 input packets  0 bytes

    0 jumbo packets  0 storm suppression packets

    0 giants  0 input error  0 short frame  0 overrun   0 underrun

    0 watchdog  0 if down drop

    0 input with dribble  0 input discard(includes ACL drops)

    0 Rx pause

  TX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 output packets  0 bytes

    0 jumbo packets

    0 output errors  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble

    0 Tx pause

  0 interface resets

Everyone's tags (6)
5 REPLIES

Nexus 3048 port-channel to 3750G issues.

Hello Dan.

- What if you remove the configuration, are the interface coming up as individuals?

- What if you try to loop the fiber cables, for example plug the fiber from the interface 4/0/7 to the 5/0/7 in the same stack, is the interface coming up? try the same test in the 3k.

Can you put in a notepad the output of the following commands and attach it.

- Show log (both switches)

- Show interface status err-disable. (both switches)

- Show inventory (both switches)

- Show version.

Regards.

Wilson B.

New Member

Re: Nexus 3048 port-channel to 3750G issues.

Hi Wilson-

Thanks for the reply. To answer your questions:

- If i remove all of the configuration, they do NOT come up. All interfaces still show as not connected.

- I can loop the fiber cables and get lights. I looped the two nexus switches on eth1/49 on both switches successfully, and 4/0/7 to 5/0/7 successfully.

Attached is the output that you were looking for. Thanks again!

Nexus 3048 port-channel to 3750G issues.

Hi Dan.

Thank you for the ouputs, I checked the show inventory, it doesn't populate the transceivers number, only the serial number, and when I search for the transceiver serial number it doesn't show up with any result. So are those cisco transceivers? ...

can you share the transceiver part number!

Regards.

Wilson B

New Member

Nexus 3048 port-channel to 3750G issues.

Wilson-

I noticed that as well when I sent this to you. I am going to reboot that switch tonight, because there are all Cisco transceivers in it, and there are some other funny things going on.

I found the issue with this. On the 3750G ports, I had to set 'speed nonegotiate' on the trunks going to the 3k's.

Thank you for the help!

New Member

Nexus 3048 port-channel to 3750G issues.

Dear Dan,

The Same Issue I am facing with my Nexus Switch and 3750 Core Switch, Can u Pls Guide me How to Fix this issue?

CDP Neighbour shows the device, but not pinging.

Thanks,

Tamizh

1563
Views
0
Helpful
5
Replies
CreatePlease login to create content