Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 3064 strange behaviour

Hello chaps,

I've been strugling for last two days with something really strange. I have Nexus3064 installed with two SFPs (GLC-SX). These are connected via 2m patch cable to vmware machine and physically terminated on Solarflare adapter.

The issue is that these links are reported "down" by nexus, where the Vmware reports them as "connected". If I go to the switch and shutdown both ports - VMware immediatelly reacts with "link failure" message.. (I've never managed to transfer even a single bit of data thru any of these links)

Here is some output from Nexus:

switch# show int br

Eth1/2        45     eth  access down    Link not connected         1000(D) --

Eth1/3        100    eth  access down    Link not connected         1000(D) --

switch# show int eth 1/3 capabilities

Ethernet1/3

  Model:                 N3K-C3064PQ-SUP

  Type (SFP capable):    1000base-SX

  Speed:                 100,1000,10000

  Duplex:                full

  Trunk encap. type:     802.1Q

  Channel:               yes

  Broadcast suppression: percentage(0-100)

  Flowcontrol:           rx-(off/on),tx-(off/on)

  Rate mode:             none

  QOS scheduling:        rx-(6q1t),tx-(1p6q0t)

  CoS rewrite:           no

  ToS rewrite:           no

  SPAN:                  yes

  UDLD:                  yes

  Link Debounce:         yes

  Link Debounce Time:    yes

  MDIX:                  no

  Pvlan Trunk capable:   no

  TDR capable:           no

  Port mode:             Routed,Switched

  POE capable:           no

switch# show int eth 1/3 transceiver

Ethernet1/3

    transceiver is present

    type is 1000base-SX

    name is CISCO-FINISAR

    part number is FTLF8519P2BCL-CS

    revision is 0000

    serial number is FNS11010A5W

    nominal bitrate is 1300 MBit/sec

    Link length supported for 50/125um fiber is 550 m

    Link length supported for 62.5/125um fiber is 270 m

    cisco id is --

    cisco extended id number is 4

switch# show run int eth 1/3

interface Ethernet1/3

  description server 2

  switchport access vlan 100

  speed 1000

  duplex full

switch# show int eth 1/3

Ethernet1/3 is down (Link not connected)

  Hardware: 100/1000/10000 Ethernet, address: 0005.73fb.802a (bia 0005.73fb.802a)

  Description: server 2

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA

  Port mode is access

  full-duplex, 1000 Mb/s, media type is 1G

  Beacon is turned off

  Input flow-control is off, output flow-control is off

  Rate mode is dedicated

  Switchport monitor is off

  EtherType is 0x8100

  Last link flapped never

  Last clearing of "show interface" counters 00:22:56

  30 seconds input rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  30 seconds output rate 0 bits/sec, 0 bytes/sec, 0 packets/sec

  Load-Interval #2: 5 minute (300 seconds)

    input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

  RX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 input packets  0 bytes

    0 jumbo packets  0 storm suppression packets

    0 giants  0 input error  0 short frame  0 overrun   0 underrun

    0 watchdog  0 if down drop

    0 input with dribble  0 input discard(includes ACL drops)

    0 Rx pause

  TX

    0 unicast packets  0 multicast packets  0 broadcast packets

    0 output packets  0 bytes

    0 jumbo packets

    0 output errors  0 collision  0 deferred  0 late collision

    0 lost carrier  0 no carrier  0 babble

    0 Tx pause

  0 interface resets

switch# show vlan id 100

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

100  DMZ-100                          active    Eth1/1, Eth1/3

There is nothing in system log. Furthermore, according to the syslog that interface (eth1/3) has never been UP. I tried to physically plug/unplug the SFPs (because I've read somewhere that this might cause some troubles) but nothing helped..

Unfortunatelly - there is no longer 'no keepalive' command on nexus, which could help me to bring the interface up.. Does anyone know how can I tell to nexus not to relay on NLP/FLP in order to bring the interface up? :s

Any thoughts are more than welcome!

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Nexus 3064 strange behaviour

Hi,

Are these 3rd party SFPs or you order them through Cisco?

Cisco devices don't always work with 3rd party optics.

HTH

4 REPLIES
VIP Super Bronze

Nexus 3064 strange behaviour

Hi,

Are these 3rd party SFPs or you order them through Cisco?

Cisco devices don't always work with 3rd party optics.

HTH

New Member

Re: Nexus 3064 strange behaviour

Hey matey & Thanks for the response.

I don't know what i've done, but I somehow accepted your answer as correct although I wanted to simlpy reply on that :-))

These SFPs, I am not sure 100% on that, but I believe they are original from Cisco (I am not using 'service unsupported-transreceiver' on that switch)

VIP Super Bronze

Nexus 3064 strange behaviour

Hi,

The reason I asked about the SFP compatibility is that I see this:

cisco id is --

There is usually a number associated with the this ID.

Can you try a  different SFP.

Also, just in case, can you hard set the port to Gig full duplex and test again?

HTH

New Member

Re: Nexus 3064 strange behaviour

Hello Reza,

yes, I can confirm that the SFPs are Cisco original. Today I physically unpluged & checked it myself. Furthermore, I've connected both links on the nexus (1/2 & 1/3) to each other (looping) and both went up - which means that everything is OK with SFPs & Fibre patch cord. I've tried a few times to set ports to different combinations of speed & duplex, shut/unshut, switch reload - nothing helped :-(

877
Views
0
Helpful
4
Replies
CreatePlease login to create content