Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Nexus 3548 to 3925E Design Question

Best practice connecting 2 of the 1GB ports on 3925E to Nexus 3548 pair at the top of the rack.  We currently have vPC's for each VLAN on the 3548 handling VLAN routing.  We only have the one router (3925E) which acts as our MPLS WAN router and are looking to connect gi0/1 to 3548-A and gi0/2 to 3548-B so that if one switch goes down we will have the redundancy.  Would creating a channel-group for gi0/1 & gi0/2 provide this solution? 

 

Thanks,
Jim

 

Everyone's tags (1)
9 REPLIES
New Member

Hi Jim, Do you have SVIs on

Hi Jim,

 

Do you have SVIs on the Nexus 3548 to handle the inter-vlan routing?  What routing protocol are you using between the Nexus and 3925?

 

Alan

New Member

Hi Alan, Yes we have SVI's

Hi Alan,

 

Yes we have SVI's for each VLAN on each switch.  For example:

3548-A:

interface vlan7
ip address 172.16.7.2/24
hsrp ver 2
hsrp 7
  preempt
  priority 120
  ip 172.16.7.1

 

3548-B

interface vlan7
ip address 172.16.7.3/24
hsrp ver 2
hsrp 7
  preempt
 priority 120
 ip 172.16.7.1

 

We want to be able to run OSPF between the two since we run that protocol over the WAN now.

thanks much

VIP Super Bronze

ok, in this case, you can

ok, in this case, you can simply make the connection between the 3548s a layer-3 routed link with a /30 without any SVI, vlan and HSRP.  You also add to more /30 connecting each 3548 to 3925E. It will all be routed links with /30s and no vlans.  You can run OSPF between all 3 devices.

HTH
 

New Member

Reza, In doing so, do I keep

Reza,

 

In doing so, do I keep the port-channel on the 3925 and changing it's IP to a /30? 

VIP Super Bronze

No, In this case you no

No, In this case you no longer need the Portchannel. Just regular interfaces on all the devices with IPs.  OSPF will take care of the redundancy.  If one link from the 3925E to one 3548 fails, you have a second connection to the other 3548.

HTH

New Member

That's what I thought so

That's what I thought so pardon this elementary question:  I'll be creating 2 /30 subnets to participate in OSPF as such?

 

3925:

Interface gi0/1
description to 3548-A eth1/24
ip address 192.168.2.1 255.255.255.252

Interface gi0/2
description to 3548-B eth1/24
ip address 192.168.3.1 255.255.255.252
 

3548-A:

Interface  eth1/24
desc to 3925 gi0/1
ip address 192.168.2.2 255.255.255.252

3548-B

Interface eth1/24
desc to 3925 gi0/2
ip address 192.168.3.2 255.255.255.252

Thanks much!
 

 

 

VIP Super Bronze

Yes, these are correct.

Yes, these are correct.

VIP Super Bronze

Yes, the 3900 series support

Yes, the 3900 series support Portchannels, so you can connect both 3548s to the 3945E and give the Portchannel an IP address on each side (Layer-3).

HTH

New Member

Hi Reza/Alan,In the 3925 we

Hi Reza/Alan,

In the 3925 we are using port-channel 2.109 as such:

Interface port-channel 2.109
encapsulation dot1q 109
ip address 192.168.1.2 255.255.255.224
end

3548-A
interface VLAN 109
ip address 192.168.1.3/27
ip ospf cost 2
ip route ospf 1 area 0.0.0.0

3548-B
interface VLAN 109
ip address VLAN 109
ip address 192.168.1.4/27
ip ospf cost 3
ip ospf priority 2
ip router ospf 1 area 0.0.0.0

Once this config was deployed, the VLAN's on the 3548's would be accessible for a time from behind the 3925E then not then accessible again.  Very frustrating. I was hoping to achieve a measure of load balancing as opposed to just OSPF priorities if that makes sense.

thanks

79
Views
0
Helpful
9
Replies