Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Nexus 3548 : vlan is not allowed on peer-link

Hi, I had posted earlier but I think I have almost figured out the issue.. just not how to resolve it. I have two nexus switches connected together with PO5. Each nexus has a PO6 to connect to a single Cat3750 VLAN 46 on one of the switches is showing %ETHPORT-3-IF_ERROR_VLANS_SUSPENDED: VLANs 46 on Interface port-channel6 are being suspended. (Reason: Vlan is not allowed on Peer-link) Oddly the other switch seems to ok with VLAN 46. I also see this show vpc consistency-parameters vpc 6 ... Local Remote. Allowed VLANs - 1,31,34,46,200,600-605 1,31,34,46,200,600-605 Local suspended VLANs - 46 - I just dont get it. Both switches are almost identical in their running configs. Any thoughts?
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Super Bronze

Glad to know it is working.

Glad to know it is working. Some times resting the vlan, interface or po interface does the job.

HTH

6 REPLIES
VIP Super Bronze

Hi,Can you post the config

Hi,

Can you post the config from both switches including the VPC peer link config?

also config from the 3750.

 

New Member

well the funny thing about

well the funny thing about the nexus configs is that I compared them in notepad ++ and they are the same.


vrf context management
  ip route 0.0.0.0/0 10.31.0.9
vlan 1
vlan 31
  name VLAN0031-VOIP
vlan 34
  name vlan_nutanix
vlan 46
  name VLAN0046-MITEL
vlan 200
  name VLAN0200-ExchDAG
vlan 600
  name VLAN0600-VMOTION
vlan 601
  name VLAN0601-DMZ1
vlan 602
  name VLAN0602-DMZ2
vlan 603
  name VLAN0603-DMZ3
vlan 604
  name VLAN0604-DMZ4
vlan 605
  name VLAN0605-PNET
vpc domain 1
  role priority 110
  peer-keepalive destination 10.31.61.11 source 10.31.61.12
  auto-recovery

interface port-channel5
  switchport mode trunk
  spanning-tree port type network
  speed 10000
  vpc peer-link

interface port-channel6
  switchport mode trunk
  spanning-tree port type normal
  speed 1000
  vpc 6

interface port-channel11
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  speed 10000
  vpc 11

interface port-channel12
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  speed 10000
  vpc 12

interface port-channel13
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  speed 10000
  vpc 13

interface port-channel14
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  speed 10000
  vpc 14

interface port-channel15
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  speed 10000
  vpc 15

interface Ethernet1/1
  switchport mode trunk
  speed 1000
  channel-group 6 mode active

interface Ethernet1/2
  switchport mode trunk
  speed 1000
  channel-group 6 mode active

interface Ethernet1/3
  description Nutanix
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  channel-group 11

interface Ethernet1/4
  description Nutanix
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge
  channel-group 12

interface Ethernet1/5
  description Nutanix
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge
  channel-group 13

interface Ethernet1/6
  description Nutanix
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge
  channel-group 14

interface Ethernet1/7
  description Nutanix
  switchport mode trunk
  switchport trunk allowed vlan 1,31,34,46,200,600-605
  spanning-tree port type edge trunk
  channel-group 15

interface Ethernet1/47
  switchport mode trunk
  channel-group 5 mode active

interface Ethernet1/48
  switchport mode trunk
  channel-group 5 mode active

 

 

+++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

3750 confing

 

interface Port-channel6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!

!
interface GigabitEthernet1/0/33
 description ch nexus1-1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/34
 description ch nexus1-2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/35
 description ch nexus2-1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!
interface GigabitEthernet1/0/36
 description ch nexus2-2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 6 mode active
!

!
interface Vlan46
 ip address 172.17.16.1 255.255.255.0

 


 

VIP Super Bronze

The config looks good.Can you

The config looks good.

Can you try shut and no shut po6?

Also, does "sh int trunk" show all vlans being on vpc peer link (po5)?

HTH
 

New Member

Well sho int trunk does show

Well sho int trunk does show all vlans being on po5 on both switches (vlan 1-4094)

On switch 2 it still shows Vlan 46 as being err disabled (see below)

Cant really do an shut/noshut on PO6 without a maintenance window :( I will see what I can do)

I did (desparately) try a status active and a no shut on vlan 46

 

Port          Vlans Err-disabled on Trunk
-----------------------------------------------------
Eth1/1        46
Eth1/2        46

Po5           none
Po6           46

New Member

So I couldnt shut/noshut PO6

So I couldnt shut/noshut PO6 but I could do it to vlan 46. Guess what.. it worked.

VIP Super Bronze

Glad to know it is working.

Glad to know it is working. Some times resting the vlan, interface or po interface does the job.

HTH

1378
Views
0
Helpful
6
Replies