Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Community will be in read-only mode on 12/14/2017 from 12:00 am pacific to 11:30 am.

During this time you will only be able to see content. Other interactions such as posting, replying to questions, or marking content as helpful will be disabled for few hours.

We apologize for the inconvenience while we perform important updates to the Community.

New Member

Nexus 5548UP connectivity with Cisco router 2811.

               In the existing network we have Cisco 2811 router connected to Corporate MPLS cloud. Cisco 2811 is connected to Catalyst 6509 switch(set based IOS with MSFC card). Along with that we have two Catalyst 5509. We are upgrading the access layer by replacing catalyst switches with Nexus 5548 & 2248.

For a purpose of testing I have connected 5548 & 2248. Created cPC and ether channels between two. SVI and HSRP configuredon 5548. I am terminating 2651 (test router) on 2248 port 101/1/1. On 5548 I have enabled EIGRP on vlans. I am unable to ping to 2651 from nexus switch 5548 and vice-versa.

I can see both devices on CDP but I do not see eigrp neighborship formed.

What configuration should go in 2248 and 2651 in order to establish a connection between two? If test is successful then I will connect 2811 to 2248 during actual migration. I assume that in testing if it works for 2651 then it must work on 2811 router.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

I think there is a design issue here.

If you want to peer your N5K with your 2600 and 2800 routers, the best way is to do L3 ECMP instead of using a VLAN through vPC.

Regards,

jerry

Hall of Fame Super Gold

Nexus 5548UP connectivity with Cisco router 2811.

You got your HWIC-1GE-SFP and GLC-T already???

And you've connected the 2K to the GLC-T?

67 REPLIES
Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

I think there is a design issue here.

If you want to peer your N5K with your 2600 and 2800 routers, the best way is to do L3 ECMP instead of using a VLAN through vPC.

Regards,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

How should I do that? Can you describe in details or provide the link?

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Earlier I had configured switch port e 101/1/1 only on one 5548 switch. After configuring on same configuration on 2nd 5548 the interface came up and now it is showing in eigrp neighborship.

At this moment in test environment switches connected as below:

N5K ==== N5K

  |                  |

  |                  |

N2K          N2k

We have existing production network with 6509 switch. We are going to remove that upgrade with 5548.

We have 2 5548 and 4 2248 each are interconnected with 10G-FET fiber module.

Cable from router 2811 will be connected to the e 101/1/1 on 2248.

What is the other way to connect 2811 router to 5548/2248 switches?

5548 does not have ethernet port that accepts copper cable. So I terminated on 2248.

Jerry >> Is it a bad solution? What is the better solution?

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

The recommended method is to use L3 point-to-point link on the N5500 toward to the 2811 (both Ethernet interface, I think this actually require 1GE because the interface on the C2800, the Nexus 5500 doesn't support 100MB).

Please see the following link on why your design is not recommended (also figure 16):

http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9670/guide_c07-673997.html#wp9000346

The recommended design is in figure 17 in the above link.

If you can't do the recommended method, the other way to do it to use regular spanning-tree instead of vPC.

Regards,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jeye,

Thanks for update. I know design is not as per Cisco recommendation. But we have to work on devices that are available to us.

Is there any way I can connect Cisco 2811 Fast Etherport to Nexus 5548?

Thanks

Ashok Basapure

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

Yes, you can connect the 2811 to the FEX and make sure you are NOT configure any vPC in this set up:

N5K==N5K

||          ||

FEX     FEX

      \    /

     2811

Regards,

jerry

New Member

Re: Nexus 5548UP connectivity with Cisco router 2811.

Jeye,

Thanks. I have configured vPC between N5k and N5K and also in between N5K and N2k. I have only one 2811 so i will be connecting Cisco 2811 fa0/0 to 2248 e 101/1/1. You said not to configure vPC. Is that between 2811 & 2248 Or in between N5K/N5K and N5K/N2K.

I am attaching configuration pertaining to N5K and N2k.

I have not clearly understood "make sure you are NOT configure any vPC"

Thanks

Ashok

Cisco Employee

Re: Nexus 5548UP connectivity with Cisco router 2811.

I mean you should not run vPC at all in the Nexus 5548s.

Regards,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jeye,

Thanks.

In test environment I connected Cisco 2651 router to 2248UP. As per my earlier attachment I have configured vPC between N5K & N5K and between N5K & N2K. I configured DHCP on Cisco 2651 and connected my machine to one of the port on N2K. My machine got the IP from DHCP (router). So my understanding was that when we connect N5K/N2K in production then it should work with vPC.

So you want me to disable the vPC feature and remove the vPC between N5K/N5K & N5K/N2K.

Can you please modify my configuration to reflect it without vPC ( config I have attached it in earlier port)?

Thanks

Ashok

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

What is the purpose of your 2811 in real life? I know you can put 2600 as DHCP, that i just host emulation.

If I understand your initial email correctly, your 2811 will be used to connect to MPLS (as a router), and you want to peer 2811 with your N5Ks via routing protocol over vPC peer-link. This is why I said it is not supported. You should reconfigure so it is not using vPC (regular STP topology).

HTH,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jeye,

We have existing network with following connectivity:

MPLS cloud == 2811 == cat 6509 == cat 5509 (1st flr)

                                             ||

                                           cat 5509(2 nd flr)

In new environment we will using same cloud and 2811 router but repalcing Cat 6509/5509 with Nexus 5548 & cat 4510.

MPLS cloud == 2811 == 2 X N5K & 4 X N2K == cat 4510 (1st flr)

                                                            ||

                                                  cat 4510(2 nd flr)

1) There will be no vPC between Cisco 2811 & N5K. (eigrp used between two)

2) But there is vPC between two N5K and between N5K & N2Ks.

Will this work?

Thanks

Ashok

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

So... You will use vPC between N5Ks and 4500s that is fine. But in order for you to connect 2811, it will need to be on the FEX. If you only have one trunk (vpc peer-link), all VLANs will be consider as vPC VLAN, and this is why I said you need to use STP, meaning move the 2811 VLAN to a different trunk and prune the 2811 VLAN from vPC peer-link. Please see the below diagram which explain what I mean.

HTH,

jerry

New Member

Re: Nexus 5548UP connectivity with Cisco router 2811.

Jerry thanks for the update.

I have connected three cables (SFP-H10GB-CU1M=)between two N5k. I have configured ether channel between two N5K.

SW01(config-if-range)# interface port-channel 1

SW01(config-if)# switchport mode trunk

SW01(config-if)# switchport trunk allowed vlan  

SW01(config-if)# vpc peer-link

SW01(config-vpc-domain)# int ethernet 1/30-32

SW01(config-if-range)# switchport mode trunk

SW01(config-if-range)# channel-group 1 mode active

SW01(config-if-range)# switchport trunk allowed vlan 1,24-29,31,129,137,146

Same configuration I have done on second switch.

As per your diagram I will have to configure vPC between port 31 & 32 and run STP on port 30.

I am using vlan 24 for Cisco 2811.

Can you please paste configuration for pruning 2811 vlan from vPC?

Thanks

Ashok

New Member

Nexus 5548UP connectivity with Cisco router 2811.

FYI. We have N2K which are dual homed with N5K.

N5K === N5K

||||           ||||

||||           ||||

|||\--N2K--/|||

||\---N2K--/ ||

|\----N2K---/ |

\-----N2K----/

Cisco Employee

Re: Nexus 5548UP connectivity with Cisco router 2811.

Your topology will not work. When you connect the 2811 to the FEX, that FEX needs to be single homed, not vPC to the N5K.

To prune the 2811 VLAN from the vPC peer-link, you can use

switchport trunk allowed vlan remove 24

HTH,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

The FEX on which I am connecting Cisco 2811 router has to be single homed or it can be multi homed ?

Thanks

Ashok

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

I was reading below Cisco document on vPC

http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/operations/n5k_L3_w_vpc_5500platform.html#wp999181

One of the solution for suboptimal route is use command peer-gateway starting from Release 5.0(3)N1(1b),

I have this OS n5000-uk9.5.1.3.N2.1a.bin on my N5K.

Let me know your view on above command.

Thanks

Ashok

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

The FEX to your C2811 should be single homed.

Peer-gateway is used to solve certain problem. It is generally recommended for vPC set up involved inter-VLAN routing.

HTH,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

As per our discussion till now I have setup network as below:

  • •1)      Connected Cisco 2811 router on Single homed N2K.
  • •2)      Separate cable is connected between N5K & N5K and trunk is formed with router vlan 24 allowed.
  • •3)      Command peer-gateway is configured on both N5K port channel 0.

Is it OK to configured VPC between N5K and N2K that is single homed?

What is the good practice to configure Catalyst 4510 to both N5K?

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

I think your L3 toward 2811 is fine.

What is your connection to the C4510? L2 or L3? If it is L2, you can do vPC. If it is L3, you should do ECMP.

HTH,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

It is L2. so I will configure vPC between N5K and 4510.

Tomorrow I am setting up N5K, N2K & 4510 in test environment. Once I am done I will send you final diagram and config.

Thanks for help till now.

Thanks

Ashok

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

Today did configured Nexus as per our discussion.

1) Under port channel 1 (N5k to N5K) I did not find command peer-gateway.

2) I connected test router to N2K (single homed). Port is showig inactive.

Hall of Fame Super Gold

Nexus 5548UP connectivity with Cisco router 2811.

You got your HWIC-1GE-SFP and GLC-T already???

And you've connected the 2K to the GLC-T?

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Leolaohoo,

Earlier I was researching on which interface is suitable for connection between N5K & Cisco 2811. We are not buying the card at this moment instead I am connecting Cisco 2811 directly to N2K. As per suggesion from support.cisco.com I re-wired the switches. Below is the present set-up.

Cisco 2651 (vlan 24) === N2K(single homed) (vPC) === N5K -1 ------- (trunk, allowed vlan 24) ------- N5K

                                                                                           | | |  \==================vPC (Po1)====/  | | |

                                                                                           | | |                                                                        | | |

                                                                                           | |  \------------------N2K (dual homed)----------------/ | |

                                                                                           | |                                                                            | |

                                                                                           |  \--------------------N2K (dual homed)-----------------/ |

                                                                                           |                                                                                |

                                                                                            \----------------------N2K (dual homed)------------------/

I have connected test router to N2K. Interface at N2K is showing inactive.

[I accidentely clicked on answered button.:( ]

Hall of Fame Super Gold

Nexus 5548UP connectivity with Cisco router 2811.

And what model is you N2K?

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

Hi Leo,

I think he has 2248TP. This has support of 100MB.

Hi Ashok,

1. peer-gateway command is not under port-channel. It is a vPC global configuration, you need to put this under vpc domain x.

2. Can you show me the FEX fabric configuration along with the port-channel? Also need the FEX HIF configuration.

Regards,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

  • •1)       Yes under vpc domain 1 it took the command. I added it on both N5K.
  • •2)       FEX configuration:
    • •1)       ON N5K-1 (On port 1/1 & ½ single homed N2K is connected)

interface port-channel101

switchport mode fex-fabric

fex associate 101

vpc 101

interface Ethernet1/1

switchport mode fex-fabric

fex associate 101

channel-group 101

interface Ethernet1/2

switchport mode fex-fabric

fex associate 101

channel-group 101

  • •2)       vPC configuration between N5K-1 & N5K-2

interface port-channel1

switchport mode trunk

switchport trunk allowed vlan 1,25-29,31,129,137,146

spanning-tree port type network

speed 10000

vpc peer-link

interface Ethernet1/9

switchport mode trunk

switchport trunk allowed vlan 1,25-29,31,129,137,146

channel-group 1 mode active

interface Ethernet1/10

switchport mode trunk

switchport trunk allowed vlan 1,25-29,31,129,137,146

channel-group 1 mode active

  • •3)       Trunk between N5K & N5K for router vlan 24.

interface Ethernet1/11

switchport mode trunk

switchport trunk allowed vlan 24

  • •4)       Domain config and Management vlan

On N5K-1

interface mgmt0

ip address 172.16.154.1/24

vpc domain 1

role priority 1000

peer-keepalive destination 172.16.154.2

peer-gateway

On N5K-2

interface mgmt0

ip address 172.16.154.2/24

vpc domain 1

role priority 2000

peer-keepalive destination 172.16.154.1

peer-gateway

I did not understood HIF command. Please explain.

Cisco Employee

Nexus 5548UP connectivity with Cisco router 2811.

HIF - host interface, meanning E101/1/x on the FEX.

Please provide show interface e101/1/x, show vlan id 24, and show run int vlan 24.

Regards,

jerry

New Member

Nexus 5548UP connectivity with Cisco router 2811.

Jerry,

LSV-CORE-SW01# sh run int e101/1/1

!Command: show running-config interface Ethernet101/1/1
!Time: Thu Jan 24 07:42:19 1957

version 5.1(3)N2(1a)

interface Ethernet101/1/1
  switchport access vlan 24

LSV-CORE-SW01# sh int e101/1/1
Ethernet101/1/1 is down (inactive)
  Hardware: 100/1000 Ethernet, address: 0cd9.9608.b442 (bia 0cd9.9608.b442)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is access
  auto-duplex, 100 Mb/s
  Beacon is turned off
  Input flow-control is off, output flow-control is on
  Switchport monitor is off
  EtherType is 0x8100
  Last link flapped 00:22:48
  Last clearing of "show interface" counters never
  30 seconds input rate 176 bits/sec, 0 packets/sec
  30 seconds output rate 72 bits/sec, 0 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 232 bps, 0 pps; output rate 112 bps, 0 pps
  RX
    1387 unicast packets  3242 multicast packets  23 broadcast packets
    4652 input packets  420655 bytes
    0 jumbo packets  0 storm suppression bytes
    0 runts  0 giants  0 CRC  0 no buffer
    0 input error  0 short frame  0 overrun   0 underrun  0 ignored
    0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    0 unicast packets  748 multicast packets  0 broadcast packets
    748 output packets  213261 bytes
    0 jumbo packets
    0 output errors  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble 0 output discard
    0 Tx pause
  0 interface resets

LSV-CORE-SW01#

LSV-CORE-SW01# sh vlan id 24

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
24   VLAN0024                         active    Eth1/11, Eth101/1/1, Eth101/1/2

VLAN Type  Vlan-mode
---- ----- ----------
24   enet  CE

Remote SPAN VLAN
----------------
Disabled

Primary  Secondary  Type             Ports
-------  ---------  ---------------  -------------------------------------------

LSV-CORE-SW01#

LSV-CORE-SW01# sh run int vlan 24

!Command: show running-config interface Vlan24
!Time: Thu Jan 24 07:44:14 1957

version 5.1(3)N2(1a)

interface Vlan24
  no shutdown
  no ip redirects
  ip address 192.168.24.4/24
  ip router eigrp 65102
  hsrp 2
    preempt
    ip 192.168.24.1
  ip dhcp relay address 192.168.24.2 (test DHCP configured in Cisco 2651 router)

LSV-CORE-SW01#

4680
Views
0
Helpful
67
Replies
CreatePlease to create content