Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus 5548UP vPC configuration

I have followed every piece of cisco documentation I could find on this and I still can't get vPC configured to actually work.  The VLANs stay in a suspended state so no traffic flows across.  Below is my configuration:

vrf context management
  ip route 0.0.0.0/0 10.86.0.1
vlan 1


vlan 86
  name I.S_Infrastructure


vpc domain 1
  role priority 1000
  peer-keepalive destination 10.86.0.4

interface Vlan1

interface Vlan86
  no shutdown
  description I.S._Infrastructure
  ip address 10.86.0.1/24

interface port-channel1
  switchport mode trunk
  vpc peer-link
  spanning-tree port type normal

interface Ethernet1/1
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/2
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/3

  description Connection to Mgmt0
  switchport access vlan 86
  speed 1000

interface mgmt0

  ip address 10.86.0.3/24

1 ACCEPTED SOLUTION

Accepted Solutions

Nexus 5548UP vPC configuration

This change this to "spanning-tree port type network"

interface port-channel1
  switchport mode trunk
  vpc peer-link
  spanning-tree port type normal

Let me know, if that resolve your issue.

Thanks

Rizwan Rafeek

8 REPLIES

Nexus 5548UP vPC configuration

This change this to "spanning-tree port type network"

interface port-channel1
  switchport mode trunk
  vpc peer-link
  spanning-tree port type normal

Let me know, if that resolve your issue.

Thanks

Rizwan Rafeek

New Member

Nexus 5548UP vPC configuration

Still nothing.  When I remove the vPC configuration and just use the port channel to trunk the vlans, both 5k's can see each other.  Once I put the vPC config on I get nothing. 

switch# show vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                   : 1
Peer status                     : peer link is down
                                  (peer-keepalive not operational,
                                  peer never alive)
vPC keep-alive status           : Suspended (Destination IP not reachable)
Configuration consistency status: failed
Per-vlan consistency status     : success
Configuration consistency reason: Consistency Check Not Performed
Type-2 consistency reason       : Consistency Check Not Performed
vPC role                        : none established
Number of vPCs configured       : 0
Peer Gateway                    : Disabled
Dual-active excluded VLANs      : -
Graceful Consistency Check      : Disabled (due to peer configuration)

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans
--   ----   ------ --------------------------------------------------
1    Po1    up     -
switch#

Nexus 5548UP vPC configuration

Assign the port-channel1 to vrf "management"

interface port-channel1
  switchport mode trunk
  vpc peer-link
spanning-tree port type network

  vrf memeber management

let me know.

thanks

Nexus 5548UP vPC configuration

Hello rizwanr74

These commands that you suggest are disruptive ?  they mean any big impact inside the nexus ?

Regards

Carlos

New Member

Nexus 5548UP vPC configuration

I don't see the command "vrf member management" under my port channel.  I do see it under mgmt0 but that had no affect on my problem.

Cisco Employee

Nexus 5548UP vPC configuration

Beside the peer-link is using the wrong port type (should be network). The other problem is the peer keepalive is not up:

Peer status:     peer link is down (peer-keepalive not operational, peer never alive)

Can you ping 10.86.0.4 vrf management?

Regards,

jerry

New Member

Nexus 5548UP vPC configuration

Thanks for the help everyone.  Since this is new to me, I didn't know I couldn't plug the mgmt0 interface back into the 5548 and expect it to talk...So i used an external switch to provide communicaiton for mgmt0.  That solved the whole problem.

Nexus 5548UP vPC configuration

It was good to hear that things worked out for you.

Please rate any helpful post, this might be become a helpful dip for someone else.

thanks

Rizwan Rafeek

3590
Views
5
Helpful
8
Replies
CreatePlease login to create content