Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Nexus 7000 & PXE Boot

Recently, we went through an upgrade at our data center core, moving from 6509s to Nexus 7000s. We are running version 4.2(8).

Prior to the upgrade, the problem never happened.

We are seeing a strange issue in our Citrix environment as we try to use PXE boot. On our DHCP server, we have defined the necessary options, including option 66 and option 67, which are tftp server name and bootfile, for PXE boot for the clients on a specific vlan.

Our problem is that the client receives the information for option 67, but not for option 66. The IP address for the tftp server never gets returned to the clients.

Has anyone ever seen this issue before?

Thansk.

Everyone's tags (1)
4 REPLIES
Cisco Employee

Nexus 7000 & PXE Boot

Hi Robert,

Pls consider with link for differencies between 6k and N7k in DHCP rely functioning.

https://supportforums.cisco.com/docs/DOC-14753

You may need to disable "dhcp relay" on N7k as a test during Maintenance Window to see if that solves a problem.

Hope this helps,

Nik

New Member

Nexus 7000 & PXE Boot

Hi all,

I really don't understand why ip forward-protocol is not available on nx-os. A lot of my customer use PXE to boot (ghost image) and now they have to put a DHCP server in the same LAN.

I saw on the following topic that ip forward-protocol will be available on NX-OS 5.2 (N5K) :

https://supportforums.cisco.com/thread/2073405

I am using this version and this command is not available.

Any news or solution about this issue ?

Regards,

Thibault

New Member

Nexus 7000 & PXE Boot

Thanks Nik. Great article!

I was getting the No boot filename error.

Because the Nexus 7000 does NOT broadcast these DHCP broadcast packets to all ports within the VLAN I added the image server as a relay-agent and bingo PXE Boot started working again.

New Member

Re: Nexus 7000 & PXE Boot

Ran into similar issue during a 6500 to N7K upgrade.

One fix was simply configuring DHCP relay to include the PXE server, as well as the DHCP server.

However, if that's not a solution, here's another way we solved it:

Did a pcap of the bootup process.

Found that in the DHCPRequest, Option 67 is asked for, but never Option 66.

The DHCPOffer responses would then deliver Option 67, but never Option 66.

Our solution for this

(We use Infoblox for DNS/DHCP)

Was to configure:

BOOTP "Next Server" with the PXE IP

DHCP Option 67 for the PXE filename

After that,

Our PXE worked fine. Pcaps showed the required information in the DHCPOffer

Article that tipped us off:

https://www.symantec.com/business/support/index?page=content&id=TECH197816

9387
Views
5
Helpful
4
Replies