Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Nexus 7K VPC to CatOS STP problems

Hi

I'm in the process of migrating from two Catalyst 6509s running CatOS to a pair of Nexus 7009s in a VPC domain. The current Cat 6509 environment is running PVST+ and the STP priority is 8192 for all vlans. The N7Ks are running Rapid-PVST+ with an STP priority of 40960 for all vlans. After connecting one of the Cat 6509's (switch 1) to both Nexus 7Ks via a VPC I see strange issues with STP. Both the 6509s STP configurations looks normal with Cat 6509 switch 1 being the root bridge. However if I run 'show spanningtree root' on each Nexus 7K, they are also both root bridges for all vlans (I have peer-switch configured) even though the priorities are set higher. The other strange problem is that only vlan 1 is trunking between the N7Ks and Cat 6509 switch 1, I can see that all vlans are trunking when I run 'show int trunk', the VPC is also up and happy.

I would appreciate any help with this.

2 REPLIES
Silver

Choose a VLAN and look atshow

Choose a VLAN and look at

show spanning-tree vlan x

on the Nexus 7000

Check your vPC configuration

Check your vPC configuration and error logs on the N7Ks to make sure that no VLANs have been suspended on the vPC member ports.

148
Views
0
Helpful
2
Replies
CreatePlease to create content