Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Nexus Config-Sync Failure

Hi Folks,

I've configured config-sync on two Nexus 5Ks and have run into an issue.  There is a command (port-profile) that is failing a local verification check.  The guidance from Cisco documentation is that the command was made in either config terminal or config sync modes and that the command can't then be run in the other mode i.e.

DESCRIPTION:

When you are using config sync and are trying to configure an interface in conf t mode, you are unable to configure the interface because the command is not mutually exclusive. This may also arise when trying to sync a switch-profile using config sync, but it fails due to the same reason.

SOLUTION:

Any mutual exclusive check failure, in config t or config sync mode, means that the command already exists in the other mode. In other words, if you see the error when trying to configure in conf t mode, this means the command already exists in your switch-profile config sync mode. If you see the switch-profile commit fail due to this, it is because the command already exists in conf t mode either on the local switch, or on the peer switch.  If you are not sure which switch the command exists, "show switch-profile status" will show you the status of the last commit and where it failed.  Remember that when using config sync, you may only have specific configuration in one mode at a time.

The advice is to then delete the command from config t or config sync modes.  I've tried both but I receive the same error in either case;

nex-a#config t

nex-a(config)# no port-profile NET-PORT

Error: Command is not mutually exclusive

nex-a(config)#

or config sync

nex-a(config-sync-sp)# show  switch-profile buff

switch-profile  : Test

----------------------------------------------------------

Seq-no  Command

----------------------------------------------------------

5       port-profile type ethernet NET-PORT

6       no port-profile NET-PORT

nex-a(config-sync-sp)#

nex-a(config-sync-sp)# commit

Failed: Verify Failed

nex-a(config-sync-sp)# sho switch-profile status

switch-profile  : Test

----------------------------------------------------------

Start-time: 229684 usecs after Thu Sep 12 11:56:26 2013

End-time: 297033 usecs after Thu Sep 12 11:56:27 2013

Profile-Revision: 9

Session-type: Commit

Session-subtype: -

Peer-triggered: No

Profile-status: -

Local information:

----------------

Status: Verify Failure

Error(s):

Following commands failed mutual-exclusion checks:

port-profile type ethernet NET-PORT

no port-profile NET-PORT

Peer information:

----------------

IP-address: 10.2.58.15

Sync-status: In sync

Status: Verify Success

Error(s):

nex-a(config-sync-sp)#

Any help would be appreciated. Thanks.

2 REPLIES

Nexus Config-Sync Failure

This type of problem is all to common with switch-profiles.  The way I deal with them is to start out by finding out where the commands are actually configured.  I would start by deleting your commit buffer, and then do a commit, just to get a fixed starting point.  Then I copy the running configuration of each switch to a TFTP server, and have a look at the files with an editor.  I like to use WinMerge, because apart from being able to read throgh the configuration easily, I can put the two switches side by side and see the differences.

The TFTP file can be considered in two parts, the bit above the "switch-profile", which is the commands that came in from the "conf t", and the bit after, which came from the "conf sync".  Needless to say, you would expect the latter part to be identical on each switch, give or take a "sync-peers" command.

Often vthe only way to tidy up is to remove the sync-peer command (then commit), then work on each side separately until they look similar, and then re-establish the sync peering.  It may also be necessary to do a resync-database.

Hope this helps.

Kevin DORRELL

Luxembourg

New Member

Re: Nexus Config-Sync Failure

Thanks Kevin, I tried as you suggested, but I just couldn't remove/edit the port-profile config. In the end I just removed the sync configuration completely and started from scratch. It was okay to do this as there is not very much configuration or active ports on the switches but I hope I don't run into this type of trouble in a couple of weeks time when it is a lot more populated. Thanks again for your help.

Sent from Cisco Technical Support iPhone App

297
Views
3
Helpful
2
Replies