Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No connected route for VLAN interface

I'm trying to add new VLANs to my Cisco 3750, but am having problems. I can add the vlan int and associate an IP with it, but I cannot ping the vlan interface, nor does it show up as a connected route when I do a show ip route. Here's the info below:

Building configuration...

Current configuration : 5515 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Switch

!

enable secret

!

no aaa new-model

switch 1 provision ws-c3750-48ts

ip subnet-zero

ip routing

ip dhcp excluded-address 192.168.2.1 192.168.2.50

ip dhcp excluded-address 192.168.2.101 192.168.2.254

!

ip dhcp pool VLAN2

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1

!

!

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback1

ip address 192.168.253.2 255.255.255.255

!

interface FastEthernet1/0/1

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/2

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/3

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/4

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/5

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/6

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/7

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/8

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/9

switchport access vlan 2

spanning-tree portfast

!

interface FastEthernet1/0/10

switchport access vlan 2

spanning-tree portfast

!

interface Vlan1

no ip address

!

interface Vlan2

ip address 192.168.2.1 255.255.255.0

!

interface Vlan3

ip address 10.57.200.1 255.255.255.0

!

interface Vlan4

ip address 10.56.2.1 255.255.255.0

!

interface Vlan5

ip address 10.56.12.1 255.255.255.0

!

interface Vlan6

ip address 10.56.22.1 255.255.255.0

!

router eigrp 100

network 192.168.2.0

network 192.168.253.2 0.0.0.0

network 192.168.254.0

auto-summary

!

ip classless

ip http server

ip http secure-server

!

!

!

control-plane

!

!

line con 0

line vty 0 4

password xxx

login

line vty 5 15

password xxx

login

!

end

Switch#ping 10.57.200.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.57.200.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Switch#

Switch#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C 192.168.254.0/24 is directly connected, FastEthernet1/0/46

D 192.168.1.0/24 [90/28416] via 192.168.254.2, 00:04:11, FastEthernet1/0/46

192.168.253.0/24 is variably subnetted, 2 subnets, 2 masks

D 192.168.253.0/24 is a summary, 00:04:11, Null0

C 192.168.253.2/32 is directly connected, Loopback1

C 192.168.2.0/24 is directly connected, Vlan2

Switch#

7 REPLIES

Re: No connected route for VLAN interface

The route would only show up if the VLAN 3 interface is up. You need to have atleast one active port on vlan 3 or a trunk port in which 3 VLAN is active for the interface to come up. Can you assign one of the active ports to vlan 3 and check the status?

HTH

Sundar

New Member

Re: No connected route for VLAN interface

That worked for vlan3 int. I've got another Netgear smart switch that needs to see these vlans as well. I've got fa1/0/47 set up like this:

interface FastEthernet1/0/47

switchport mode dynamic desirable

Will that serve as an appropriate trunk to allow the vlans be seen across both switches? Essentially a trunking interface...

Thanks,

Steve

Re: No connected route for VLAN interface

Try this configuration.

int f1/0/47

switchport trunk encapsulation dot1q

switchport mode trunk

HTH

Sundar

New Member

Re: No connected route for VLAN interface

The Netgear switch has an IP of 192.168.2.3 which is on Vlan2. After setting the trunk encaps. and the mode, I cannot ping the netgear switch.

Re: No connected route for VLAN interface

Did you create vlan 2 itself and not the vlan interface in the Netgear?

New Member

Re: No connected route for VLAN interface

That was it...I had not created the trunking port on the netgear switch. I can ping it now. Thanks for your help!

New Member

Re: No connected route for VLAN interface

stephen,

perform a 'show interface' command. My guess is the vlans you have created are down, since there is no port(s) assigned to the new vlan(s).

317
Views
0
Helpful
7
Replies
CreatePlease login to create content