Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No connection between routing and switching part in a 4510

Hello

I have problem to ping GW on my 4510, I have create one vlan for each VRF. when I put in a computer on a port 3/5 with an ip address in correct network, it just time out. I cant ping GW, but if I have many ports on same Vlan they have no problem ping each other. When I sniff i found that I recived L2 traffic like, STP, ARP, VTP but no L3 traffic.

All ports and Vlans are up.

It seems like the routingpart and the switchingpart only talks L2 and not L3.

All this worked yesterday, there was no problem. this morgning 4510 didnt answer at L3, but it still talks L2.

Some info:

Image 12.2(25)EWA7

Redundant SUP V

VRF-lite with BGP, 5 vrf

RSTP, configured 4510 as root, the ports are not in blocking state.

interface GigabitEthernet3/5

switchport access vlan 210

switchport mode access

interface Vlan210

ip vrf forwarding adm

ip address 172.16.1.254 255.255.0.0

On my computer i used 172.16.1.253 /16

This also worked yesterday.

Is there any good command that I can use to see if there is any problem between routingpart and switchingpart.

10 REPLIES
New Member

Re: No connection between routing and switching part in a 4510

Hi,

Can you paste the config on the 4510?

Cheers

New Member

Re: No connection between routing and switching part in a 4510

Hello

I add an attachment with the config

thanks!

New Member

Re: No connection between routing and switching part in a 4510

interface Vlan910

description ***till old admNet***

ip vrf forwarding adm

ip address 172.16.1.254 255.255.0.0

!

interface GigabitEthernet3/5

description ***VRF adm till old admNet***

switchport access vlan 910

switchport mode access

for ex. if I connect to port 3/5 with an adress of 172.16.1.253 I only se L2 traffic, like arp, vtp stp but no L3.

New Member

Re: No connection between routing and switching part in a 4510

hi

what does the sh ip route vrf adm look like?

i would suggest removing VLAN 910 from vrf adm and try pinging the gateway.

Thanks

New Member

Re: No connection between routing and switching part in a 4510

I haven't done vrfs before but I would have thought the interface network 172.16.0.0 would need to be under the vrf in :

router rip

version 2

no auto-summary

!

address-family ipv4 vrf adm

network 172.17.0.0

network 172.31.0.0

*** add network 172.16.0.0 here , perhaps? ***

no auto-summary

version 2

exit-address-family

Otherwise the route will not be in the routing table and therefore not advertised by BGP

hth

New Member

Re: No connection between routing and switching part in a 4510

I dont think there is any problem with the routing part. I use "no synchronization" in bgp. Everything works for a for some hours and then there is no answer from GW. If I restart the switch i works again. On the network 172.16.0.0/16 there is about 1200 hosts.

New Member

Re: No connection between routing and switching part in a 4510

Is the same result. I have removed all config, then I created a new vlan, new vlan interface with ip address (not in any vrf), and a port for that Vlan everything is up. if I configure two to ports to the same Vlan the can talk with each other but not with the gateway. there is still no connection between L2 and L3.

When I restart Cisco 4510, the problem disappear and the switch i function for a while, after some hours the problem occurs again.

New Member

Re: No connection between routing and switching part in a 4510

It might be worth clearing the 4500's ARP table the next time it stops working to see if that makes any difference... also it would be interesting to see if you cleared the CAM table whether that would help & see if your host MAC is actually in the table.

I assume it is only this VLAN that is experiencing the problem?

New Member

Re: No connection between routing and switching part in a 4510

The problem exist on every Vlan. I removed config and created a new vlan = same problem. i found my mac-adress in 4510.

New Member

Re: No connection between routing and switching part in a 4510

What about the ARP table? If you clear it while the problem is happening, does it re-fill itself?

What happens if you run a sniff on the client PC and try to ping it from the 4500 (again, while the problem is ongoing)?

287
Views
0
Helpful
10
Replies
CreatePlease login to create content