Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No Internet - Cisco Router

Dear All,

I'm using Cisco Router 2800 for gateway connected to my Modem.

Internet Service Provider ===} Cisco Router ====} Cisco Switch

The cisco switch 3750 is connected to Router port FE0/0.

I already configured the gateway which is my Internet Modem for testing but

still I cant get Internet connection to my switch.

DHCP is enabled/configured in Cisco router 2800.

Attached please find file copy of my configuration.

What should I do?

Thank you for the help.

Regards,

Michael

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: No Internet - Cisco Router

Hi Michael

Your 2800 router does not seem to have a default route configured. When the router recieves a packet destined for an Internet public IP address, it does a lookup in its routing table to try and match the address. Obviously internal routers don't have routes for all internet addresses, so you need to configure something called a default route. This route effectively points to your ISP and says 'If there is no matched route in the routing table, forward the packet to the default route'.

It looks like your 2800 is connected to another router, which I suspect is then connected to your ISP.

interface FastEthernet0/1

description Connection to Zain Router

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

You need to setup a default route on the 2800 which points to the 'Zain router' as its next hop.

Something like:

ip route 0.0.0.0 0.0.0.0 192.168.1.1

Assuming 192.168.1.1 is the Router address.

I am also not sure what 192.100.100.0 /24 is? You appear to be using the whole /24 subnet as a private IP range.

Purple

Re: No Internet - Cisco Router

Hi,

You put the router config in the switch zip file but here are some points to take into account concerning the router:

1) if your ISP router accepts to nat non directly connected subnets which I highly doubt it needs a route back to this subnet(192.100.100.0/24) but this subnet is not a private subnet(192.168.x.x/16) so you should change it to 192.168.100.0/24 instead.

2) if the ISP router doesn't NAT non directly connected subnets then you'll have to do NAT on the 2800

access-list 1 permit 192.168.100.0 0.0.0.255

ip nat inside source list 1 interface f0/1

  int f0/0

ip address 192.168.100.1 255.255.255.0

ip nat inside

int f0/1

ip nat outside

Don't forget to change the dhcp pool accordingly to provide the 192.168.100.0/24 subnet

Also as already pointed you have to define your ISP modem as the default gateway on the 2800

ip route 0.0.0.0 0.0.0.0 192.168.1.x  where x is the last octet value for the ISP router IP address.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
3 REPLIES

Re: No Internet - Cisco Router

Hi Michael

Your 2800 router does not seem to have a default route configured. When the router recieves a packet destined for an Internet public IP address, it does a lookup in its routing table to try and match the address. Obviously internal routers don't have routes for all internet addresses, so you need to configure something called a default route. This route effectively points to your ISP and says 'If there is no matched route in the routing table, forward the packet to the default route'.

It looks like your 2800 is connected to another router, which I suspect is then connected to your ISP.

interface FastEthernet0/1

description Connection to Zain Router

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

You need to setup a default route on the 2800 which points to the 'Zain router' as its next hop.

Something like:

ip route 0.0.0.0 0.0.0.0 192.168.1.1

Assuming 192.168.1.1 is the Router address.

I am also not sure what 192.100.100.0 /24 is? You appear to be using the whole /24 subnet as a private IP range.

Purple

Re: No Internet - Cisco Router

Hi,

You put the router config in the switch zip file but here are some points to take into account concerning the router:

1) if your ISP router accepts to nat non directly connected subnets which I highly doubt it needs a route back to this subnet(192.100.100.0/24) but this subnet is not a private subnet(192.168.x.x/16) so you should change it to 192.168.100.0/24 instead.

2) if the ISP router doesn't NAT non directly connected subnets then you'll have to do NAT on the 2800

access-list 1 permit 192.168.100.0 0.0.0.255

ip nat inside source list 1 interface f0/1

  int f0/0

ip address 192.168.100.1 255.255.255.0

ip nat inside

int f0/1

ip nat outside

Don't forget to change the dhcp pool accordingly to provide the 192.168.100.0/24 subnet

Also as already pointed you have to define your ISP modem as the default gateway on the 2800

ip route 0.0.0.0 0.0.0.0 192.168.1.x  where x is the last octet value for the ISP router IP address.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Re: No Internet - Cisco Router

Thank you very much for the help..

Cadet Alain

194
Views
0
Helpful
3
Replies