Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

no network connectivity with 2650xm router

Hi all,

i have 2650xm  router directly connected to cable modem.

I have laptop on fa1/0 port and port fa0/0 connects directly connect to cable modem.

My Laptop  has IP  192.168.1.2  and its gateway is fa1/0 interface IP 192.168.1.1

fa0/0  interface on router has IP  96.X.X.X.

From my laptop i am unable to access any internet sites also unable to ping the Fa0/0 interface on the router.

i rebooted cable modem and laptop few times no luck.

any ideas which i can try

thanks

mahesh

13 REPLIES

Re: no network connectivity with 2650xm router

What is the status of the fa0/0 by issuing a command show fa0/0 and are you able to ping the gateway ip 192.168.1.1 ?

Regards

Ganesh.H

Community Member

Re: no network connectivity with 2650xm router

Hi,

i am able to telnet the router now by public ip

i will past my config here .

from router i am unable to ping the 96.x.x.x ip which my int fa0/0 has got from my isp.

i can ping the 192.168.1.1 fine.

Please help

mahesh

Community Member

Re: no network connectivity with 2650xm router

Hi,

status of  fa0/0 is up up and public ip is assigned to it.

Community Member

Re: no network connectivity with 2650xm router

Hi,

Have you enabled NAT on the router?

A sample configuration is displayed below:

interface fa1/0

ip add 192.168.1.1 255.255.255.0

description TO LAN

ip nat inside

interface fa0/0

ip address 96.1.1.1 255.255.255.252

desc TO INTERNET

ip nat outside

access-list NAT-ACL permit ip any any

ip nat inside source list NAT-ACL interface fa0/0 overload

-------------------


And then ping a public ip, say 8.8.8.8 with an internal ip

Ping 8.8.8.8 source fa1/0

!!!!!

Hope that helps

TIA, Nicos Nicolaides
Community Member

Re: no network connectivity with 2650xm router

hi,

thanks for reply

i have pasted my router config .

i have enabled nat.

still no luck.

please help

thanks

mahesh

VIP Super Bronze

Re: no network connectivity with 2650xm router

mahesh

Do you have a default route configured toward your service provide?

Can you post the entire config?

Reza

Community Member

Re: no network connectivity with 2650xm router

Ol

Community Member

Re: no network connectivity with 2650xm router

Hi Reza,

thanks for reply i have entire config  attached please see my post from today

thanks

VIP Super Bronze

Re: no network connectivity with 2650xm router

Hi Mahesh,

I do not see a default route in your config.

ip router 0.0.0.0 0.0.0.0 (the address of the modem)

May be you did not post every thing

HTH

Reza

Community Member

Re: no network connectivity with 2650xm router

Hi Reza,

when you use ip address dhcp command under wan interface you do not need to maually config this command/

i pasted you all config

thanks

mahesh

Hall of Fame Super Silver

Re: no network connectivity with 2650xm router

Hello Mahesh,

I see that your external interfaces takes an ip address by DHCP. This is made by using BOOTP packets that are UDP/IPv4 packets.

Actually, you send out a broadcast request but the answer is directed to your router's fas0/0 MAC address.

The fact that you cannot ping your default gateway may come from a security measure of provider, it is not a sure sign of problem.

The cable modem can act as a simple bridge and the default gateway can be in the head end serving a lot of users.

You say that you are not able to browse the internet from the laptop, have you tried to bypass the DNS function trying to access directly a public ip address that can be pinged?

in the file we see:

S*   0.0.0.0/0 [254/0] via 96.X.Y.Z

have you got this from DHCP or you have configured it manually?

that is you are using

ip route 0.0.0.0 0.0.0.0 96.X.Y.Z 254

or a form including the DHCP keyword:

ip route 0.0.0.0 0.0.0.0 dhcp 254

see

http://www.cisco.com/en/US/docs/ios/iproute/command/reference/irp_pi1.html#wp1031306

dhcp

(Optional) Enables a Dynamic Host Configuration Protocol (DHCP) server to assign a static route to a default gateway (option 3).

Note Specify the dhcp keyword for each routing protocol.

Was the service working if the PC is connected directly to the cable modem? Could the provider have stored the MAC address of your PC?

from the laptop shell if you try to use the old nslookup tool what you get?

I see that you receive a DNS server that is in a different major network, this should not be a problem but testing the DNS part can help to understand if you have only a DNS issue, or an IP connectivity issue.

Edit:

I have forgotten that you have been able to telnet to the public ip address of your router this should demonstrate IP connectivity.

Hope to help

Giuseppe

Community Member

Re: no network connectivity with 2650xm router

Hi giuslar,

thanks for reply

in the file we see:

S*   0.0.0.0/0 [254/0] via 96.X.Y.Z

have you got this from DHCP or you have configured it manually?  

Answer  i got this from DHCP.

Was the service working if the PC is connected directly to the cable modem

Answer  yes it works if pc is directly connected to cable modem.

Also i am unable to ping the IP  of interface fa0/0  when i am logged on router but i can ping this IP  from C>prompt of laptop.

Let me know if you need more info.

also Note i am able to telnet public IP only from my home Lan not from outside.

thanks

mahesh

Re: no network connectivity with 2650xm router

Hi,

Are you able to ping the direct gateway from your laptop that is local lan and if yes try ping from router with extended ping command using source ip as fa0/0 and try ping laptop and  run ethereal software on your laptop and capture the packet what exatly is happening when you ping the interface fa0/0 and share your output.

Regards

Ganesh.H

473
Views
0
Helpful
13
Replies
CreatePlease to create content