Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

no routing entry for RPF checking

I setup a network for testing multicast streaming.

It is a non routing environment for unicast, but it is success in multicast.

I check that the multicast source is not present in unicast routing table, how it pass the RPF checking??

on the other word, if there is no routing entry for multicast source in  unicast routing table, what is the behavior of RPF checking?

  • LAN Switching and Routing
Everyone's tags (2)
8 REPLIES
Cisco Employee

no routing entry for RPF checking

Hello,

Correctly, if no matching route for the packet source in the routing table is found, the packet should be dropped because it fails the RPF check.

Can you post a diagram of your topology showing the placement of the sender and receiver, and also show us the contents of the router's routing table? Thank you!

Best regards,

Peter

New Member

no routing entry for RPF checking

The above is my network diagram.

Since my router is aleady return to others, I can only tell what configuration on each router.

Cisco 1841:

ip multicast-routing

interface f0/0

ip address 192.168.1.1 255.255.255.0

ip pim sparse-mode

ip igmp version 3

interface f0/1

ip address 172.16.0.1 255.255.0.0

ip pim sparse-mode

Cisco 2811:

ip multicast-routing

ip pim bsr-candidate fastethernet 0/1

ip pim rp-candidate fsatethernet 0/1

inferface f0/0

ip address 10.0.0.1 255.0.0.0

ip pim sparse-mode

ip igmp version 3

interface f0/1

ip address 172.16.0.2 255.255.0.0

ip pim sparse-mode

The above is all the configuration besides the default settings. However, it is work and I remeber in  the "show ip mroute", I can found the (S,G) route for the source on both router

New Member

no routing entry for RPF checking

The routing table of the router:

For Cisco 2811:

C          10.0.0.0/8 is directly connected, FastEthernet0/0

C          172.16.0.0/16 is directly connected, FastEthernet0/1

For Cisco 1841:

C          192.168.1.0/24 is directly connected, FastEthernet0/0

C          172.16.0.0/16 is directly connected, FastEthernet0/1

New Member

I think the catch is 'BSR'

I think the catch is 'BSR' configuration in 2811 with candidate RP being Fa0/1.1. 1841 is using (*, 239.1.1.1).

(*, 239.1.1.1), 00:08:12/stopped, RP 172.16.0.2, flags: SJC
  Incoming interface: FastEthernet0/1, RPF nbr 172.16.0.2
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:05:24/00:02:05

(10.0.0.2, 239.1.1.1), 00:00:11/00:02:48, flags: J
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:00:11/00:02:48

Cisco Employee

no routing entry for RPF checking

Hello,

What type of device(s) are you using and what is the topology like? Do you have the "no ip routing" command configured? Understand that on a router, the simple act of configuring an interface creates routes. This type of routes is referred to as connected. Please provide the additional information mentioned above and I will try to help you explain the behavior you see.

Thanks

Anthony

New Member

no routing entry for RPF checking

I didn't issue the "no ip routing" command and I know the connected routing entry, so I use two router in the test. For the details, you can found my reply on the previous.

Cisco Employee

no routing entry for RPF checking

Hi Tsan,

I can't really see why it would have worked so I labbed it up really quick just to verify. In my environment, I do receive an RPF failure and it does not forward multicast traffic:

Router#show ip mroute 239.0.0.1     

IP Multicast Routing Table

Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,

       L - Local, P - Pruned, R - RP-bit set, F - Register flag,

       T - SPT-bit set, J - Join SPT, M - MSDP created entry,

       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,

       U - URD, I - Received Source Specific Host Report,

       Z - Multicast Tunnel, z - MDT-data group sender,

       Y - Joined MDT-data group, y - Sending to MDT-data group

Outgoing interface flags: H - Hardware switched, A - Assert winner

Timers: Uptime/Expires

Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.0.0.1), 00:12:47/00:02:42, RP 172.16.0.2, flags: SJCL

  Incoming interface: FastEthernet0/0, RPF nbr 172.16.0.2

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:12:47/00:02:59

(10.0.0.2, 239.0.0.1), 00:00:35/00:02:24, flags: LJ

  Incoming interface: Null, RPF nbr 0.0.0.0

  Outgoing interface list:

    FastEthernet0/1, Forward/Sparse, 00:00:35/00:02:59

Router#show ip rpf 10.0.0.2

RPF information for ? (10.0.0.2) failed, no route exists

Sourcing a ping to a join-group on the router also fails:

Router#ping 239.0.0.1 repeat 10 source 10.0.0.1

Type escape sequence to abort.

Sending 10, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:

Packet sent with a source address of 10.0.0.1

..........

Router#

So my guess is we are missing something that was overlooked in the configuration or there is a possible defect. I would guess its most likely something we overlooked.

Anthony

New Member

no routing entry for RPF checking

Hi Anthony,

I have borrow the equipment again and retry the lab, the multicast traffic is success but rpf check is fail in the 1841 router.

I have capture some information (config, routing table, mroute, igmp group, pim and rpf check) in the lab. Is that mean multicast traffic can be pass in some case of rpf fail?

For Cisco 2811:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.07.16 16:42:34 =~=~=~=~=~=~=~=~=~=~=~=
Router#ter len 0
Router#sh ver
Cisco IOS Software, 2800 Software (C2800NM-IPBASEK9-M), Version 12.4(9)T5, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Thu 16-Aug-07 15:21 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Router uptime is 13 minutes
System returned to ROM by power-on
System image file is "flash:c2800nm-ipbasek9-mz.124-9.T5.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2811 (revision 53.51) with 251904K/10240K bytes of memory.
Processor board ID
2 FastEthernet interfaces
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102

Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, FastEthernet0/1
C    10.0.0.0/8 is directly connected, FastEthernet0/0

Router#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Router#sh ip igmp groups
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
239.255.255.250  FastEthernet0/0          00:02:18  00:02:39  10.0.0.2       
224.0.1.40       FastEthernet0/1          00:03:27  00:02:09  172.16.0.2     

Router#sh ip pim rp
Group: 239.1.1.1, RP: 172.16.0.2, v2, next RP-reachable in 00:01:13
Group: 239.255.255.250, RP: 172.16.0.2, v2, next RP-reachable in 00:01:13

Router#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:03:21/00:03:05, RP 172.16.0.2, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:03:21/00:03:05

(10.0.0.2, 239.1.1.1), 00:01:23/00:03:25, flags: T
  Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:01:23/00:03:05

(*, 239.255.255.250), 00:03:22/00:03:05, RP 172.16.0.2, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:02:33/00:02:24
    FastEthernet0/1, Forward/Sparse, 00:03:22/00:03:05

(*, 224.0.1.40), 00:08:55/00:02:54, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/1, Forward/Sparse, 00:03:40/00:02:54

Router#sh ip rpf ?
  Hostname or A.B.C.D  IP name or address of multicast source
  events               Triggered RPF events
  vrf                  Select VPN Routing/Forwarding instance

Router#sh ip rpf 10.0.0.2
RPF information for ? (10.0.0.2)
  RPF interface: FastEthernet0/0
  RPF neighbor: ? (10.0.0.2) - directly connected
  RPF route/mask: 10.0.0.0/8
  RPF type: unicast (connected)
  RPF recursion count: 0
  Doing distance-preferred lookups across tables

Router#sh run
Building configuration...

Current configuration : 719 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
ip multicast-routing
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.0.0.0
ip pim sparse-mode
ip igmp version 3
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.0.2 255.255.0.0
ip pim sparse-mode
duplex auto
speed auto
!
!
ip http server
no ip http secure-server
ip pim bsr-candidate FastEthernet0/1 0
ip pim rp-candidate FastEthernet0/1
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

Router#

For Cisco 1841:

=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.07.16 16:44:32 =~=~=~=~=~=~=~=~=~=~=~=
ter len 0
Router#sh ver
Cisco IOS Software, 1841 Software (C1841-ADVSECURITYK9-M), Version 12.4(15)T9, RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Tue 28-Apr-09 11:17 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Router uptime is 14 minutes
System returned to ROM by power-on
System image file is "flash:c1841-advsecurityk9-mz.124-15.T9.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 1841 (revision 7.0) with 195584K/66560K bytes of memory.
Processor board ID
2 FastEthernet interfaces
1 Serial(sync/async) interface
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity disabled.
191K bytes of NVRAM.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x142

Router#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    172.16.0.0/16 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0

Router#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Router#sh ip igmp group
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
239.1.1.1        FastEthernet0/0          00:05:11  00:02:21  192.168.1.2    
239.255.255.250  FastEthernet0/0          00:05:10  00:02:24  192.168.1.2    
224.0.1.40       FastEthernet0/1          00:05:13  00:02:22  172.16.0.1     

Router#sh ip pim rp
Group: 239.1.1.1, RP: 172.16.0.2, v2, uptime 00:04:59, expires 00:02:09
Group: 239.255.255.250, RP: 172.16.0.2, v2, uptime 00:04:59, expires 00:02:09

Router#sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:08:12/stopped, RP 172.16.0.2, flags: SJC
  Incoming interface: FastEthernet0/1, RPF nbr 172.16.0.2
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:05:24/00:02:05

(10.0.0.2, 239.1.1.1), 00:00:11/00:02:48, flags: J
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:00:11/00:02:48

(*, 239.255.255.250), 00:08:13/00:02:08, RP 172.16.0.2, flags: SJC
  Incoming interface: FastEthernet0/1, RPF nbr 172.16.0.2
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 00:05:24/00:02:08

(*, 224.0.1.40), 00:08:45/00:02:06, RP 0.0.0.0, flags: DPL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

Router#sh ip rpf 10.0.0.2
RPF information for ? (10.0.0.2) failed, no route exists

Router#sh run
Building configuration...

Current configuration : 844 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 25
dot11 syslog
ip cef
!
!
!
!
ip multicast-routing
!
multilink bundle-name authenticated
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip pim sparse-mode
ip igmp version 3
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.0.1 255.255.0.0
ip pim sparse-mode
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Router#

The multicast source server succesfully stream the film, and cannot ping the client

The multicast client succesfully receive the multicast traffic, and cannot ping the source

1044
Views
0
Helpful
8
Replies