Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Not able to ping over VRF

dd.png                  

Dear Friend,

I have created two VRF on R1 i.e R2 and R10. I am able to ping from R1 to R2. But not able to ping From R1 to R4. Please find below configuration On R1.

ip vrf R10

rd 44:44

ip vrf R2

rd 22:22

R1#sh run int f0/0
Building configuration...

Current configuration : 115 bytes
!
interface FastEthernet0/0
ip vrf forwarding R2
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto


R1#sh run int f0/1
Building configuration...

Current configuration : 116 bytes
!
interface FastEthernet0/1
ip vrf forwarding R10
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto

R1#ping vrf R2 12.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.1.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/56 ms

R1#ping vrf R10 12.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.1.1.10, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R2 and R4 are running same IP that is 12.1.1.10........!!!!!!!!!!!!!!!!!!!!!!!!!! PLEASE HELP !!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Regards,

sanjib

9 REPLIES
Hall of Fame Super Blue

Not able to ping over VRF

Sanjib

We need to see the configurations of R1 and R4 and also -

"sh ip route vrf R10 from R1 and R4"

Jon

New Member

Re: Not able to ping over VRF

R1#sh running-config
Building configuration...

Current configuration : 1149 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
ip vrf R10
rd 44:44
!
ip vrf R2
rd 22:22
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated

archive
log config
  hidekeys
!
!ip tcp synwait-time 5
!
!interface FastEthernet0/0
ip vrf forwarding R2
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip vrf forwarding R10
ip address 12.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 13.1.1.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp run
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R1#sh ip route vrf R10

Routing Table: R10
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     12.0.0.0/24 is subnetted, 1 subnets
C       12.1.1.0 is directly connected, FastEthernet0/1

Hall of Fame Super Blue

Not able to ping over VRF

Sanjib

Need to see the same for R4 as well.

Jon

New Member

Not able to ping over VRF

Jon

I have not created VRF on R4 also on R2....I think no require to configure VRF on R4....

Hall of Fame Super Blue

Re: Not able to ping over VRF

Sanjib

Okay but is R4's fa0/1 interface up and does it have the IP of 12.1.1.10 ?

What happens if you try to ping from R4 ?

Jon

New Member

Re: Not able to ping over VRF

Jon

Right...It's F0/1 and IP address is 12.1.1.10.

R4#ping 12.1.1.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.1.1.10, timeout is 2 seconds

......

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/56 ms

Hall of Fame Super Blue

Not able to ping over VRF

Sanjib

Sorry to state the obvious but are you sure that you have connected the right port and that it is up.

Your configuration should work fine.

Jon

New Member

Not able to ping over VRF

Yeah............I am sure.

Hall of Fame Super Blue

Not able to ping over VRF

Sanjib

Then from what you have posted i can't see why it wouldn't work.

Jon

300
Views
0
Helpful
9
Replies
CreatePlease login to create content