Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Not able to reach over VRF lite

Dear Friend,

VRF.png

I have configured VRF on R1.

ip vrf R2

rd 11:11

!

ip vrf R3

rd 22:22

!

ip vrf R4

rd 33:33

Interface Configuration:

interface FastEthernet0/0

ip vrf forwarding R2

ip address 12.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip vrf forwarding R3

ip address 12.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

ip vrf forwarding R4

ip address 12.1.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 15.1.1.1 255.255.255.0

duplex auto

speed auto

PROBLEM:

I am not able to ping 15.1.1.1 from  R2 , R3, R4 as they have already a Default Route towards R1.

R2#ping 15.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 15.1.1.1, timeout is 2 seconds:

UUUUU

Success rate is 0 percent (0/5)

Route on R2:

S*   0.0.0.0/0 [1/0] via 12.1.1.1

Is there anything that I have missed here????

Regards,

Sanjib

2 ACCEPTED SOLUTIONS

Accepted Solutions

Not able to reach over VRF lite

Hello,

This is because VRF is a totally separate routing table that is specified to the VRF. Since you assigned the interface to the VRF you will only have connectivity to the connected router.

You assigned R1 fa0/0 to a separate VRF (VRF R2) only the attached interface will have access to this VRF.

You would perhaps need to do route leaking on R1 between VRF's.

Try 'show ip route vrf R2' etc... you may see there arent any routes to the 15.1.1.1 network. You will only see connected.

Think of it as connected to another router. The router's within R1 (VRF's) need to be able to talk to each other to achieve your goal.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Re: Not able to reach over VRF lite

Hello

Bilal is correct even though this is just one router its has acting separate routers becasue of vrf. is enabled.

Try this on R1.

This puts routes in the global table towards the vrf nexthops

ip route 12.1.1.2 255.255.255.255 FastEthernet0/0

ip route 12.1.1.3 255.255.255.255 FastEthernet 0/1

ip route 12.1.1.4 255.255.255.255 FastEthernet1/0

This tell the vrfs how to get to R5 via the global table

ip route vrf R2 15.1.1.0 255.255.255.0 15.1.1.5 global

ip route vrf R3 15.1.1.0 255.255.255.0 15.1.1.5 global

ip route vrf R4 15.1.1.0 255.255.255.0 15.1.1.5 global

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
3 REPLIES

Not able to reach over VRF lite

Hello,

This is because VRF is a totally separate routing table that is specified to the VRF. Since you assigned the interface to the VRF you will only have connectivity to the connected router.

You assigned R1 fa0/0 to a separate VRF (VRF R2) only the attached interface will have access to this VRF.

You would perhaps need to do route leaking on R1 between VRF's.

Try 'show ip route vrf R2' etc... you may see there arent any routes to the 15.1.1.1 network. You will only see connected.

Think of it as connected to another router. The router's within R1 (VRF's) need to be able to talk to each other to achieve your goal.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
New Member

Not able to reach over VRF lite

Dear Bilal,

Thanks..

To achive my objective then how to configure the device so that R2 can able to ping 15.1.1.1. Please explain in details.

Re: Not able to reach over VRF lite

Hello

Bilal is correct even though this is just one router its has acting separate routers becasue of vrf. is enabled.

Try this on R1.

This puts routes in the global table towards the vrf nexthops

ip route 12.1.1.2 255.255.255.255 FastEthernet0/0

ip route 12.1.1.3 255.255.255.255 FastEthernet 0/1

ip route 12.1.1.4 255.255.255.255 FastEthernet1/0

This tell the vrfs how to get to R5 via the global table

ip route vrf R2 15.1.1.0 255.255.255.0 15.1.1.5 global

ip route vrf R3 15.1.1.0 255.255.255.0 15.1.1.5 global

ip route vrf R4 15.1.1.0 255.255.255.0 15.1.1.5 global

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
108
Views
0
Helpful
3
Replies