Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

not able to see eigrp neighbour

Hi all

i've got 2 1700 series routers connected back to back via a switch with the config below. I'm not able to see the routers when i do a show ip eigrp neighbors, and hence cannot route from the 10 network of one router to the 10 network of the other.

Router 1

!

interface FastEthernet0.4

encapsulation dot1Q 4

ip address 192.168.4.1 255.255.255.252

!

interface FastEthernet0.20

encapsulation dot1Q 20

ip address 10.10.20.1 255.255.255.0

router eigrp 100

network 10.0.0.0

network 192.168.0.0

no auto-summary

Router 2

!

interface FastEthernet0.4

encapsulation dot1Q 4

ip address 192.168.4.2 255.255.255.252

!

interface FastEthernet0.40

encapsulation dot1Q 40

ip address 10.10.40.1 255.255.255.0

router eigrp 100

network 10.0.0.0

network 192.168.0.0

no auto-summary

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: not able to see eigrp neighbour

Glen

It will NOT work ok. You are overlooking the difference between a class A network (10.0.0.0) and a class C network (192.168.0.0). When you put a network statement without a mask in EIGRP then it will match anything within that particular network. So if your network statement is 10.0.0.0 it will match any interface address within class A 10.0.0.0. But if your network statement is 192.168.0.0 it will match any interface address within class C 192.168.0.0 but will not match 192.168.4.0.

HTH

Rick

9 REPLIES

Re: not able to see eigrp neighbour

Hi, Pokey

Change your network statement from

network 192.168.0.0

to

network 192.168.4.0

Then it should work.

Let me know if you have any further question.

SSLIN

New Member

Re: not able to see eigrp neighbour

or maybe set netmask by wildcard bits by hands.

Purple

Re: not able to see eigrp neighbour

Your network statement looks ok , can you ping the addresses on the other side . Seeing that these are directly attached you should be able to ping directly across links . Also on each side add this to f0.4 "encapsulation dot1q 4 native . It's possible the trunk is not working and thus eigrp would not come up . Also you say there is a switch in between unless that switch is setup to trunk it is not going to work either , if its a unmanaged switch it will not work because they have no concept of vlan tagging.

If its a unmanaged switch and you are just doing this to test the functionality , remove subinterfaces and put just one address on the fasthernet interface directly on each side and the eigrp should come up

Hall of Fame Super Silver

Re: not able to see eigrp neighbour

Glen

Actually the network statements do not look ok. Here is information from the oriinal post:

interface FastEthernet0.4

ip address 192.168.4.2 255.255.255.252

router eigrp 100

network 192.168.0.0

The network statement will match class C network 192.168.0.x and not 192.168.4.x.

One good way to verify this issue (and a good troubleshooting tool) would be to do show ip eigrp interface. It would show that only one of the subinterfaces was included in EIGRP.

I believe that SSLIN was quite right in suggesting a change in the network statement.

HTH

Rick

Purple

Re: not able to see eigrp neighbour

I think it will work ok , it is saying is if the first two octets in the interface address match 192.168 .x.x then it will put it in the routing table as long as they have no auto-summary configured . We have a whole network like this and it works fine . We have a whole bunch of separate 10.x.x.x networks and the network statement is 10.0.0.0 with no mask and it works fine . You can certainly get more granular with your statements if you wish .

Hall of Fame Super Silver

Re: not able to see eigrp neighbour

Glen

It will NOT work ok. You are overlooking the difference between a class A network (10.0.0.0) and a class C network (192.168.0.0). When you put a network statement without a mask in EIGRP then it will match anything within that particular network. So if your network statement is 10.0.0.0 it will match any interface address within class A 10.0.0.0. But if your network statement is 192.168.0.0 it will match any interface address within class C 192.168.0.0 but will not match 192.168.4.0.

HTH

Rick

Purple

Re: not able to see eigrp neighbour

Your right for some reason that just wasn't clicking about the classfull boundaries .

Hall of Fame Super Silver

Re: not able to see eigrp neighbour

Glen

It is a very easy thing to overlook - especially when we spend so much time with a classless view of how things work.

HTH

Rick

New Member

Re: not able to see eigrp neighbour

dear engineer ,

im not agree with the ip address want to change . i would to say u must check layer 2 network iman in 1st u make ping to see if routers see them selves or not and in 2nd u must see how vlan works and check ur router

in the last i want to talking about ip address why this ip is wrong . isee this ip is write when he configure vlan on router put ip 192.168.4.0 and when use eigrp use big subnet that big than this subnet may be that found another subnet and make subnet to write the command one line

thax ,

amr

211
Views
5
Helpful
9
Replies