Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Not getting IP from dhcp pool cisco 887-VA-K9

Hi all.  Can someone look at my config and explain why i am not getting an IP from the router when connected over ethernet cable.  Have tried on 2 different laptops, both just show as unidentified network.  have tried 2 ethernet cables and all 4 ethernet ports on the cisco

TheBeast#sh run
Building configuration...

Current configuration : 2560 bytes
!
! Last configuration change at 19:33:24 UTC Sat Sep 28 2013
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TheBeast
!
boot-start-marker
boot system flash:c880data-universalk9-mz.151-4.M4.bin
boot-end-marker
!
!
no logging console
enable secret 4 ##############################
!
no aaa new-model
memory-size iomem 10
crypto pki token default removal timeout 0
!
!
ip source-route
!
!
!
ip dhcp excluded-address 192.168.0.1 255.255.255.255
ip dhcp excluded-address 192.168.0.12 255.255.255.255
!
ip dhcp pool HomeNetwork
import all
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 62.24.199.13 62.24.199.23
lease 0 2
!
!
ip cef
ip name-server 62.24.199.13
ip name-server 62.24.199.23
no ipv6 cef
!
!
license udi pid CISCO887VA-K9 sn FCZ17119094
!
!
vtp mode transparent
!
!
!
!
controller VDSL 0
firmware filename flash:vdsl.bin-A2pv6C035d_d23j
!
vlan 10
!
!
!
!
!
!
!
!
interface Ethernet0
no ip address
ip virtual-reassembly in
!
interface Ethernet0.101
encapsulation dot1Q 101
ip address dhcp
pppoe-client dial-pool-number 1
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
pvc 0/38
  pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1432
dialer pool 1
ppp authentication chap callin
ppp chap hostname Bob
ppp chap password 0 bob
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source static tcp 192.168.0.12 53 interface Dialer0 53
ip nat inside source static udp 192.168.0.12 53 interface Dialer0 53
ip nat inside source static tcp 192.168.0.12 80 interface Dialer0 80
ip nat inside source static udp 192.168.0.12 88 interface Dialer0 88
ip nat inside source static tcp 192.168.0.12 3074 interface Dialer0 3074
ip nat inside source static udp 192.168.0.12 3074 interface Dialer0 3074
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 101 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
end

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Not getting IP from dhcp pool cisco 887-VA-K9

Your excluded-address command seems to be a culprit. Instead of defining one single host you are giving it a range from 192.168.0.1 to 255.255.255.255, that is excluding all of the addresses, thats why your client are not getting ips

5 REPLIES
New Member

Not getting IP from dhcp pool cisco 887-VA-K9

Do the following

1) ip dhcp excluded-address 192.168.0.1

    ip dhcp excuded-address 192.168.0.12

and remove "import all" from dhcp pool and then let us know

New Member

Not getting IP from dhcp pool cisco 887-VA-K9

Your excluded-address command seems to be a culprit. Instead of defining one single host you are giving it a range from 192.168.0.1 to 255.255.255.255, that is excluding all of the addresses, thats why your client are not getting ips

New Member

Not getting IP from dhcp pool cisco 887-VA-K9

Thanks All.

Doh, how did i miss that.  yes, working fine now.

New Member

Not getting IP from dhcp pool cisco 887-VA-K9

Thanks for rating..

Silver

Not getting IP from dhcp pool cisco 887-VA-K9

Hi Ste,

You have excluded every address in range from 192.168.0.1 to 255.255.255.255

ip dhcp excluded-address 192.168.0.1 255.255.255.255

ip dhcp excluded-address 192.168.0.12 255.255.255.255

The second address is not mask, it is the high address from range.

Syntax:

Router(config)# ip dhcp excluded-address low-address [high-address]

Best regards,

Jan

449
Views
10
Helpful
5
Replies
CreatePlease to create content