Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Not getting trap while removing SFP

Dear All,

         I am not getting any trap messages while removing SFP port  in 6513 Switch via console...There was no problem while removing modules.

How i will rectify that problem?

Please help me

Senthil

Everyone's tags (3)
8 REPLIES

Re: Not getting trap while removing SFP

Dear All,

        I am not getting any trap messages while removing SFP port  in 6513 Switch via console...There was no problem while removing modules.

How i will rectify that problem?

Please help me

Senthil

Hi Senthil,

Check out the below configuration logging console on your switch

BD(config)#logging console
BD(config)#^Z

Hope to help !!

Ganesh.H

Remember to rate the helpful post

Community Member

Re: Not getting trap while removing SFP

Dear Ganesh,

I tried that command also..But still i am not getting  the log via console.

What to do? Other than that is there any solution?

Tks&Rgds

Senthil

Re: Not getting trap while removing SFP

Dear Ganesh,

I tried that command also..But still i am not getting  the log via console.

What to do? Other than that is there any solution?

Tks&Rgds

Senthil

Senthil,

Can you configure the following commands and check the logs are coming on console :-

logging console
logging monitor
logging buffered 16384
logging event link-status
service timestamps log datetime localtime show-timezone msec
logging on

Hope to help !!

Ganesh.H

Remember to rate the helpful post

Community Member

Re: Not getting trap while removing SFP

Dear Mr.Ganesh,

                        I tried that command also..Still i am not getting any trap via console while removing the SFP in 6513 Switch.The configuration of that sfp port as below,

interface GigabitEthernet6/1
no ip address
shutdown
end

I resetted the module..Still i cant get the trap.

May 17 19:43:35.266 IST: %C6KPWR-SP-4-DISABLED: power to module in slot 6 set off (Reset)

switch2#sh int gi6/4
GigabitEthernet6/4 is administratively down, line protocol is down (disabled)

Whether we have to configure anything for that?

Tks&Rgds

Senthil

Re: Not getting trap while removing SFP

Dear Mr.Ganesh,

                       I tried that command also..Still i am not getting any trap via console while removing the SFP in 6513 Switch.The configuration of that sfp port as below,

interface GigabitEthernet6/1
no ip address
shutdown
end

I resetted the module..Still i cant get the trap.

May 17 19:43:35.266 IST: %C6KPWR-SP-4-DISABLED: power to module in slot 6 set off (Reset)

switch2#sh int gi6/4
GigabitEthernet6/4 is administratively down, line protocol is down (disabled)

Whether we have to configure anything for that?

Tks&Rgds

Senthil

Hi Senthil,

Can you make the port in up and up status and then do no shut to the port and check if the trap is coming on console or not.

Hope to Help !!

Ganesh.H

Community Member

Re: Not getting trap while removing SFP

Dear Ganesh,

               Finally i got the answer for that question..Normally SFP wont give any trap/log while removing/inserting into Switch.If any problem with that SFP, that time only we will be getting error message like

.(like SYS-3-TRANSCEIVER_NOTAPPROVED:Transceiver on port [dec]/[dec] is not supported)

After connecting any fiber/copper cable to that port,  You will get log message on that.
(http://www.cisco.com/en/US/products/hw/modules/ps4999/products_tech_note09186a00807a30d6.shtml)

Thank you for replying my post.Tell me whether i am telling correct.

Tks&Rgds

Senthil

Re: Not getting trap while removing SFP

Dear Ganesh,

              Finally i got the answer for that question..Normally SFP wont give any trap/log while removing/inserting into Switch.If any problem with that SFP, that time only we will be getting error message like

.(like SYS-3-TRANSCEIVER_NOTAPPROVED:Transceiver on port [dec]/[dec] is not supported)

After connecting any fiber/copper cable to that port,  You will get log message on that.
(http://www.cisco.com/en/US/products/hw/modules/ps4999/products_tech_note09186a00807a30d6.shtml)

Thank you for replying my post.Tell me whether i am telling correct.

Tks&Rgds

Senthil

Hi Senthil,

As per my understanding OIR is supported on the SFP module slot. When the SFP is inserted and removed when the system is operational, a syslog message like the following is generated.

%HWIC_1GE_SFP-6-SFP_IN: Interface GigabitEthernet0/2/0 1000BaseT SFP has been inserted
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2/0, changed state to up
%HWIC_1GE_SFP-6-SFP_OUT: Interface GigabitEthernet0/2/0 SFP has been removed
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2/0, changed state to down

Check out the below link for more information

http://www.cisco.com/en/US/prod/collateral/routers/ps5854/prod_qas0900aecd80169bf0_ps5949_Products_Q_and_A_Item.html

Anyhow thanks for the message in your previous post about SFP let me check in more detail is sfp provides syslog messages or not.

Hope to Help !!

Ganesh.H

Re: Not getting trap while removing SFP

Another way to do this is to use EEM. You can send a message to your syslog server when you see something happen in the device's log. See if your device supports it:

http://www.cisco.com/en/US/docs/ios/netmgmt/configuration/guide/nm_eem_policy_cli_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1053582

HTH,

John

HTH, John *** Please rate all useful posts ***
1104
Views
5
Helpful
8
Replies
CreatePlease to create content