Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Odd OSPF behavior with /16 showing as /23

I have a 6509 with a vlan confifured as shown below. I want to supernet the two /23 networks to a single /22, but if I change the interface to be 'ip address 162.212.188.3 255.255.252.0' OSPF stops advertising the network to other routers in the same OSPF area.

my current Vlan config:

interface Vlan6

ip address 162.212.188.3 255.255.254.0 secondary

ip address 162.212.191.3 255.255.254.0

no ip redirects

If I do a '>sho ip route' I get the below output, where it shows the 162.212.0.0 as being a /23 native network?? It shows my other network as the expected /16 native mask subnetted for 162.208.0.0/16. it also doesn't show the /xx mask information for the two /23's that are the actual subnets of the 162.212.188.0/22 CIDR block?

     162.212.0.0/23 is subnetted, 2 subnets

C       162.212.190.0 is directly connected, Vlan6

C       162.212.188.0 is directly connected, Vlan6

     162.208.0.0/16 is variably subnetted, 19 subnets, 6 masks

C       162.208.53.160/28 is directly connected, Vlan9

C       162.208.53.176/29 is directly connected, Vlan11

C       162.208.53.184/29 is directly connected, Vlan12

O       162.208.53.128/27 [110/2] via 172.25.25.27, 00:01:15, Vlan99

ospf configuration:

!

router ospf 666

router-id 172.25.25.6

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

Everyone's tags (7)
9 REPLIES
New Member

Odd OSPF behavior with /16 showing as /23

I cant get why you named topic "OSPF behavior" there is nothing about OSPF in your question.

In your show ip route output  162.212.0.0/16 network subnetted with two equal masks so IOS shows this mask /23 in row with major network to  "preserve space and make things easer". If you see such construction you can safely assume all subnets under this network have /23 mask.

In your second case with 162.208.0.0/16 as you can see in output it "variably subnetted, 19 subnets, 6 masks" so there is no possibility to show with union mask all subnets correctly. Here IOS use native mask in row with major network, and shows subnets mask in corresponded rows with subnets itself.

New Member

Re: Odd OSPF behavior with /16 showing as /23

My question is completely an OSPF question.

If I configure my Vlan as:

ip address 162.212.188.3 255.255.252.0

Then the OSPF neighbors to this router do not get the advertisement for the 162.212.188.0/22 route. It only works with a /23 or longer mask.

That is my question. Why does the router not advertise the /22, when it can advertise the /23 just fine.

thanks

New Member

Re: Odd OSPF behavior with /16 showing as /23

Can you post here outputs of

show ip ospf interfaces brief

show ip ospf neighbor

show ip ospf database router 172.25.25.6

during you have ip address 162.212.188.3 255.255.252.0 configured from 172.25.25.6 router

and from neighbor where you stop observe those network.

Besides in which vlan this router have neighbors? Maybe problem in this that it have neighbor in vlan 6 but to establish neighborship both routers must have ip addresses belonged to same network (same mask on both ends is mandatory for ospf).

New Member

Re: Odd OSPF behavior with /16 showing as /23

this router is an OSPF neighbor to a 7206vxr on Vlan 99. That router is the one that stops seeing the advertisement if I change the Vlan masks from 255.255.254.0 to 255.255.252.0.

So I have it working as configured below.

6509:

Vlan 6

ip address 162.212.188.3 255.255.254.0 secondary

ip address 162.212.191.3 255.255.254.0

!

interface Vlan99

ip address 172.25.25.28 255.255.255.248

!

router ospf 666

router-id 172.25.25.6

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

7206VXR:

interface GigabitEthernet0/2

ip address 172.25.25.26 255.255.255.248

!

router ospf 666

router-id 162.208.52.2

log-adjacency-changes

network 162.208.52.2 0.0.0.0 area 0

network 172.25.25.26 0.0.0.0 area 0

network 192.168.255.254 0.0.0.0 area 0

default-information originate always

!

If I make this change to supernet the two /23's to a /22, the 7206VXR drops it's route to 162.212.188.0/23 and 162.212.190/23, but does not learn of 162.212.188.0/22

6509:

Vlan 6

ip address 162.212.188.3 255.255.252.0

!

interface Vlan99

ip address 172.25.25.28 255.255.255.248

!

router ospf 666

router-id 172.25.25.6

log-adjacency-changes

network 0.0.0.0 255.255.255.255 area 0

!

7206VXR:

interface GigabitEthernet0/2

ip address 172.25.25.26 255.255.255.248

!

router ospf 666

router-id 162.208.52.2

log-adjacency-changes

network 162.208.52.2 0.0.0.0 area 0

network 172.25.25.26 0.0.0.0 area 0

network 192.168.255.254 0.0.0.0 area 0

default-information originate always

!

thanks

New Member

Re: Odd OSPF behavior with /16 showing as /23

Can you post here outputs of

show ip ospf database router 172.25.25.6

from 6509 and 7206vxr, during you have ip address 162.212.188.3 255.255.252.0 configured

BTW looking at your ospf process id (666) Im not suprised with strange beahavior you get

New Member

Re: Odd OSPF behavior with /16 showing as /23

With the two /23's configured I get:

6509:

OSPF Router with ID (172.25.25.6) (Process ID 666)

        Router Link States (Area 0)

  LS age: 381

  Options: (No TOS-capability, DC)

  LS Type: Router Links

  Link State ID: 172.25.25.6

  Advertising Router: 172.25.25.6

  LS Seq Number: 8000138C

  Checksum: 0x4BB6

  Length: 312

  Number of Links: 24

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 172.25.25.6

     (Link Data) Network Mask: 255.255.255.255

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

    Link connected to: a Transit Network

     (Link ID) Designated Router address: 162.212.191.2

     (Link Data) Router Interface address: 162.212.191.3

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 162.212.188.0

     (Link Data) Network Mask: 255.255.254.0

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

7206:

OSPF Router with ID (162.208.52.2) (Process ID 666)

        Router Link States (Area 0)

  LS age: 312

  Options: (No TOS-capability, DC)

  LS Type: Router Links

  Link State ID: 172.25.25.6

  Advertising Router: 172.25.25.6

  LS Seq Number: 8000138C

  Checksum: 0x4BB6

  Length: 312

  Number of Links: 24

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 172.25.25.6

     (Link Data) Network Mask: 255.255.255.255

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

    Link connected to: a Transit Network

     (Link ID) Designated Router address: 162.212.191.2

     (Link Data) Router Interface address: 162.212.191.3

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 162.212.188.0

     (Link Data) Network Mask: 255.255.254.0

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

with the single /22 configured I get:

6509:

            OSPF Router with ID (172.25.25.6) (Process ID 666)

        Router Link States (Area 0)

  LS age: 48

  Options: (No TOS-capability, DC)

  LS Type: Router Links

  Link State ID: 172.25.25.6

  Advertising Router: 172.25.25.6

  LS Seq Number: 8000138A

  Checksum: 0x7514

  Length: 300

  Number of Links: 23

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 172.25.25.6

     (Link Data) Network Mask: 255.255.255.255

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 162.212.188.0

     (Link Data) Network Mask: 255.255.252.0

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

7206VXR:

OSPF Router with ID (162.208.52.2) (Process ID 666)

        Router Link States (Area 0)

  LS age: 25

  Options: (No TOS-capability, DC)

  LS Type: Router Links

  Link State ID: 172.25.25.6

  Advertising Router: 172.25.25.6

  LS Seq Number: 8000138A

  Checksum: 0x7514

  Length: 300

  Number of Links: 23

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 172.25.25.6

     (Link Data) Network Mask: 255.255.255.255

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

    Link connected to: a Stub Network

     (Link ID) Network/subnet number: 162.212.188.0

     (Link Data) Network Mask: 255.255.252.0

      Number of TOS metrics: 0

       TOS 0 Metrics: 1

New Member

Re: Odd OSPF behavior with /16 showing as /23

Thanks for your help, i found the problem. It was not that OSPF was not advertising, the 7206VXR is doing BGP to the internet. and the 162.212.188.0/22 route is one of the BGP advertised prefixes. This meant that there was a "hold-down" null0 route for 162.212.188.0.22 that was taking precedence over the OSPF advertised 162.212.188.0/22 route coming from the 6509. I removed the "hold down" route, and the 162.212.188.0/22 advertisement started showing up on the 7206VXR.

Now I need to figure out what I should be doing on the 7206VXR for a "hold down" route for the BGP advertisement of 162.212.188.0/22 that is going out to the internet.

All my other Vlan interfaces are subnets of my BGP advertisements, only this /22 happens to also match a BGP advertisement.

Thanks

New Member

Re: Odd OSPF behavior with /16 showing as /23

I suggest to took one address from range 162.212.188.0/22  and assign it  to 7206VXR loopback, under bgp process configure redistribute connected (possibly with route-map to limit redistributed routes only to loopback interface) and and

aggregate-address162.212.188.0/22 summary-only

With such construction 7206VXR will advertise only  prefix 162.212.188.0/22 always, independently  of OSPF. BTW trick with redistribute connected  and using summary-only keyword will supress propagation of subnet (in our case only one address) assigned to loopback.

The only problem here that advertised network will have in origin atribute undifined - "?", if you want to have IGP origin for this network just add network 162.212.188.0 mask 255.255.252.0 under BGP process as well.

.

New Member

Re: Odd OSPF behavior with /16 showing as /23

Hm, the first thing i noticed

that in 162.212.191.0/23 network your have  other router which one selected as designated for segment - it have ip

162.212.191.2 in this subnet.

When you change side of 6509 to /22 subnet have you made corresponded changes to router with 162.212.191.2 ip?

Besides provide output from 7206VXR show ip route | i 162.212.

Have you red article Why Are Some OSPF Routes in the Database but Not in the Routing Table?

244
Views
0
Helpful
9
Replies