Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

odd STP/arp issue???

Hi, I have a Ethernet RING consisting of 5 switches, 4 3524-XL and 1 6509 running IOS. The 6509 is the root of the topology and is connected to the rest of the switches via two Ethernet feeds. I’m using 10.10.10.x/24 for mgt ips off these 3500's switches i have customers on different ip ranges.

On the 4 3524-XL switches’ everything is configured as VLAN1 and on the 6509 this ring topology is configured as a vlan (vlan105, see below). The issue I’m running into is that when I turn down a link, to force a change, on a 3524-XL switches the change gets propagated fast but not on the 6509 or so it seems.

For some reason the 6509 takes a lot of time around 10-15+ minutes to be able to ping the 3534-XL’s ip address, usually on the switch I forced the interface change, while all the 3534-XL can ping each other after the STP propogation, usualy around 5 min.

Also  the switch I made the change can’t ping the 6509 either (root switch, 10.10.10.1). I’m trying to figure out why the 6509 is not able to ping the 3524-XL ip as fast as the rest of the 3524-XL switches can. The weird part is if a link goes down on its own without intervention from me the propagation on the 6500 seems a lot quicker.

This seems like an arp issue but im not sure and I’m confused as to was is going on, if someone has any suggestions that would be greatly apriciated.

Sample 3500 config

spanning-tree uplinkfast

!

spanning-tree portfast bpduguard

spanning-tree portfast bpdufilter default

ip subnet-zero

!

interface FastEthernet0/1

spanning-tree portfast

!

interface FastEthernet0/2

spanning-tree vlan 1 cost 4000

!

interface FastEthernet0/3

spanning-tree portfast

!

interface FastEthernet0/5

spanning-tree vlan 1 cost 40

VLAN1

  Spanning tree enabled protocol IEEE

  ROOT ID    Priority 30000

             Address 0009.12a7.3869

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49152

             Address     0009.4388.0f40

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

6400 config info:

interface Vlan105

ip address x.x.x.x 255.255.255.192 secondary

ip address x.x.x.x 255.255.255.192 secondary

ip address x.x.x.x 255.255.255.192 secondary

ip address x.x.x.x 255.255.255.192 secondary

ip address x.x.x.x 255.255.255.252 secondary

ip address x.x.x.x 255.255.255.252 secondary

ip address x.x.x.x 255.255.255.248 secondary

ip address x.x.x.x 255.255.248.0 secondary

ip address 10.10.10.1 255.255.255.0 ß ring ips

ip access-group 130 in

ip access-group MBW out

no ip redirects

ip route-cache flow

service-policy input trust-dscp

VLAN0105

  Spanning tree enabled protocol rstp

  Root ID    Priority    30000

             Address     0009.12a7.3869

             This bridge is the root

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    30000

             Address     0009.12a7.3869

             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa1/5            Desg FWD 19        128.5    P2p Peer(STP)

Fa1/7            Desg FWD 19        128.7    P2p

Fa1/8            Desg FWD 100       128.8    Shr

Fa1/9            Desg FWD 100       128.9    Shr

Fa1/10           Desg FWD 19        128.10   P2p Peer(STP)

Fa2/34           Desg FWD 19        128.162  Edge P2p

thanks, Paul

9 REPLIES

Re: odd STP/arp issue???

This is surely an STP issue. Your setup raises more questions than anwers:

What is the portconfig on the interfaces of the 6509 towards the other switches?

Trunk or access, ISL or dot1Q?

Why do you use different vlan ID's on the 6509 and the 3500's?

(not necessarily wrong bit introducing extra complexity to the scenario> more info needed)

Why is the 6509 running another protocol than the 3500's?

(RSTP vs 802.1d; same remarks as previous)

How did you configure the links between the 3500 switches?

(just curious)

New Member

Re: odd STP/arp issue???

lgijssel,

the 6500 interface's to the 3500 switch are configure like this

interface FastEthernet1/5
description To Switched ring
switchport
switchport access vlan 105
switchport mode access
no ip address
mls qos vlan-based
!

Note that is configured as an access port so its not using ISL/dot1Q

I'm using too different VLAN id's because there is only one vlan on the 3500, and more then one on the 6500  so using vlan1 on the 3500 is not a problem.

As for the STP protocols, on the 3500's im using "Spanning tree 1 is executing the IEEE compatible Spanning Tree protocol"

Here are my choices for the 3500:

3500(config)#spanning-tree protocol ?
  ibm   IBM spanning-tree protocol
  ieee  IEEE Ethernet spanning-tree protocol

For the 6509 im using "VLAN0105 Spanning tree enabled protocol rstp"

6509(config)#spanning-tree mode ?
  mst         Multiple spanning tree mode
  pvst        Per-Vlan spanning tree mode
  rapid-pvst  Per-Vlan rapid spanning tree mode

I was under the impression that the 3500 use RSTP and I'm using " rapid-pvst" on the 6509, note that i tried PVST on the 6509 and that caused the same problem also.

the links are configured as follow, from the 6509 there is two ethernet links to two 3500 switches. its all ethernet between the 3500's also.

thanks for the reply, paul

Re: odd STP/arp issue???

Probably the most significant change to make is removing the "uplinkfast" feature.

This feature does not match with your setup because it was designed to work in a collapsed backbone topology instead of in a ring.

For more or less the same reasons, you should also remove any "backbonefast" commands when found.

Finally, you can match the STP protocols over the entire network by selecting "ieee" for the 3500's altough I presume that is what's there now.

For the 6500, select PVST, this is the IEEE 802.1D protocol with enhancements for use on networks with multiple vlans.

RSTP is backward compatible so you should try the other suggestion first.

Personally I dislike the idea of using different STP protocols and it doesn't make a difference here anyway.

Convergence time should be about 60 seconds with good old 802.1D.

regards,

Leo

New Member

Re: odd STP/arp issue???

i will try your suggestions and update with that happens. thanks.

paul

New Member

Re: odd STP/arp issue???

so i ddi what was suggested and it still took the 6509 over 10 min to see the change.

Re: odd STP/arp issue???

Can you repeat the test while doing a debug on the 6500?

debug spanning-tree events

Also please provide IOS version information on the boxes.

Leo

New Member

Re: odd STP/arp issue???

Leo,

6509 System image file is "disk0:s72033-advipservicesk9_wan-mz.122-18.SXF14.bin"

3500's System image file is "flash:c3500xl-c3h2s-mz.120-5.WC11.bin"

I will provide the debug info when i can obtain it but I wouldnt be suprised if this is some odd 6509 behavior, there's a lot of odd things about that switch.

Re: odd STP/arp issue???

Maybe you are right, I just noticed another oddity:

Your 3500's look to me like 2900 series.

Meanwhile the link below may give you some interesting reading on the subject:

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a0080094797.shtml

New Member

Re: odd STP/arp issue???

oops, looks like i have one 2900 and the rest are 3500 with the 6509 as the root.

the 3500 is using flash:c3500xl-c3h2s-mz.120-5.WC11.bin and the 2900 is using flash:c2900xl-c3h2s-mz.120-5.WC17.bin, sorry for the confusion i been looking at this for too long.

316
Views
0
Helpful
9
Replies
CreatePlease login to create content