Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

offset-list failing

I am attempting to apply an inbound offset list to my EIGRP setup. I create the ACL but when I try to apply it to EIGRP AS 12 I get the following error message: % Invalid access list name. What is worse, it seems to add a line to my EIGRP config automatically: offset-list 0 in 3 Serial0/0

See my output below. I'm not sure why this is not working. I am following the instructions in my CCNP Route book but it does not mention these issues.

R4#show ip access-lists

Extended IP access list 111
    10 permit ip host 172.16.1.0 host 255.255.255.0

R4#show run | s router
router eigrp 12
network 10.2.2.0 0.0.0.3
network 10.4.4.0 0.0.0.3
network 192.168.4.0
no auto-summary
eigrp router-id 4.4.4.4
R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#router eigrp 12
R4(config-router)#offset-list 111 in 3 serial 0/0
% Invalid access list name.
R4(config-router)#^Z
R4#
*Mar  1 00:30:05.819: %SYS-5-CONFIG_I: Configured from console by console
R4#show run | s router
offset-list 0 in 3 Serial0/0
network 10.2.2.0 0.0.0.3
network 10.4.4.0 0.0.0.3
network 192.168.4.0
no auto-summary
eigrp router-id 4.4.4.4
R4#

I wish to confirm a couple of things:

1) The ACL must permit the network whose metric is being offset and NOT the EIGRP neighbour IP that is giving these metrics. Right?

2) Why the extened ACL is generating a fault and why the router is automatically creating this extra line.

3) When I add an offset-list, do I need to bounce the interface in question? It seems like I do not need to, but I thought updates where only sent with a topology change...

Thanks in advance.

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Gold

offset-list failing

Steven, this should be a printing error then, Double check everything u read as u did now, coz there is always a small chance of typo or faulty editing !

Hope it Helps,

Soroush.

Hope it Helps, Soroush.
5 REPLIES
Gold

Re: offset-list failing

Hi Steven,

I think u mistakenly misconfigured your access list: host 172.16.1.0 host 255.255.255.0 ? try using an standard access-list with proper ip and wildcard mask.

the automatic command "offset-list 0…" means all routes that are coming in from int serial 0/0. get an offset of 3, and thats because you got ur access-list wrong (invalid).

the interface you add at the end, limits the offset application to the updates (defined in the ACL) that are comming from that particular int. if you remove it, it applies to that ACL comming in all interfaces.

HTH

plz Rate if it helped,


Soroush.

Hope it Helps, Soroush.
New Member

offset-list failing

I am taking host 172.16.1.0 host 255.255.255.0 directly from my CCNP ROUTE book.

The configuration works with a standard ACL no problems - I just wish to check if I can use extended ACLs (because the book says I can) and why the offset-list 0 in 3 Serial0/0 line is added automatically.

Gold

offset-list failing

Steven, this should be a printing error then, Double check everything u read as u did now, coz there is always a small chance of typo or faulty editing !

Hope it Helps,

Soroush.

Hope it Helps, Soroush.

offset-list failing

Steven,

Offset-lists support standard acls. Try changing your acl to something less than 100 and reapply.

HTH,

John

HTH, John *** Please rate all useful posts ***
New Member

Thanks, this helped

Thanks, this helped

448
Views
6
Helpful
5
Replies