Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

one fastethernet link down in channel-group

Hi, everyone.

I have a problem when I configure two 3550-emi switch. On both 3550 switch, I have configured FEC link on fastethernet port 0/3 and 0/4. But only link is up at the same time.

The log say: %EC-5-L3DONTBNDL2: Fa0/4 suspended: incompatible partner port with Fa0/3; but the configuration on both switch and both 4 ports are same as below, I don't know why?

---------------------------------------

interface Port-channel44

no switchport

ip address 3.3.3.3 255.255.255.0

duplex full

!

interface FastEthernet0/3

description BSW2 0/3 to BSW1 0/3

no switchport

no ip address

duplex full

speed 100

channel-group 44 mode desirable

!

interface FastEthernet0/4

description BSW1 0/4 to BSW2 0/4

no switchport

no ip address

duplex full

speed 100

channel-group 44 mode desirable

!

I have try Layer 3 FEC and Layer 2 FEC(with trunk link), but the result is same.

Anyone can help me?

With Best Regards.

Tao

6 REPLIES
Community Member

Re: one fastethernet link down in channel-group

The layer 2 configuration is as below:

sw1:

-------------------------------------

interface Port-channel33

switchport trunk encapsulation dot1q

switchport trunk native vlan 951

switchport mode trunk

no ip address

end

interface FastEthernet0/3

description BSW1 0/3 to BSW2 0/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 951

switchport mode trunk

no ip address

duplex full

speed 100

channel-group 33 mode desirable

end

interface FastEthernet0/4

description BSW1 0/4 to BSW2 0/4

switchport trunk encapsulation dot1q

switchport trunk native vlan 951

switchport mode trunk

no ip address

duplex full

speed 100

channel-group 33 mode desirable

end

-----------------------

sw2

--------------------------------

interface Port-channel33

switchport trunk encapsulation dot1q

switchport trunk native vlan 951

switchport mode trunk

no ip address

end

interface FastEthernet0/3

description BSW2 0/3 to BSW1 0/3

switchport trunk encapsulation dot1q

switchport trunk native vlan 951

switchport mode trunk

no ip address

duplex full

speed 100

channel-group 33 mode desirable

interface FastEthernet0/4

description BSW1 0/4 to BSW2 0/4

switchport trunk encapsulation dot1q

switchport trunk native vlan 951

switchport mode trunk

no ip address

duplex full

speed 100

channel-group 33 mode desirable

-------------------------------------

But the result is same, only fas0/3 is up, line protocol in fas0/4 is down, log say:

Mar 1 14:55:49.212: %EC-5-L3DONTBNDL2: Fa0/4 suspended: incompatible partner port with Fa0/3

*Mar 1 14:55:57.188: %EC-5-L3DONTBNDL2: Fa0/4 suspended: incompatible partner port with Fa0/3

*Mar 1 14:56:27.196: %SM-4-BADEVENT: Event 'link_down' is invalid for the current state 'link_down': pm_port 0/3

-Traceback= 34A88C 32F000 2F8954 345CE8 346358 1C6440

*Mar 1 14:56:33.632: %EC-5-L3DONTBNDL2: Fa0/4 suspended: incompatible partner port with Fa0/3

*Mar 1 14:56:36.328: %EC-5-L3DONTBNDL2: Fa0/4 suspended: incompatible partner port with Fa0/3

anyone can help me?

Very thanks

Tao

Community Member

Re: one fastethernet link down in channel-group

when I finished the configuration as above, line protocaol on fa0/3 is up, but line protocaol on fas 0/4 is down.

Then i shutdown the fas0/3, line protocol on fas0/4 is up immediately.

why?

Re: one fastethernet link down in channel-group

Hi

Can u try this.Dnot create the port-channel interface as when u assign the ports in a switch to form a channel it will be automatically created.

Thanks

Mahmood

Community Member

Re: one fastethernet link down in channel-group

Thanks, Mood.

I have try it again. And I found when i change channel-group mode to on from desirable, it is ok. But when i change to desirable again, same result. But port-channel interface is up always.

Who can give some advise. In production network, should I make it mode on or desirable?

Purple

Re: one fastethernet link down in channel-group

Try adding the non-silent command at the end of the port channel statement for all interfaces and see what happens . Also for all your attaching ports make sure you have added the "switchport" command to make it a non routed port for a lyer 2 etherchannel.

channel-group 33 mode desirable non-silent

Community Member

Re: one fastethernet link down in channel-group

Tao,

try this setting the channel-group mode on switch1 to "desirable" and the channel-group mode on the switch2 to "auto"

Switch1:

channel-group 33 mode desirable

Switch2:

channel-group 33 mode auto

rgds.

ben

452
Views
0
Helpful
6
Replies
CreatePlease to create content