Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Optimized Edge Routing (OER) -- classes learning process.

Hello everyone,

I am new here so let me introduce myself briefly.  My name is Alexis, I'm a Belgian IT student and I work in a small business environnement as a trainee. 

I am asked to found and setup a cisco solution that offers load balancing between two different ISP. 

I configured a first solution using IP SLA and PBR.  It work pretty well.  But the problem is it doesn't look like I can do dynamic load balancing. If I am wrong, dont hesitate to correct me.

Then I searched a little bit more and I found OER (Maybe better known as PfR today ?).  Cisco documentation says it can do intelligent load balancing so I suppose it's the perfect choice.

I started reading the whole document about it.  I have to admit, it was not easy to understand everything (still don't by the way) but I thought I could give it a try in a lab environnement.

To help you understand better, I joined the basic topology.

As you can see, I need to configure an OER master and an OER border on the same router (1841 with IOS Version 12.4(25d)).

The problem is that the router does not profile any traffic classes.  So the main process won't work since Profiling Traffic Classes is the first step in OER.  When I use the show oer master prefix command, I get nothing.  I expected to see classes related to the traffic going through the router...   Am I wrong ?

Of course if you need more information, just ask.

Hope you can help.  

Thank you.

Alexis

Here is the configuration I used :

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

!

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

key chain OER

key 1

   key-string cisco

oer master

logging

!

border 172.16.13.100 key-chain OER

  interface Vlan1 internal

  interface FastEthernet0/1 external

  interface FastEthernet0/0 external

!

learn

  throughput

  delay

  periodic-interval 2

  monitor-period 1

mode route control

!

oer border

logging

local Loopback0

master 172.16.13.100 key-chain OER

!

!

username Alexis privilege 15 secret 5 $1$UXem$pmZh1uUxYgk1vfhBmB1YO/

!

!

!

!

!

!

interface Loopback0

ip address 172.16.13.100 255.255.255.0

!

interface FastEthernet0/0

description openweb

ip address 172.16.14.10 255.255.255.0

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

description voo

ip address dhcp               //public ip address given by ISP2

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/1

no ip address

shutdown

clock rate 2000000

!

interface Vlan1

ip address 10.10.10.254 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.16.14.1

ip route 0.0.0.0 0.0.0.0 85.85.85.1          // Default Gateway for ISP2

!

!

no ip http server

no ip http secure-server

ip nat inside source route-map ISP1-NAT interface FastEthernet0/0 overload oer

ip nat inside source route-map ISP2-NAT interface FastEthernet0/1 overload oer

!

access-list 1 permit 10.10.10.0 0.0.0.255

!

route-map ISP2-NAT permit 10

match ip address 1

match interface FastEthernet0/1

!

route-map ISP1-NAT permit 10

match ip address 1

match interface FastEthernet0/0

!

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

logging synchronous

login local

!

scheduler allocate 20000 1000

end
2 ACCEPTED SOLUTIONS

Accepted Solutions
Bronze

Optimized Edge Routing (OER) -- classes learning process.

I loaded your IOS into GNS3 and created a similar topology. I was unable to get OER to learn traffic as well, even though I could see it in NetFlow.

I'm not too familiar with OER on that code. I do know OER is pretty finicky and buggy on some platforms. If possible I'd try a 12.4T image.

Good luck.

Super Bronze

Optimized Edge Routing (OER) -- classes learning process.

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

Correct, 12.4 OER doesn't support classes.  You need 12.4T (or later) PfR for classes feature.

7 REPLIES
Bronze

Optimized Edge Routing (OER) -- classes learning process.

Try specifying traffic types under "learn" with either the "protocol" command or "traffic-class" command.

New Member

Optimized Edge Routing (OER) -- classes learning process.

Hi ajnallicruz,

First of all, thank you for your help.  Very much appreciated !

I tryed with the protocol command but it still not learning anything. 

Looks like the traffic-class command does not exist in my IOS version (Version 12.4(25d)).

Anything else you can come up with ?

Alexis

Bronze

Optimized Edge Routing (OER) -- classes learning process.

I'm at a client site today. If my wife manages to pry the iPad3 from my fingers tonight I'll load it up in GNS3 with your IOS.

New Member

Optimized Edge Routing (OER) -- classes learning process.

Hi ajnallicruz,

Did you manage to make it work ?

Bronze

Optimized Edge Routing (OER) -- classes learning process.

I loaded your IOS into GNS3 and created a similar topology. I was unable to get OER to learn traffic as well, even though I could see it in NetFlow.

I'm not too familiar with OER on that code. I do know OER is pretty finicky and buggy on some platforms. If possible I'd try a 12.4T image.

Good luck.

New Member

Optimized Edge Routing (OER) -- classes learning process.

I agree, 12.4T releases seem to have much more OER features BUT I have a second hand router with no customer contract so I am stuck with IOS 12.4. 

Thanks for your help anyway.

Super Bronze

Optimized Edge Routing (OER) -- classes learning process.

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

Correct, 12.4 OER doesn't support classes.  You need 12.4T (or later) PfR for classes feature.

463
Views
0
Helpful
7
Replies
CreatePlease login to create content