Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

%OSPF-5-ADJCHG: Neighbor Down: Dead timer expired

Hi All,

I am seeing a lot of OSPF "Dead timer expired" and OSPF adjacency drop off for for R1 (see below).

Physical topology.

R1 (Cisco 7206) --> R2 (Cisco 7606)

R1 = 203.17.101.x

R2 = DR = 203.17.101.A

Is there a way to narrow down what is causing this? My understanding is that the dead timer is an indication that no hello packets are being received. I can also confirm that the link between R1 and R2 remains up/up.

This is the log from another router running the same OSPF process showing R1 going down.

Nov 30 05:47:32.342 AEDT: %OSPF-5-ADJCHG: Process 100, Nbr 203.17.101.x
on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

Nov 30 06:15:32.401 AEDT: %OSPF-5-ADJCHG: Process 100, Nbr 203.17.101.x
on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

Nov 30 17:43:32.140 AEDT: %OSPF-5-ADJCHG: Process 100, Nbr 203.17.101.x
on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

Dec  1 00:35:09.808 AEDT: %OSPF-5-ADJCHG: Process 100, Nbr 203.17.101.x
on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

Dec  1 00:59:46.163 AEDT: %OSPF-5-ADJCHG: Process 100, Nbr 203.17.101.x
on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

Dec  1 05:28:56.613 AEDT: %OSPF-5-ADJCHG: Process 100, Nbr 203.17.101.x
on GigabitEthernet0/0 from 2WAY to DOWN, Neighbor Down: Dead timer expired

R1:

R1#sh ip ospf interface gigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
  Internet Address 203.10.110.x/27, Area 0.0.0.0
  Process ID 100, Router ID 203.17.101.x, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DROTHER, Priority 1
  Designated Router (ID) 203.17.101.A, Interface address 203.10.110.A
  Backup Designated router (ID) 203.17.101.B, Interface address 203.10.110.B
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:05
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 0, maximum is 40
  Last flood scan time is 0 msec, maximum is 28 msec
  Neighbor Count is 17, Adjacent neighbor count is 2
    Adjacent with neighbor 203.17.101.A  (Designated Router)
    Adjacent with neighbor 203.17.101.B  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

R2:

R2#sh ip ospf interface vlan 11
Vlan11 is up, line protocol is up
  Internet Address 203.10.110.A/27, Area 0
  Process ID 100, Router ID 203.17.101.A, Network Type BROADCAST, Cost: 2
  Transmit Delay is 1 sec, State DR, Priority 15
  Designated Router (ID) 203.17.101.A, Interface address 203.10.110.A
  Backup Designated router (ID) 203.17.101.B, Interface address 203.10.110.B
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:06
  Supports Link-local Signaling (LLS)
  Index 3/3, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 40
  Last flood scan time is 0 msec, maximum is 8 msec
  Neighbor Count is 17, Adjacent neighbor count is 17
    Adjacent with neighbor 203.17.101.x
    Adjacent with neighbor 203.17.101.y
    Adjacent with neighbor 203.17.101.B  (Backup Designated Router)
    Adjacent with neighbor 203.17.101.z

.

.

  Suppress hello for 0 neighbor(s)

Thanks.

Andy

2 REPLIES
New Member

Re: %OSPF-5-ADJCHG: Neighbor Down: Dead timer expired

Could it possibly be a MTU mismatch between the two interfaces???

R1:

interface GigabitEthernet0/2
description Connect to R2:Gi2/5
ip address 203.10.110.x 255.255.255.224
ip flow ingress
load-interval 30
media-type rj45
speed 1000
duplex full
no negotiation auto
mpls ip
no clns route-cache


R2::

interface GigabitEthernet2/5
description Connect to R1:Gi0/2
switchport
switchport access vlan 11
switchport mode access
mtu 9216
no ip address
load-interval 30
speed 1000
duplex full

Notice no "mtu 9216" set on R1:Gi0/2.

Hall of Fame Super Blue

Re: %OSPF-5-ADJCHG: Neighbor Down: Dead timer expired

asaykao73 wrote:

Could it possibly be a MTU mismatch between the two interfaces???

R1:

interface GigabitEthernet0/2
description Connect to R2:Gi2/5
ip address 203.10.110.x 255.255.255.224
ip flow ingress
load-interval 30
media-type rj45
speed 1000
duplex full
no negotiation auto
mpls ip
no clns route-cache


R2::

interface GigabitEthernet2/5
description Connect to R1:Gi0/2
switchport
switchport access vlan 11
switchport mode access
mtu 9216
no ip address
load-interval 30
speed 1000
duplex full

Notice no "mtu 9216" set on R1:Gi0/2.

Andy

Yes, a mismatch in mtu would affect the neighborship.

Jon

17185
Views
0
Helpful
2
Replies