Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF and EIGRP redistribution

I have a strange problem.  Here is my topology:

I have a L3 switch with several VLANs: 10.1.1.1/24, 10.1.2.1/24 10.1.3.1/24

I have a Router with its g0 connected to the switch on 10.1.1.1/24 .  The router's g1 is connected to another network.

I'm running OSPF AND EIGRP between the switch and the router.  I am redistributing OSPF into EIGRP and vice versa on the router.

When I do a "sh ip ospf database" on the switch, the 10.1.2.1/24 and the 10.1.3.1/24 shows up as LSA type 5s.  Shouldn't these links show up as type 1 (router link states)?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

OSPF and EIGRP redistribution

Hello,

They are there but they are included in the type 1 LSA from the advertising router. Each router creates a type 1 LSA for itself. The LSA describes the router, its interfaces in that area and a list of neighboring routers on each interface. If you look again LSA with link id of 10.41.101.103 has a link count of 8. The type 5 is there because of the redistribution statement.

  Also may I ask why are running two IGPs between the devices and redistributing between the protocols?

  One more comment. Without a metric associated with your redistribute ospf 1 statement, EIGRP will not redistribute the OSPF routes. OSPF I believe applies a default metric of 20 and that's why you see the type 5 LSAs. CAUTION: Are you redistributing like this anywhere else in the network. Without the proper configuration the possibility of routing loops, suboptimal routing, etc could occur and I afraid that this misconfiguration has prevented such scenario from happening.

Regards,
Ryan

4 REPLIES
Hall of Fame Super Silver

OSPF and EIGRP redistribution

Vincent

You have not provided enough information for us to give you good answers. Please post the OSPF configuration, the interface configuration, and the output of show ip ospf interface.

HTH

Rick

New Member

OSPF and EIGRP redistribution

I'm sorry.  You'll have to disregard the IP addresses I used in the original post.  I used those for the sake of brevity.  As you can see from the 'sh ip ospf data' output, the connected networks on the switch show up as type 5 externals.

Here is my config from the switch:

interface Vlan120

ip address 10.41.120.1 255.255.255.0

no ip redirects

ip ospf message-digest-key 1 md5 7 xxxxx

end

router eigrp 1

network 10.41.1.0 0.0.0.255

network 10.41.61.0 0.0.0.255

network 10.41.101.103 0.0.0.0

network 10.41.102.0 0.0.0.255

network 10.41.111.0 0.0.0.255

network 10.41.112.0 0.0.0.255

network 10.41.117.0 0.0.0.255

network 10.41.120.0 0.0.0.255

eigrp stub connected summary

!

router ospf 1

area 0 authentication message-digest

network 10.41.1.0 0.0.0.255 area 0

network 10.41.61.0 0.0.0.255 area 0

network 10.41.101.103 0.0.0.0 area 0

network 10.41.102.0 0.0.0.255 area 0

network 10.41.111.0 0.0.0.255 area 0

network 10.41.112.0 0.0.0.255 area 0

network 10.41.117.0 0.0.0.255 area 0

network 10.41.120.0 0.0.0.255 area 0

!

Here is my config from the router:

interface GigabitEthernet0/0

description to switch

ip address 10.41.120.2 255.255.255.0

ip ospf message-digest-key 1 md5 7 xxxxx

end

router eigrp 1

redistribute static

redistribute ospf 1

network 10.41.101.1 0.0.0.0

network 10.41.120.0 0.0.0.255

network 192.168.41.0

no auto-summary

!

router ospf 1

log-adjacency-changes

area 0 authentication message-digest

redistribute static subnets

redistribute eigrp 1 subnets

network 10.41.101.1 0.0.0.0 area 0

network 10.41.120.2 0.0.0.0 area 0

network 192.168.41.41 0.0.0.0 area 0

!

Here is the "show ip ospf database: on the switch:

            OSPF Router with ID (10.41.101.103) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count

10.41.101.1     10.41.101.1     591         0x8000000A 0x00A989 3

10.41.101.102   10.41.101.102   1708        0x80000159 0x009BAB 2

10.41.101.103   10.41.101.103   1252        0x80000066 0x00F93B 8

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum

10.41.102.1     10.41.101.103   756         0x80000033 0x00CAA3

10.41.120.1     10.41.101.103   1502        0x80000007 0x00D01D

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag

0.0.0.0         10.41.101.102   1618        0x80000150 0x00D5A3 0

10.40.0.0       10.41.101.102   1728        0x80000063 0x00D505 0

10.40.1.0       10.41.101.1     349         0x80000005 0x007A9A 0

10.40.101.1     10.41.101.1     349         0x80000005 0x00208F 0

10.40.102.0     10.41.101.1     349         0x80000005 0x001F90 0

10.40.103.0     10.41.101.1     349         0x80000005 0x00149A 0

10.40.110.0     10.41.101.1     366         0x80000005 0x00C6E0 0

10.40.111.0     10.41.101.1     366         0x80000005 0x00BBEA 0

10.40.112.0     10.41.101.1     366         0x80000005 0x00B0F4 0

10.40.117.0     10.41.101.1     366         0x80000005 0x007927 0

10.40.118.0     10.41.101.1     366         0x80000005 0x006E31 0

10.40.120.0     10.41.101.1     366         0x80000005 0x005845 0

10.40.121.0     10.41.101.1     366         0x80000005 0x004D4F 0

10.41.1.0       10.41.101.1     112         0x80000003 0x0081A2 0

10.41.61.0      10.41.101.1     112         0x80000003 0x00EAFC 0

10.41.101.103   10.41.101.1     112         0x80000003 0x002731 0

10.41.102.0     10.41.101.1     112         0x80000003 0x002698 0

10.41.111.0     10.41.101.1     112         0x80000003 0x00C2F2 0

10.41.112.0     10.41.101.1     112         0x80000003 0x00B7FC 0

10.41.117.0     10.41.101.1     112         0x80000003 0x00802F 0

10.41.120.4     10.41.101.1     607         0x80000005 0x00AAA8 0

10.45.1.0       10.41.101.1     366         0x80000005 0x003ED1 0

10.45.61.0      10.41.101.1     366         0x80000005 0x00A72C 0

10.45.102.0     10.41.101.1     366         0x80000005 0x00E2C7 0

10.54.0.0       10.41.101.102   1604        0x8000002D 0x009969 0

10.54.1.0       10.41.101.1     366         0x80000005 0x00D135 0

10.54.101.1     10.41.101.1     366         0x80000005 0x00772A 0

10.54.102.0     10.41.101.1     366         0x80000005 0x00762B 0

10.54.111.0     10.41.101.1     366         0x80000005 0x001385 0

10.54.112.0     10.41.101.1     366         0x80000005 0x00088F 0

10.54.117.0     10.41.101.1     366         0x80000005 0x00D0C1 0

10.54.120.0     10.41.101.1     366         0x80000005 0x00AFDF 0

10.54.120.4     10.41.101.1     366         0x80000005 0x008704 0

192.168.35.0    10.41.101.1     366         0x80000005 0x00B506 0

192.168.36.0    10.41.101.102   1565        0x80000151 0x001C74 0

192.168.45.0    10.41.101.1     366         0x80000005 0x00476A 0

192.168.54.0    10.41.101.1     366         0x80000005 0x00B9F5 0

London-Core-Switch3560#

Cisco Employee

OSPF and EIGRP redistribution

Hello,

They are there but they are included in the type 1 LSA from the advertising router. Each router creates a type 1 LSA for itself. The LSA describes the router, its interfaces in that area and a list of neighboring routers on each interface. If you look again LSA with link id of 10.41.101.103 has a link count of 8. The type 5 is there because of the redistribution statement.

  Also may I ask why are running two IGPs between the devices and redistributing between the protocols?

  One more comment. Without a metric associated with your redistribute ospf 1 statement, EIGRP will not redistribute the OSPF routes. OSPF I believe applies a default metric of 20 and that's why you see the type 5 LSAs. CAUTION: Are you redistributing like this anywhere else in the network. Without the proper configuration the possibility of routing loops, suboptimal routing, etc could occur and I afraid that this misconfiguration has prevented such scenario from happening.

Regards,
Ryan

New Member

OSPF and EIGRP redistribution

I think your recomendation to provide a metric worked.

I'm migrating from EIGRP to OSPF, but I'm doing it one site at a time.  I don't know if this is the best method, but it seems to be working so far.

Thanks!

Vince

493
Views
0
Helpful
4
Replies
CreatePlease login to create content