Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF and redundant paths

Hi,

I'm trying to get a proof-of-concept working, and it almost does except for the final stage.

I'm trying to make a loop of switches so that if one link goes down then all switches can communicate with each other:

Switch A Port 0/48 <-> Switch B Port 0/47

Switch B Port 0/48 <-> Switch C Port 0/47

Switch C Port 0/48 <-> Switch A Port 0/47

All switches are IPServices 3560 PS POE switches.

I am also trying to integrate OSPF with this setup with the following IP details:

Switch A L0 - 172.31.255.1/32

Switch A VLAN1 - 172.1.0.1/24

Switch A 0/47 - 172.31.254.10/30

Switch A 0/48 - 172.31.254.1/30

Switch B L0 - 172.31.255.2/32

Switch B VLAN1 - 172.2.0.1/24

Switch B 0/47 - 172.31.254.2/30

Switch B 0/48 - 172.31.254.5/30

Switch C L0 - 172.31.255.1/32

Switch C VLAN1 - 172.1.0.1/24

Switch C 0/47 - 172.31.254.6/30

Switch C 0/48 - 172.31.254.9/30

I have then configured VLAN1 and ports 0/47-48 to be in the OSPF Area 0 on each switch.

This was all going fine until I brought up Switch C port 0/48 and then I lost all network connectivity and my laptop said the port (on VLAN1 of Switch A) was going up and down every few seconds. Equally the terminal output of switch B said that interfaces were going up and down.

Each switch as Spanning Tree set to PVST.

What have I missed? Is OSPF not supposed to be used in this way? Am I supposed to ensure there are no loops on the network?

Thanks for any and all help. If I have left out any information please ask.

Regards

Andrew.    

Everyone's tags (3)
11 REPLIES
Hall of Fame Super Silver

OSPF and redundant paths

Andrew

How are ports 47 and 48 configured on these switches? Are they in a common VLAN? If we could see config details we might be able to give better suggestions about the problem.

HTH

Rick

New Member

OSPF and redundant paths

I'd love to give you a config output, but the swtiches are at work and I'm at home. I will post them first thing tomorrow.

Ports 47 and 48 are all

no switchport

i.e. I'm using the links between the switches as layer 3 links as in practice these links will be a combination of cross-site fibre and wireless.

Thanks

Regards   

Andrew.

New Member

Re: OSPF and redundant paths

Sorry for the delay, the config are

Switch A:

no aaa new-model

ip subnet-zero

ip routing

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

ip address 172.31.255.1 255.255.255.0

!

interface FastEthernet0/1

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/2

!

.......

interface FastEthernet0/47

no switchport

ip address 172.31.254.9 255.255.255.252

!

interface FastEthernet0/48

no switchport

ip address 172.31.254.1 255.255.255.252

!

!

interface Vlan1

ip address 10.20.1.1 255.255.255.0

!

interface Vlan2

ip address 172.1.0.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 172.1.0.0 0.0.0.255 area 0

network 172.31.254.1 0.0.0.0 area 0

network 172.31.254.9 0.0.0.0 area 0

!

ip default-gateway 10.20.1.10

ip classless

ip http server

ip http secure-server

!

ip ospf name-lookup

!

snmp-server community public RO

!

control-plane

!

!

Switch B:

no aaa new-model

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

ip address 172.31.255.3 255.255.255.0

!

interface FastEthernet0/1

switchport access vlan 2

!

interface FastEthernet0/2

!

!

interface FastEthernet0/47

no switchport

ip address 172.31.254.2 255.255.255.252

!

interface FastEthernet0/48

no switchport

ip address 172.31.254.5 255.255.255.252

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface Vlan1

ip address 10.20.1.3 255.255.255.0

!

interface Vlan2

ip address 172.3.0.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 172.3.0.0 0.0.0.255 area 0

network 172.31.254.2 0.0.0.0 area 0

network 172.31.254.5 0.0.0.0 area 0

!

ip default-gateway 10.20.1.10

ip classless

ip http server

ip http secure-server

!

!

Switch C:

no aaa new-model

ip subnet-zero

ip routing

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface Loopback0

ip address 172.31.255.2 255.255.255.255

!

interface FastEthernet0/1

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/46

!

interface FastEthernet0/47

no switchport

ip address 172.31.254.10 255.255.255.252

!

interface FastEthernet0/48

no switchport

ip address 172.31.254.6 255.255.255.252

!

interface Vlan1

ip address 10.20.1.2 255.255.255.0

!

interface Vlan2

ip address 172.2.0.1 255.255.255.0

!

router ospf 1

log-adjacency-changes

network 172.2.0.0 0.0.0.255 area 0

network 172.31.254.6 0.0.0.0 area 0

network 172.31.254.10 0.0.0.0 area 0

!

ip default-gateway 10.20.1.254

ip classless

ip http server

ip http secure-server

!

Sent from Cisco Technical Support iPad App

Hall of Fame Super Silver

OSPF and redundant paths

Andrew

Thanks for providing additional information. There are several discrepancies between what you give in the original post and what is in the config. Your description says that the loopbacks are to be /32 but switches And B have /24 on their loopbacks. And some of the addressing you give for ports 47 and 48 does not match with the description. Switch A port 47 should be .10 but is configured as .9. Switch C port 47 should be .6 but is configured as .10 and port 48 should be .9 but is configured as .6. Your description talks about just VLAN 1 but the config shows VLAN 1 and 2.

But I am not sure that these descrepencies are causing your basic  problem. The description of interfaces going up and down sounds like an issue with spanning tree. And we do not have enough information to analyze a spanning tree issue.

HTH

Rick

New Member

Re: OSPF and redundant paths

You're absolutely right, I seem to have mixed up my config a bit and got some switches backwards. However, the only stuff I've taken out of the config files is the ports with no information / settings so all the spanning tree settings are there.

Everything I've read about ospf says this should work and none of it talks about spanning tree, I feel like I'm missing something.

Thanks for your help.

Sent from Cisco Technical Support iPhone App

Cisco Employee

Re: OSPF and redundant paths

Hard to say without knowing exactly what you see. Can you please paste all logs, TS you havde done so far to understand the problem itself.

For what I have now just after screening config, pls advies why you have different default GW in Vlan1:

- on C: ip default-gateway 10.20.1.254

- on A&B ip default-gateway 10.20.1.10

- your OSPF is not configured to carry VLAN1 and VLAN2 networks it only cares about p2p subnets thus it does not help you with connectivity in VLANs

- How do you also connect to these switches? console, vlan1, vlan2, etc

So please send following to understand what you are doing, see now and want to get:

- diagram (including your PC and default GW)

- logs you see during the problem

- sh cdp nei (from each switch)

Nik

Bronze

OSPF and redundant paths

A suggestion is try removing "ip default-gateway...." commands and replace them with a default static route on switches.

Hope it helps

Eugen

New Member

OSPF and redundant paths

eugen barticel wrote:

A suggestion is try removing "ip default-gateway...." commands and replace them with a default static route on switches.

Hope it helps

Eugen

I think that ended up in there from the express setup screen. The office is closed today for bank holiday but I shall try this first thing tomorrow - thanks.

I shall also check that the switch config matched the diagram I've made as there are clearly discrepancies.

Finally "

- your OSPF is not configured to carry VLAN1 and VLAN2 networks it only  cares about p2p subnets thus it does not help you with connectivity in  VLANs

"

The idea is that these switches will be split between sites so I don't want Layer2 traffic going between vlans, only layer 3. Is this not the recommended design?

Thanks for your input, it's very much appreciated.

Andrew.

New Member

Re: OSPF and redundant paths

This won't be a spanning-tree issue, as we are solely relying on layer 3 paths between the switches. Also, the 'ip default-gateway' command offers layer 2 functionality, i.e. when 'ip routing' is not enabled.

I would configure your devices EXACTLY how you have explained in the first post, paying close attention to the configuration of the VLAN 1 interface IP address and mask.

Would also be worth taking the 'ip ospf name-lookup' command off in the lab scenario, this will make your 'sh ip ospf nei' take an age to complete.

In response to your last reply, keep VLAN traffic local to the site as you are currently doing. You will still need to ensure the subnets on which your hosts sit are advertised in to OSPF so the other devices have reachability to these subnets.

Thanks,

Adam

New Member

OSPF and redundant paths

Ok, I never found out what the problem was with this. I just cleared out all my settings, did them again and now it works.

There must have been a mistake somewhere, but I couldn't work it out.

Thanks for all the suggestions.

Hall of Fame Super Silver

OSPF and redundant paths

Andrew

I am glad that you got it to work correctly when you went back and did it over again with a fresh start. Thanks for posting back to the forum and letting us know that when you did the setup over again that it now works as expected.

HTH

Rick

2674
Views
0
Helpful
11
Replies