Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF and Static Route

Hi,

I have got two internet link from different ISP. One ISP have got the bandwidth of 1 mbps and another of 10 mbps. I want to run ospf for the first ISP as they have provided two different networks and for the second ISP I want the static route.

I only need to route certain destination networks through first ISP so the OSPF should contain only few networks only and 0.0.0.0 through 2nd ISP. How can I perform this ?

DESTINATION NETWORK EXAMPLE (from 1st ISP)

200.200.200.200/24

100.100.100.100/24

150.150.150.150/24

Thanks in advance,

Regards

Mero

4 REPLIES

OSPF and Static Route

Hello,

From ISP 1 you could redistribute in to OSPF those specific networks using a filter like ACL or Prefix-list with Route-Map. How does ISP 1 know about those prefix's?

It's good that you will be advertising the specific networks as the most specific prefix makes it to the routing table. Therefor you will be taking the correct exit point.

Is this real life scenario or not, if so can you share configs so we can help you. If not then give us some idea whether or not the addresses are connected networks, static route networks, IGP or EGP learned networks for ISP 1.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
New Member

OSPF and Static Route

Hi,

Thanks for your reply.

I have got the configuration as follows:

Interface 0/0

Desc ***** connected to lan ******

ip address 101.2.2.1 255.255.255.240

interface 0/1

Desc ***** Connected to ISP  1 (Primary)

ip address 101.2.3.1 255.255.255.252

interface 0/2

Desc ***** Connected ISP 2 (Secondary)

ip address 101.2.4.1 255.255.255.252

ISP1 Networks:

200.200.200.200/24

100.100.100.100/24

150.150.150.150/24

How to distribute the above networks only through ospf ?

ISP1 is advertising area 30 for my network (101.2.2.1/28, 102.2.3.1/30, 101.2.4.1/30)

Now how do I perform my above mentioned task ?

Regards,

Mero

Re: OSPF and Static Route

Hello Mero, I asked for ISP 1 configuration? (Do you have control of ISP1 router?) If you haven't got it then let us know please. Also show us the output of 'show ip route'

Thank you

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.

Re: OSPF and Static Route

Hello

As I understand your query you have dynamic routing (ospf) towards ISP1 only and wish to recieive just specifc routes from this provider and also you wish use a static default route towards ISP2 - if so his should work?

conf t

access-list 10 permit 200.200.200.0 0.0.0.255

access-list 10 permit 100.100.100.0 0.0.0.255

access-list 10 permit 150.150.150.0 0.0.0.255

route-map ISP1 permit 10

match ip address 10

router ospf x

distribute-list route-map ISP1 in

track 1 interface fa0/2 ip routing

ip route 0.0.0.0 0.0.0.0  fa0/2 101.2.4.2 track1 ( ISP2 next hop)

ip route 0.0.0.0 0.0.0.0  fa0/1 101.2.3.2 250  ( ISP1 next hop) - just in case you lose connectivity to ISP2

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
181
Views
0
Helpful
4
Replies