Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF BFD Query

Hello,

 

i have one query regarding to configure OSPF BFD feaure for only one interface the scenario is,

 

i have three routers, i just want to configure the BFD on the interface between R2 and R1 as showing below:

 

R1 ---------- R2 ---------- R3

 

my question is can i only enable this feaure on R2 interface and R1  not for exampe:

 

Configuration for R2

!interface Fast Ethernet 0/1

ip address 172.16.10.1 255.255.255.0

 

bfd interval 50 min_rx 50 multiplier 3

!

interface Fast Ethernet 3/0.1

ip address 172.17.0.1 255.255.255.0

!

router ospf 123

log-adjacency-changes detail

network 172.16.0.0 0.0.0.255 area 0

network 172.17.0.0 0.0.0.255 area 0

bfd all-interfaces

Configuration for R1

!

interface Fast Ethernet 6/0

ip address 172.16.10.2 255.255.255.0

 

!

interface Fast Ethernet 6/1

ip address 172.18.0.1 255.255.255.0

!

router ospf 123

log-adjacency-changes detail

network 172.16.0.0 0.0.255.255 area 0

network 172.18.0.0 0.0.255.255 area 0

 

as showed in the above example on R1 not configured BFD.

it will work or i must enable both

 

Thanks,

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Hi, Which IOS you are running

Hi,

 

Which IOS you are running. Please go through below CCO document for configuration help enabling BFD for OSPF on 4500E

 

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/15-1/XE_330SG/configuration/guide/config/bfd.html#wp1056004

 

snippet

Note Support on the Catalyst 4500E is limited. Starting with Cisco IOS Release IOS 15.1(1)SG, Bidirectional Forwarding Detection (BFD) is supported only on Catalyst 4900M, and Catalyst 4948E Ethernet switches.

 

--Pls dont forget to rate helpful posts--

Regards,

Akash

7 REPLIES
VIP Super Bronze

Hi,What devices are you using

Hi,

What devices are you using and what version of software?

 

New Member

Hello , as understood i must

Hello ,

 

as understood i must enabled between the two neighbors,  if only one interface enabled BFD the ospf neighbor will not come up.correct me ?

 

Thanks

 

New Member

Hello All, i have 4500x and

Hello All,

 

i have 4500x and under ospf i didn't  able to add

router ospf 123
bfd interface fastethernet6/0

 

can i enable it only under the interface as follow:

interface f6/0

ip ospf bfd

 

and I should enable the same BFD value on both neighbors. if there is any document mentioned this please share it.

 

Thanks

 

Cisco Employee

Hi, Which IOS you are running

Hi,

 

Which IOS you are running. Please go through below CCO document for configuration help enabling BFD for OSPF on 4500E

 

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/15-1/XE_330SG/configuration/guide/config/bfd.html#wp1056004

 

snippet

Note Support on the Catalyst 4500E is limited. Starting with Cisco IOS Release IOS 15.1(1)SG, Bidirectional Forwarding Detection (BFD) is supported only on Catalyst 4900M, and Catalyst 4948E Ethernet switches.

 

--Pls dont forget to rate helpful posts--

Regards,

Akash

New Member

Thanks Akash for your support

Thanks Akash for your support.

Cisco Employee

 Hi, I guess it should be

 

Hi,

 

I guess it should be running on all participating routers. When we configure BFD below command

"bfd interval 50 min_rx 50 multiplier 3", it says that router will send BFD packet every 50ms and would expect BFD packet every 50ms (min_rx). If does not receive BFD for 3 consecutive time, it will announce neighbor as down. So for other router to send BFD hello, it is required to configure BFD there.

 

--Pls dont forget to rate helpful posts--

 

Regards,

Akash

Bronze

Change bfd all-interface

Change bfd all-interface under OSPF to the interface you want to run BFD on.

On router 2, change this:

router ospf 123
 bfd all-interfaces

To this:

router ospf 123
 bfd interface fastethernet0/1

and add this to R1:

router ospf 123
 bfd interface fastethernet6/0

 

That should do it.

126
Views
0
Helpful
7
Replies
CreatePlease login to create content