Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

OSPF config with HSRP

Hello-

I have a network, consisting of 2 7304's (internet routers) and 2 3560's that sit directly behind them. all are in ospf area 0 and on the 3560's there is also area 1 with a different network on it. HSRP is setup on a couple of VLAN's between the 2 3560's that are all part of the network being advertised in area 1, the problem I'm having is when i add area 1 to the switch that is the "standby" switch for HSRP i end up getting routed there and never making it to my destination, i was looking for best practice on being able to correct the routing there, i was thinking ospf priority possibly?

Thanks,

Justin

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: OSPF config with HSRP

The priority will only assist in DR/BDR election. You would want to change the cost of OSPF on the interface. with the "IP OSPF COST " command. The range is from 1 ot 65,535 with 1 being the most perferred route, so assign the HSRP route a higher cost. OSPF will use the perferred route first and only if that route goes down will it use the next route.

11 REPLIES
Hall of Fame Super Gold

Re: OSPF config with HSRP

Justin

I am puzzled by your description of the problem. If I am understanding it correctly the 2 3560s are OSPF neighbors. And that if you add area 1 to it then you get routed to that switch and can not reach the destination. This would seem to imply that the other switch has route availability that the other switch does not. I am puzzled how that would happen. Perhaps you could help me understand this better? It might help if you would post the config of both switches.

HTH

Rick

Community Member

Re: OSPF config with HSRP

Its odd, why its doing that...heres a copy of my OSPF on each and one of the vlans that has hsrp from both, i misstated area 1 originally, its area 2...IP's are changed, its a public network, if you need more please feel free to let me know, the redistributed static's are a network that exists behind the router attached to VLAN 103 (inside) also, my 7300's are redis a default route so there are no other routes on these switches

-Justin

SW1

router ospf 1

router-id 1.1.1.251

log-adjacency-changes

no capability lls

redistribute static route-map sns

network 1.1.1.0 0.0.0.255 area 0

network 1.1.2.0 0.0.0.255 area 2

interface Vlan103

ip address 1.1.2.92 255.255.255.224

standby 103 ip 1.1.2.65

standby 103 priority 150

standby 103 preempt

standby 103 track GigabitEthernet0/25

SW2

interface Vlan103

ip address 1.1.2.91 255.255.255.224

standby 103 ip 1.1.2.65

standby 103 preempt

standby 103 track GigabitEthernet0/25

!

router ospf 1

router-id 1.1.1.252

log-adjacency-changes

no capability lls

redistribute static route-map sns

network 1.1.1.0 0.0.0.255 area 0

network 1.1.2.0 0.0.0.255 area 2

Community Member

Re: OSPF config with HSRP

Also, I forgot to mention, i have tried coming from the outside world back in, the network is advertised by BGP on the 7300's and is getting routed in OSPF and i end up at #2 coming in, when 1 is clearly the "active" switch/router. I can also try being plugged into SW1 on a different subnet thats still part of area 1 and it sends me to SW2 to a host in VLAN 103

Hall of Fame Super Gold

Re: OSPF config with HSRP

Justin

Thanks for posting the partial config. From the config it looks like SW1 and SW2 should be neighbors in both area 0 and in area 2. Can you confirm that this is the case? Perhaps it might help if you would post the output of show ip ospf from each router and the output of show ip ospf neighbor from each router.

I notice that your redistribute static statement in OSPF does not include the subnets keyword. That may or may not matter, depending on what is being redistributed. Perhaps you can post any static routes configured on either of the switches.

I still am puzzled why you get directed to SW2 and get stuck since it looks like both switches should have the same routing information as each other. Perhaps it would help if you could post the output of show ip route from both switches, and if you could identify the network (or host) destination that you are looking for when you get stuck.

HTH

Rick

Community Member

Re: OSPF config with HSRP

They are neighbors, in both areas, currently the config is missing area 2 on the second switch, mainly because its a production network and i dont have another window of change til 5am tomorrow morning.

it really does say subnets, sorry, i tried to shrow together as it was this am, but it does say subnets and the static route is a /22 getting routed to 1.1.2.66, that shouldnt matter at all for right now

the show ip route on the switches shows the subnet im looking for as connected. if i do it on the 7300's it shows it as available by both via ospf, the host ip trying to trace to in this instance is 1.1.2.66

Thanks

-Justin

Community Member

Re: OSPF config with HSRP

Hey - Just a word of warning!

In the HSRP process, SW1 is teh active switch due to it's priority of 150. However, the default priority decrement for a tracked interface is only 10 and the default priority is 100 which is what's on SW2.

What I'm trying to say is that if the tracked interface on SW1 fails it will only bring the priority down to 140 whcih is still higher than the standby switch so HSRP won't failover.

You can either lower the priority of SW1 to 105 or you can set the priority decrement to what ever you want with the "standby 103 track " command.

Hope that helps,

Neil

Community Member

Re: OSPF config with HSRP

The priority will only assist in DR/BDR election. You would want to change the cost of OSPF on the interface. with the "IP OSPF COST " command. The range is from 1 ot 65,535 with 1 being the most perferred route, so assign the HSRP route a higher cost. OSPF will use the perferred route first and only if that route goes down will it use the next route.

Community Member

Re: OSPF config with HSRP

Thanks, I can just give them a cost of, say 1 and 2 and that should be fine correct?

Community Member

Re: OSPF config with HSRP

Yes, You would want to give you main route a cost of 1 and you secondary route/backup route a cost of 2.

Community Member

Re: OSPF config with HSRP

Thanks again, ill report back tomorrow

-Justin

Community Member

Re: OSPF config with HSRP

OSPF cost worked like a charm...thanks

-Justin

6524
Views
0
Helpful
11
Replies
CreatePlease to create content