Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

OSPF dead timer expiring

I have set up a triangle netwrok, 6509-A connected to 6509-B and 6509-C. Router B and C are also HSRP pair where B is active router. I'm seeing lots of Dead time expired on both B and C and as result OSPF is failing several times a day on each router. I have checked all the paramers such as hello, dead, wait, retransmit are same on every router. I didn't find any physical issue either, can someone point me to direction what would be the cause or what to look next?

8 REPLIES
Hall of Fame Super Bronze

Re: OSPF dead timer expiring

Let's see the show ip ospf interface from the 3 switches.

New Member

Re: OSPF dead timer expiring

Edison

Here is some capture from router, i have added more than show ip ospf interface. I ran some debug ip ospf hello and noticed router B and C sometime send two or more hello and receive one hello, my understanding that it should be one to one. I also noticed on routerA that there are lots of retransmission toward router B and C when i do show ip ospf neighbor detail. But Im still not sure what is the root cause, I still do not see layer2 issue, no error on the ports and such, please help. Thank you all!!!

Re: OSPF dead timer expiring

I don't immediately see the source of your problem, but I do notice the ambiguous areas on router A. That is, the network 192.168.0.0 0.0.255.255 area 0 does not really seem to belong there. It could be read as implying that the two area 13 links could just as well be in area 0. I presume that area 0 is the network served by the HSRP by routers B and C, is it?

And I'm not sure where area 12 fits in, but if my geuss about the topology is correct, it looks like router A might need a virtual-link through area 13.

Could you draw your topology please?

Kevin Dorrell

Luxembourg

New Member

Re: OSPF dead timer expiring

Router A is a core router, reason i have 192.168.0.0 is because it connects to core 192.168.201.x and 192.168.202.x. Toplogy looks like this-

Router A (lets call 203) is core in Datacenter2, connects to core in datacenter1 to router 201 and 202 on area 0 and Wan block in DC2 on area 0. RouterA also connects to Dc2 distribution1 on area 12 and distribution2 on area 13. LEt me post the config of routerA for better understanding.

interface Loopback0

description interface

ip address 10.12.1.203 255.255.255.255

!

interface Vlan1

description managementVlan

ip address 192.168.203.1 255.255.255.252

!

interface Vlan20

description area 13 distro#2--router-C

ip address 192.168.203.29 255.255.255.252

ip ospf message-digest-key 1 md5 key#############

!

interface Vlan21

description area 13 distro#2-routerC

ip address 192.168.203.33 255.255.255.252

ip ospf message-digest-key 1 md5 key#############

!

interface Vlan22

description area 12 distro#1

ip address 192.168.203.21 255.255.255.252

ip ospf message-digest-key 1 md5 key#############

!

!

interface Vlan24

description area0-t0-core201 at DC1

ip address 192.168.201.30 255.255.255.252

ip ospf message-digest-key 1 md5 key#############

!

interface Vlan25

description-ara0 WAN Block area0

ip address 192.168.203.25 255.255.255.252

ip ospf message-digest-key 1 md5 key#############

!

!

interface Vlan33

description area0-t0-core202 at DC1

ip address 192.168.202.34 255.255.255.252

ip ospf message-digest-key 1 md5 7key#############

Re: OSPF dead timer expiring

OK, I understand now. I think I would have given it:

network 192.168.201.0 0.0.0.255 area 0

network 192.168.202.0 0.0.0.255 area 0

That avoids the ambiguity for the 192.168.203.x networks. But it shouldn't matter - the show command shows your links to B and C firmly in area 13.

Do you have the dead-timer problem in the other areas? What is different about their configuration?

Kevin Dorrell

Luxembourg

New Member

Re: OSPF dead timer expiring

No, all look fine. Only area 13 has dead timer issue, no port errors, no interface reset or nothing. I'm clueless. I even opened the TAC case and TAC Engineer was clueless too, he asked me replace the cable/gbic to see if it resolves but I don't think this is really issue.

New Member

Re: OSPF dead timer expiring

Anyone here who has any clue on this? Any other suggestion someone would like me to try?

Thank you all

Re: OSPF dead timer expiring

Did you try removing the area ambiguity?

The alternative is not to have any network statements at all under the OSPF process, but to put ip ospf area under each of the interfaces.

Kevin Dorrell

Luxembourg

608
Views
0
Helpful
8
Replies
CreatePlease to create content