Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ospf E1 and E2

1.- Why does the routing table for (R2) marks routes from (R1) as (E2) not as (IA) [see config and show command below]

Diagram / While marking routes from (R5) correctly [R5 running RIP]

2.- I add the following command on R1[redistribute rip metric 1 subnets] to mark traffic as TYPE-1 but routes are maked E2

R5---R1

      -    -

   -        -

-R2         -R3

R1

--------------------------

router ospf 1

log-adjacency-changes

area 1 range 8.0.0.0 252.0.0.0

redistribute connected subnets

redistribute rip metric 1 subnets

network 1.1.1.1 0.0.0.0 area 0

network 8.0.0.0 0.0.0.255 area 1

network 9.0.0.0 0.0.0.255 area 1

network 10.0.0.0 0.0.0.255 area 1

network 11.0.0.0 0.0.0.255 area 1

network 172.12.123.0 0.0.0.255 area 0

neighbor 172.12.123.2

neighbor 172.12.123.3

!

router rip

version 2

redistribute connected metric 1

redistribute ospf 1 metric 1

network 15.0.0.0

no auto-summary

R2

-----

router ospf 1

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 2

network 172.12.123.0 0.0.0.255 area 0

R5

----

router rip

version 2

network 4.0.0.0

network 5.0.0.0

network 6.0.0.0

network 7.0.0.0

network 15.0.0.0

Routing table of (R2)

R2#sh ip route ospf

     1.0.0.0/32 is subnetted, 1 subnets

O       1.1.1.1 [110/65] via 172.12.123.1, 00:44:32, Serial0/0

     33.0.0.0/32 is subnetted, 1 subnets

O IA    33.33.33.33 [110/65] via 172.12.123.3, 00:44:32, Serial0/0

     3.0.0.0/32 is subnetted, 1 subnets

O IA    3.3.3.3 [110/65] via 172.12.123.3, 00:44:32, Serial0/0

O E2 4.0.0.0/8 [110/1] via 172.12.123.1, 00:44:32, Serial0/0

O E2 5.0.0.0/8 [110/1] via 172.12.123.1, 00:44:32, Serial0/0

O E2 6.0.0.0/8 [110/1] via 172.12.123.1, 00:44:32, Serial0/0

     172.34.0.0/24 is subnetted, 1 subnets

O IA    172.34.34.0 [110/74] via 172.12.123.3, 00:44:32, Serial0/0

O E2 7.0.0.0/8 [110/1] via 172.12.123.1, 00:44:32, Serial0/0

     8.0.0.0/32 is subnetted, 1 subnets

O E2    8.1.1.1 [110/20] via 172.12.123.1, 00:44:32, Serial0/0

     9.0.0.0/32 is subnetted, 1 subnets

O E2    9.1.1.1 [110/20] via 172.12.123.1, 00:44:32, Serial0/0

     10.0.0.0/32 is subnetted, 1 subnets

O E2    10.1.1.1 [110/20] via 172.12.123.1, 00:44:32, Serial0/0

     11.0.0.0/32 is subnetted, 1 subnets

O E2    11.1.1.1 [110/20] via 172.12.123.1, 00:44:34, Serial0/0

     14.0.0.0/32 is subnetted, 1 subnets

O E2    14.14.14.14 [110/20] via 172.12.123.3, 00:44:34, Serial0/0

     15.0.0.0/24 is subnetted, 1 subnets

O E2    15.0.0.0 [110/20] via 172.12.123.1, 00:44:34, Serial0/0

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: ospf E1 and E2

1) Can you check if the network/wildcard-masks cover the desired interfaces (show ip ospf interface brief) on R1?

2) You have to use the metric-type 1 option in the redistribute-command. Metric 1 sets the seed metric to 1 (default: 20).

HTH

Rolf

1 REPLY

Re: ospf E1 and E2

1) Can you check if the network/wildcard-masks cover the desired interfaces (show ip ospf interface brief) on R1?

2) You have to use the metric-type 1 option in the redistribute-command. Metric 1 sets the seed metric to 1 (default: 20).

HTH

Rolf

172
Views
0
Helpful
1
Replies