Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

OSPF error: Dead timer expired

Hello, everybody!

I have two routers, which I want to bind with OSPF. The problem is I can't made them to be neighbors for each other. I receive the following error message on router:

sz-novg-derzh-2#

Oct 25 09:59:19.023: %OSPF-5-ADJCHG: Process 1, Nbr 172.18.245.80 on GigabitEthernet0/0.1 from LOADING to FULL, Loading Done

Oct 25 09:59:22.051: %OSPF-5-ADJCHG: Process 1, Nbr 172.18.245.80 on GigabitEthernet0/0.1 from FULL to DOWN, Neighbor Down: Dead timer expired

Oct 25 09:59:27.191: %OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.0 on GigabitEthernet0/0.1 from ATTEMPT to DOWN, Neighbor Down: Dead timer expired

Oct 25 09:59:29.019: OSPF-1 EVENT: service_maxage: Trying to delete MAXAGE LSA

sz-novg-derzh-2#

This is show int for the interface at router sz-novg-derzh-2:

interface GigabitEthernet0/0.1

encapsulation dot1Q 55

ip address 172.18.25.133 255.255.255.252

ip ospf network non-broadcast (Without this I can't set neighborhood between them cause it says that "wrong network types")

ip ospf dead-interval 3

ip ospf hello-interval 1

This is show int for the interfaces at router r-psk2:

interface GigabitEthernet0/0.55

encapsulation dot1Q 55

ip address 172.18.25.134 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip ospf hello-interval 1

ip ospf dead-interval 3

ip ospf priority 0

!

interface GigabitEthernet0/0.66

encapsulation dot1Q 66

ip address 172.18.25.245 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

!

interface GigabitEthernet0/1

ip address 172.18.245.80 255.255.255.224

no ip redirects

          no ip unreachables

no ip proxy-arp

ip ospf hello-interval 1

ip ospf dead-interval 3

ip ospf priority 0

duplex auto

speed auto

Both routers can ping each other.

Hello and dead intervals are same. Then, what could be the problem?

Please, help!  The full show runn for both routers are applied.

Many thanks in advance!!!

8 REPLIES
New Member

OSPF error: Dead timer expired

OSPF Neighbors

All of the following fields in an OSPF hello message must match for an adjacency to form:

  • hello timer
  • dead timer
  • area ID
  • authentication type
  • password
  • stub area flag

Note: On multi-access links, adjacencies are only formed between the router and the DR and BDR.

OSPF error: Dead timer expired

ip ospf network non-broadcast (Without this I can't set neighborhood between them cause it says that "wrong network types")

That's interesting.. The default is "BROADCAST" on Ethernet ports, so is this configured as n NBMA somehow?

Can you try putting 'ip ospf mtu-ignore' on the port that is attempting to form a neighbor relationship with the other OSPF network?

OSPF error: Dead timer expired

Just so I understand this correctly. GigabitEThernet0/0.1 on sz-novg-derzh-25 is directly connected to GigabitEthernet0/0.55 on r-psk2? Is this connect run through any other switches via L2 or just a cable from each switch going into the other?

I'm a little confused as to way, it wouldn't work without 'ip ospf network non-broadcast'. Because as of right, without this on GigabitEthernet0/0.55 it should still be complaning about mismatched network types, and it's a /30 at that.

New Member

Re: OSPF error: Dead timer expired

Hi!

Thank you for your response!

GigabitEThernet0/0.1 on sz-novg-derzh-2 is not directly connected to GigabitEthernet0/0.55 on r-psk2.

1) r-psk2 is connected to 2960 switch

2) There is provider's virtual channel between the 2960 switch and sz-novg-derzh-2 router. For me, it's like direct cable connection from port to port.

You are completely right with this:

I'm a little confused as to way, it wouldn't work without 'ip ospf network non-broadcast'. Because as of right, without this on GigabitEthernet0/0.55 it should still be complaning about mismatched network types, and it's a /30 at that.

I executed "ip ospf network non-broadcast" command for GigabitEThernet0/0.1 interface on sz-novg-derzh-2. The message about mismatched network types disappeared after that, but new one about "Dead timer expired" came...

Are there any solutions for my problem?

Many, many thanks to you!!!


Re: OSPF error: Dead timer expired

From looking at your configurations it looks like the hello-interval and dead-interval are the same for these two neighbors. On router sz-novg-derzh-2, does the "Dead timer expired" ever start receiving hellos? It's possible, since this goes through a switch (correct me if I'm wrong on that), that spanning tree could by causing some issues, considering on how short the dead timer is.

New Member

Re: OSPF error: Dead timer expired

Thank you John,

you mean, that looking at this

sz-novg-derzh-2#

Oct 25 09:59:19.023: %OSPF-5-ADJCHG: Process 1, Nbr 172.18.245.80 on GigabitEthernet0/0.1 from LOADING to FULL, Loading Done

Oct 25 09:59:22.051: %OSPF-5-ADJCHG: Process 1, Nbr 172.18.245.80 on GigabitEthernet0/0.1 from FULL to DOWN, Neighbor Down: Dead timer expired

Oct 25 09:59:27.191: %OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.0 on GigabitEthernet0/0.1 from ATTEMPT to DOWN, Neighbor Down: Dead timer expired

Oct 25 09:59:29.019: OSPF-1 EVENT: service_maxage: Trying to delete MAXAGE LSA

sz-novg-derzh-2#

it is impossible to understand whether sz-novg-derzh-2 router receives hello from neighbor?

Actually, I think that they establish a very short partnership, because from other router, connected to sz-novg-derzh-2, I can ping remote addresses from network, known by r-psk2, but in a very strange way. For example, I execute ping x.x.x.x -t command and receive countless "Request timed out" but periodically, may be every 2-3 minutes, I receive 5-6 succesful replies and the endless "Request timed out"!!!

May be, I have to increase dead-interval value?

Oops, I have missed something from your previous post - I'll try to run "ip ospf mtu-ignore" command on Monday - at the moment those office is closed. 

Many thanks to you!

Re: OSPF error: Dead timer expired

it is impossible to understand whether sz-novg-derzh-2 router receives hello from neighbor?

If you have access to both routers, even if the adjacency goes down then yes. Also if you have syslog setup, you should be able to see that as well, depending on how your trap level is setup.

This is show int for the interface at router sz-novg-derzh-2:

interface GigabitEthernet0/0.1

encapsulation dot1Q 55

ip address 172.18.25.133 255.255.255.252

ip ospf network non-broadcast (Without this I can't set neighborhood between them cause it says that "wrong network types")

ip ospf dead-interval 3

ip ospf hello-interval 1

On your above config, it shows Nbr 172.18.245.80 going from FULL to DOWN, with the reason being Dead timer expired.

From your initial post, I don't see a interface configured on the same subnet..

It sounds like you could possible have a L2 issue somewhere.

New Member

Re: OSPF error: Dead timer expired

The problem was solved.

I have converted trunk port on the switch (between routers) to access.

Then, I deleted the subinterface on the novgderzh-2 router, configured GigaEthernet 0/0 int, and set DEAD-Interval to 15 instead of 3.

Everything works fine now!!!

Many thanks to all the participants of this discussion!

2218
Views
0
Helpful
8
Replies
CreatePlease to create content