Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

OSPF inter-area routes are not installed in VRF routing table

Hello!

I have a simple topology: two routers R1 and R2 connected to each other through ethernet link. Both routers runs OSPF. R1 runs OSPF process in the VRF 1. The ethernet link is configured for OSPF area 4. R2 also have loopback interface in area 0. Now when I look for ip routes in VRF1 in R1 I doesn't see route for R2's loopback 0. But when I look in OSPF database I see that summary LSA for this network is present. It seems that R1 doesn't install this route in VRF's routing table. Here are routers' configs:

R1:

ip vrf 1

rd 1:1

interface Ethernet0/0

ip vrf forwarding 1

ip address 10.0.0.1 255.255.255.252

router ospf 1 vrf 1

network 10.0.0.1 0.0.0.0 area 4

R2:

interface Loopback0

ip address 192.168.0.2 255.255.255.255

!

interface Ethernet0/0

ip address 10.0.0.2 255.255.255.252

router ospf 1

log-adjacency-changes

network 10.0.0.2 0.0.0.0 area 4

network 192.168.0.2 0.0.0.0 area 0

Show commands on R1:

R1#sh ip route vrf 1

10.0.0.0/30 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, Ethernet0/0

R1#sh ip ospf database

...

Summary Net Link States (Area 4)

Link ID ADV Router Age Seq# Checksum

192.168.0.2 192.168.0.2 144 0x80000002 0x00B3B0

Why this LSA is not installed in the routing table?

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: OSPF inter-area routes are not installed in VRF routing tabl

Konstantin,

Summary LSAs are not installed by default in a VRF-lite context. You need to use the following command on R1 to change this behavior.

router ospf 1 vrf1

capability vrf-lite

This should fix the issue.

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
6 REPLIES

Re: OSPF inter-area routes are not installed in VRF routing tabl

Hi KONSTANTIN,

please do as follows:

R2:

interface Loopback0

ip vrf forwarding 1

ip address 192.168.0.2 255.255.255.255

interface Ethernet0/0

ip vrf forwarding 1

ip address 10.0.0.2 255.255.255.252

Keep that in mind: You need to apply the L3 interface into the VRF you want!

Hopes this helps

Thot

Cisco Employee

Re: OSPF inter-area routes are not installed in VRF routing tabl

Konstantin,

Summary LSAs are not installed by default in a VRF-lite context. You need to use the following command on R1 to change this behavior.

router ospf 1 vrf1

capability vrf-lite

This should fix the issue.

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Re: OSPF inter-area routes are not installed in VRF routing tabl

Hi all,

Thannks HAROLD, I missed that one.

Cheers

Thot

Community Member

Re: OSPF inter-area routes are not installed in VRF routing tabl

Yes, the problem was in "capability vrf-lite".

Thank you guys!

You're doing great job!

Re: OSPF inter-area routes are not installed in VRF routing tabl

Harold,

Thanks for this answer Just what I was looking for. Kudos to u

Check my blog at http:laguiadelnetworking.com for further information.

Cheers,

Julio Carvajal Segura

Julio Carvajal
Senior Network Security and Core Specialist
CCIE #42930, 2xCCNP, JNCIP-SEC
Cisco Employee

Re: OSPF inter-area routes are not installed in VRF routing tabl

Hi Julio,

You are very welcome. Interesting blog.

Regards

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
1676
Views
10
Helpful
6
Replies
CreatePlease to create content