Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

OSPF: IP Unnumbered feature on CISCO WS-C6503-E

Hi Expert,

I am using a CISCO WS-C6503-E box. My CISCO box is currently up with build Version 12.2(33)SXI3.

My task is to test the IP unnumbered feature with CISCO box. I have read somewhere that CISCO WS-C6503-E supports IP unnumbered on vlan routing interfaces.

But I am not able to find a concrete answer, whether IP unnumbered feature is actually supported on the BOX and build version combination I am using or not?

I have to configure OSPF on IP unnumbered interface. Whenever I try to configure a vlan routing interface as IP unnumbered interface, CISCO box displays following ERROR message:

Router(config)#interface vlan 200

Router(config-if)#ip unnumbered  loopback 1

Warning: dynamic routing protocols will not work on SVI interfaces with IP unnumbered configured.

I am pasting running-config also here. Your help and answers are highly appreciated.

Router#show version

Cisco IOS Software, s72033_rp Software (s72033_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(33)SXI3, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Tue 27-Oct-09 11:11 by prod_rel_team

ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1)

Router uptime is 32 minutes

Uptime for this control processor is 32 minutes

Time since Router switched to active is 31 minutes

System returned to ROM by reload at 08:23:21 UTC Wed Jan 15 2014 (SP by reload)

System image file is "disk0:s72033-advipservicesk9_wan-mz.122-33.SXI3.bin"

Last reload reason: Reload Command

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

cisco WS-C6503-E (R7000) processor (revision 1.1) with 458720K/65536K bytes of memory.

Processor board ID FOX093404HJ

SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache

Last reset from power-on

3 Virtual Ethernet interfaces

50 Gigabit Ethernet interfaces

4 Ten Gigabit Ethernet interfaces

1917K bytes of non-volatile configuration memory.

8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2

Router#

Router#

Router#

Router#sh

Router#show  run

Router#show  running-config

Building configuration...

Current configuration : 4305 bytes

!

! Last configuration change at 08:55:58 UTC Wed Jan 15 2014

!

upgrade fpd auto

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service counters max age 10

!

hostname Router

!

boot-start-marker

boot system disk0:s72033-advipservicesk9_wan-mz.122-33.SXI3.bin

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

!

!

mls netflow interface

mls cef error action freeze

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

diagnostic bootup level minimal

!

redundancy

main-cpu

  auto-sync running-config

mode sso

!

vlan internal allocation policy ascending

vlan access-log ratelimit 2000

!

!

!

!

!

interface Loopback1

ip address 61.1.1.1 255.255.255.0

!

interface GigabitEthernet1/1

no ip address

shutdown

!

interface GigabitEthernet1/2

no ip address

shutdown

!

interface TenGigabitEthernet2/1

no ip address

!

interface TenGigabitEthernet2/2

no ip address

!

interface TenGigabitEthernet2/3

no ip address

!

interface TenGigabitEthernet2/4

switchport

switchport access vlan 200

switchport mode access

!

interface GigabitEthernet3/1

no ip address

!

interface GigabitEthernet3/2

no ip address

!

interface GigabitEthernet3/3

no ip address

!

interface GigabitEthernet3/4

no ip address

!

interface GigabitEthernet3/5

no ip address

shutdown

!

interface GigabitEthernet3/6

no ip address

shutdown

!

interface GigabitEthernet3/7

no ip address

shutdown

!

interface GigabitEthernet3/8

no ip address

shutdown

!

interface GigabitEthernet3/9

no ip address

shutdown

!

interface GigabitEthernet3/10

no ip address

shutdown

!

interface GigabitEthernet3/11

no ip address

shutdown

!

interface GigabitEthernet3/12

no ip address

shutdown

!

interface GigabitEthernet3/13

no ip address

shutdown

!

interface GigabitEthernet3/14

no ip address

shutdown

!

interface GigabitEthernet3/15

no ip address

shutdown

!

interface GigabitEthernet3/16

no ip address

shutdown

!

interface GigabitEthernet3/17

no ip address

shutdown

!

interface GigabitEthernet3/18

no ip address

shutdown

!

interface GigabitEthernet3/19

no ip address

shutdown

!

interface GigabitEthernet3/20

no ip address

shutdown

!

interface GigabitEthernet3/21

no ip address

shutdown

!

interface GigabitEthernet3/22

no ip address

shutdown

!

interface GigabitEthernet3/23

no ip address

shutdown

!

interface GigabitEthernet3/24

no ip address

shutdown

!

interface GigabitEthernet3/25

no ip address

shutdown

!

interface GigabitEthernet3/26

no ip address

shutdown

!

interface GigabitEthernet3/27

no ip address

shutdown

!

interface GigabitEthernet3/28

no ip address

shutdown

!

interface GigabitEthernet3/29

no ip address

shutdown

!

interface GigabitEthernet3/30

no ip address

shutdown

!

interface GigabitEthernet3/31

no ip address

shutdown

!

interface GigabitEthernet3/32

no ip address

shutdown

!

interface GigabitEthernet3/33

no ip address

shutdown

!

interface GigabitEthernet3/34

no ip address

shutdown

!

interface GigabitEthernet3/35

no ip address

shutdown

!

interface GigabitEthernet3/36

no ip address

shutdown

!

interface GigabitEthernet3/37

no ip address

shutdown

!

interface GigabitEthernet3/38

no ip address

shutdown

!

interface GigabitEthernet3/39

no ip address

shutdown

!

interface GigabitEthernet3/40

no ip address

shutdown

!

interface GigabitEthernet3/41

no ip address

shutdown

!

interface GigabitEthernet3/42

no ip address

shutdown

!

interface GigabitEthernet3/43

no ip address

shutdown

!

interface GigabitEthernet3/44

no ip address

shutdown

!

interface GigabitEthernet3/45

no ip address

shutdown

!

interface GigabitEthernet3/46

no ip address

shutdown

!

interface GigabitEthernet3/47

no ip address

shutdown

!

interface GigabitEthernet3/48

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

interface Vlan100

no ip address

shutdown

!

interface Vlan200

ip unnumbered Loopback1

ip ospf network point-to-point

!

router ospf 100

router-id 66.66.66.66

log-adjacency-changes

network 61.1.1.0 0.0.0.255 area 0

!

ip classless

ip route 32.1.1.1 255.255.255.255 Vlan200

!

!

no ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

dial-peer cor custom

!

!

!

!

line con 0

line vty 0 4

login

line vty 5 15

login

!

!

end

Router#

Thanks a lot in advance..

Regards,

Abhi


Everyone's tags (2)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver

OSPF: IP Unnumbered feature on CISCO WS-C6503-E

According to the Feature Navigator (www.cisco.com/go/fn) it should be in 12.2(33)SXI2 and SXI6. You can do your own search and filter on unnumbered. Then choose IP Unnumbered for VLAN-SVI interfaces. Then choose the platform. You will have all supported images there.

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.

Re: OSPF: IP Unnumbered feature on CISCO WS-C6503-E

Hi Abhi,

Release 12.2(18)SXE and later releases supports the ip unnumbered command on Layer 3 VLAN interfaces, but I believe with similar Limitations and Restrictions applying to the Catalyst 4500:

For IP unnumbered interfaces, the following features are not supported:

Dynamic routing protocols

–HSRP/VRRP

–Static ARP

–Unnumbered interface and Numbered interface in different VRFs

(...)

Unfortunately I coudn't find a better source.

HTH

Rolf

5 REPLIES
Silver

OSPF: IP Unnumbered feature on CISCO WS-C6503-E

According to the Feature Navigator (www.cisco.com/go/fn) it should be in 12.2(33)SXI2 and SXI6. You can do your own search and filter on unnumbered. Then choose IP Unnumbered for VLAN-SVI interfaces. Then choose the platform. You will have all supported images there.

Daniel Dib
CCIE #37149

Please rate helpful posts.

Daniel Dib CCIE #37149 Please rate helpful posts.
New Member

OSPF: IP Unnumbered feature on CISCO WS-C6503-E

Hi Daniel,

Thanks a lot for your reply.

Actually I could see the build 12.2(33)SXI3 there in the feature navigator but in platform list, I did not find the box I am using i.e.WS-C6503-E.

.

That's why I was wondering if feature is actually suported on my CISCO box running with build version 12.2(33)SXI3 or not.

I am first time working on a CISCO box.

Your confirmation would be highly appreciated...

Thansk in advance..

Regards,

Abhi

 

Re: OSPF: IP Unnumbered feature on CISCO WS-C6503-E

Hi Abhi,

Release 12.2(18)SXE and later releases supports the ip unnumbered command on Layer 3 VLAN interfaces, but I believe with similar Limitations and Restrictions applying to the Catalyst 4500:

For IP unnumbered interfaces, the following features are not supported:

Dynamic routing protocols

–HSRP/VRRP

–Static ARP

–Unnumbered interface and Numbered interface in different VRFs

(...)

Unfortunately I coudn't find a better source.

HTH

Rolf

New Member

Re: OSPF: IP Unnumbered feature on CISCO WS-C6503-E

Hi Rolf,

Thanks a lot for your reply.

So can I conclude that OSPF will work on IP unnumbered interface only if underlying interface is a serial port. Otherwise on ethernet ports, OSPF over IP unnumbered interface will not work?

Regards,

Abhi

OSPF: IP Unnumbered feature on CISCO WS-C6503-E

Oh - now I recall the discussion we've had a couple of weeks ago:

https://supportforums.cisco.com/message/4126967

I apologize for mentioning the support on the 6500 without pointing to the limitations (I just didn't know that there were any).

So can I conclude that OSPF will work on IP unnumbered interface only if  underlying interface is a serial port. Otherwise on ethernet ports,  OSPF over IP unnumbered interface will not work?

According to my best knowledge, yes.

Regards,

Rolf

611
Views
0
Helpful
5
Replies
CreatePlease login to create content