Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF metric calculation

Hi,

I have a doubt in ospf metric calculation. I will atatch a topology with this thread.

In that topology i expected the routers R1 and R4 to reach R5's networks via two routes. one through R2 and other through R3. i.e I expected they should choose two ABR's so that it will list in routing table both these abr's ip as next hop for the dest-ip. but that is not happening here. I have the most basic configs. Dunt know what is going wrong. Can you guys kindly point out the mistake.

Also with this topology can you explain me, why is the metric for route ( 5.1.1.0 - between f1/0 of R1 and R2 ) in R5 is 3? I can understand it manually. Can you explain me how it is calculated through LSA's.

PS: The topology is attached. For quick reference of the topology i have attached the picture.

Thanks

Chidambaram

  • LAN Switching and Routing
Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

OSPF metric calculation

Hello Chidambaram,

router R2 has no direct connection to area 0

>> router ospf 10

log-adjacency-changes

network 4.1.1.0 0.0.0.255 area 4

network 5.1.1.0 0.0.0.255 area 5

network 6.1.1.0 0.0.0.255 area 3

!

inter -area routing has to happen going through area 0.

This is a requirement of OSPF protocol design.

Area 0 is present in link R3-R4 1.1.1.0/24.

This makes R3 ABR (0,3,5), R4 ABR ( 0,4)

R2 is not attached to area 0 so it is not a true ABR, not a full working ABR.

So R4 learns of R5 routes in area 3 from R3 that is ABR (0,3,5). R2 is also member of area 3 so it has routes to R5 directly to R5 but it shouldn't be injecting an OSPF LSA type 3 summary LSA for each or R5 IP subnets from area 3 to area 4. This is the key point.

The expected result in your setup is that R4 sees only R3 as IP next-hop for R5 IP subnets in area 3.

R1 is only member of area 5 and has a direct link to R3 that is a valid ABR with links in area 0,3,5 =ABR (0,3,5)

So also R1 should install a route to R5 IP subnets in area 3 only via R3.

on R1,R4 you should see a summary LSA generated only by R3 for each IP prefix that is part of area 3.

For R4 it is a summary LSA in area 0. For R1 is a summary LSA in area 5.

the summary LSA should list the cost from the point of view of ABR R3 so the listed cost should be 2 = 1 to reach R5 + 1 as the cost of an interface as reported in R5 router LSA in area 3.

The internal cost to reach R3 the ABR is summed to the metric reported into the summary LSA so the total cost is 3.

If you want to make R2 a true ABR connect it to R3 with a link in area 0.

Hope to help

Giuseppe

2 REPLIES
Hall of Fame Super Silver

OSPF metric calculation

Hello Chidambaram,

router R2 has no direct connection to area 0

>> router ospf 10

log-adjacency-changes

network 4.1.1.0 0.0.0.255 area 4

network 5.1.1.0 0.0.0.255 area 5

network 6.1.1.0 0.0.0.255 area 3

!

inter -area routing has to happen going through area 0.

This is a requirement of OSPF protocol design.

Area 0 is present in link R3-R4 1.1.1.0/24.

This makes R3 ABR (0,3,5), R4 ABR ( 0,4)

R2 is not attached to area 0 so it is not a true ABR, not a full working ABR.

So R4 learns of R5 routes in area 3 from R3 that is ABR (0,3,5). R2 is also member of area 3 so it has routes to R5 directly to R5 but it shouldn't be injecting an OSPF LSA type 3 summary LSA for each or R5 IP subnets from area 3 to area 4. This is the key point.

The expected result in your setup is that R4 sees only R3 as IP next-hop for R5 IP subnets in area 3.

R1 is only member of area 5 and has a direct link to R3 that is a valid ABR with links in area 0,3,5 =ABR (0,3,5)

So also R1 should install a route to R5 IP subnets in area 3 only via R3.

on R1,R4 you should see a summary LSA generated only by R3 for each IP prefix that is part of area 3.

For R4 it is a summary LSA in area 0. For R1 is a summary LSA in area 5.

the summary LSA should list the cost from the point of view of ABR R3 so the listed cost should be 2 = 1 to reach R5 + 1 as the cost of an interface as reported in R5 router LSA in area 3.

The internal cost to reach R3 the ABR is summed to the metric reported into the summary LSA so the total cost is 3.

If you want to make R2 a true ABR connect it to R3 with a link in area 0.

Hope to help

Giuseppe

New Member

OSPF metric calculation

Thank you very much Guiseppe. Never expected a big concept to be involved behind this . I was thinking i had made a mistake somewhere. Thanks again. (hats off).

Chidambaram

375
Views
0
Helpful
2
Replies