Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

OSPF on Frame-Relay

I have been trying a lab in GNS3 for using OSPF on Frame-Relay.

I have a few questions regarding that. Will be really grateful if someone can help to clarify these:

1.. When I used debug ospf ..... I found that OSPF is sending hello packets to a strange IP Address although no static neighbor has yet been configured:
*Mar  1 00:28:04.663: OSPF: Send hello to 0.0.0.1 area 0 on Serial0/1 from 1.0.0.3

What is this IP "0.0.0.1" ??

2.. Although I have not used the broadcast keyword which configuring the static IP to DLCI mapping. But the two routers exchange their routes across the Frame-Relay network. Why is this so?

3.. When we use the OSPF network type of broadcast, does the router starts sending the updates to the multicast address 224.0.0.5 and 224.0.0.6?? If so, how are they delivered by the FrameRelay network which is not capable of delivering a Broadcast/Multicast Frame ??

If these are still delivered as Unicast then what is the significance of using the Network Type of Broadcast ???

4.. The same question is for the Point-to-Multipoint Network.

5.. And in the last a very basic question, but which is confusing me, that why we need to take so much pain for selecting amont the 5 OSPF Network Types for the Frame-Relay interfaces?? 

And what is the best option to be used and why ??

Best Regards,

10 REPLIES

Re: OSPF on Frame-Relay

Hello Daud,

Lets start with your last question: There are simply too many possibilities.

The recommended solution is to always use /30 nets and subinterfaces. This will trigger ospf to use the point-point network type thereby avoiding all non-broadcast related issues.

As for the other questions: All will depend on the configuration. Not only how you configure ospf but also how frame-relay is set up. Whether you used frame-relay map commands or not can already make a lot of difference.

With this kind of setup, the devil is really in the details and you need to be very careful while configuring them.

On GNS, many people simply do not spend enough time to go through all possibilities and detect the subtle differences between them.

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094051.shtml

regards,

Leo

Cisco Employee

OSPF on Frame-Relay

Leo,

The recommended solution is to always use /30 nets and subinterfaces.  This will trigger ospf to use the point-point network type thereby  avoiding all non-broadcast related issues.

Really? I have never noticed OSPF change its mind about the network type based on the netmask. All my experiences show that the default network type is always determined by the interface type and encapsulation, and is never influenced by its particular addressing.

Best regards,

Peter

OSPF on Frame-Relay

Peter Paluch wrote:

Leo,

The recommended solution is to always use /30 nets and subinterfaces.  This will trigger ospf to use the point-point network type thereby  avoiding all non-broadcast related issues.

Really? I have never noticed OSPF change its mind about the network type based on the netmask. All my experiences show that the default network type is always determined by the interface type and encapsulation, and is never influenced by its particular addressing.

Best regards,

Peter

Hi Peter,

As usual you are right. What I meant to say was using point-point subinterfaces on frame relay.

This is explained in the same link:

Frame Relay subinterfaces can run in two modes:

  • Point-to-Point—When a Frame Relay point-to-point subinterface is configured, the subinterface emulates a point-to-point network and OSPF treats it as a point-to-point network type.

...

Leo

New Member

Re: OSPF on Frame-Relay

Thanks Leo for your reply,

if we use Point-to-Point sub-interface on frame-relay network then the default ospf type for that is POINT-TO-POINT. For POINT-TO-POINT network type, the default OSPF behavious is to send updates using the multicast address 224.0.0.5. But my confusion is that frame relay is not capable of forwarding the multicast addressed packets. Then how do they get routed to the other end router. Also, if we say that frame relay is concerned only with the DLCI, then should it not so that we should create a static mapping of the 224.0.0.0 to the DLCI used on the frame relay pvc ??? But in reality this works without creating this static mapping which is confusing me.

Clarification to other questions is that i am using frame relay on interface level with frame-relay map command with no broadcast keyword and inverse-arp disabled.

Best Regards

Cisco Employee

OSPF on Frame-Relay

Hello Daud,

1.) Is it possible that the 0.0.0.1 was actually the neighbor's Router ID? When starting OSPF on NBMA networks, it is sufficient to have a static neighbor defined just on one end of a VC - the other router will not be capable of initiating OSPF adjacency (because it does not know to whom it should initiate it) but once another router contacts it directly, it will respond and form an adjacency.

2.) Please include the configuration of your two routers. It is difficult to answer without knowing how your routers are exactly configured.

3.) If the broadcast network type is used, the router will indeed start using the multicast IP addresses 224.0.0.5 and 224.0.0.6 for OSPF communication. The Frame Relay is not capable of replicating these multicasts itself but if the IP/DLCI mappings are configured with the broadcast flag, your router will replicate each broadcast/multicast packet itself, sending it over every VC that has the broadcast flag set. Frame Relay does not really care if the packet is broadcast/multicast/unicast. All it cares about is whether the DLCI has been set properly.

This is a common confusion with NBMA networks, by the way. It is often believed that they are incapable of delivering broadcasts/multicasts. That is not true. They are incapable of replicating broadcasts/multicasts. It is the job of the node that is directly connected to a NBMA network to replicate such packets on its own, but after it has been replicated over every virtual circuit, the NBMA network will happily deliver it to the other end of the VC.

4.) The point-to-multipoint network type behaves, within the aspect of addressing, replicating and delivering multicast packets, exactly identically to the NBMA network type. Once again, there is no difference between PtMP and NBMA network types as far as the multicast packet replication/delivery goes.

The difference is in the way the OSPF models the network in its link-state database. With NBMA, the network itself is expected to provide full-mesh connectivity and is therefore represented as an LSA2 generated by the Designated Router - which has to be elected. If the NBMA network does not provide full-mesh connectivity then many things have to be tweaked: OSPF priorities for DR/BDR elections, next-hop address reachabilities, etc.

With PtMP, the network is seen simply as a bunch of VCs assorted under a common interface. There is no expectation of a full-mesh connectivity, quite contrary: a link is assumed between two routers only if they mutually hear and accept their Hello packets. If there is no VC between two routers, they won't hear themselves directly and hence, no direct connection between them will be installed in the link-state database. The PtMP does not elect DR/BDR and does not represent the network as a LSA-2. At a price of being more memory-intensive, it models the real reachability within the network far more accurately.

5.) The NBMA network type was put to OSPF primarily because OSPF was originally intended to run over networks with signalled VCs and each router could ask the network to provide a VC to every other router, creating a full mesh - think ATM, X.25, SMDS. A full mesh network is then representable more efficiently both in memory and CPU terms using a LSA-2.

However, with Frame Relay in particular, the network is seldom fully meshed. Much more often, Frame Relay networks are hub-and-spoke or partially meshed. The OSPF was never meant to run in NBMA mode on such networks and it is actually surprising how many people are trying to force the NBMA network type upon the Frame Relay. Frame Relay with its partially-meshed PVCs not controlled by individual routers is an exemplary candidate for Point-to-Multipoint network type. The downside of the PtMP network type is the increase in the memory and CPU complexity, because each router has to declare a link to all other routers it can hear Hello packets from, leading to O(N^2) memory complexity, as opposed to the linear O(N) complexity with LSA-2 and fully meshed networks.

Best regards,

Peter

New Member

Re: OSPF on Frame-Relay

The configurations of the two routes is as follows:

__________________________________________________R2 Configuration___________________________________


R2#sh run
Building configuration...

interface Loopback0
ip address 22.22.22.22 255.255.255.255
!        
interface Serial0/0
ip address 1.0.0.1 255.0.0.0
encapsulation frame-relay
serial restart_delay 0
frame-relay map ip 1.0.0.3 103
no frame-relay inverse-arp

!
router ospf 1
log-adjacency-changes
network 1.0.0.0 0.255.255.255 area 0
network 22.0.0.0 0.255.255.255 area 0
neighbor 1.0.0.2

!
end

                                                            _______________________________

R2#sh ip ospf n

Neighbor ID     Pri   State           Dead Time   Address         Interface
N/A               0   ATTEMPT/DROTHER 00:00:25    1.0.0.2         Serial0/0
33.33.33.33       1   FULL/DR         00:01:45    1.0.0.3         Serial0/0

R2#sh ip route
Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, Serial0/0
     33.0.0.0/32 is subnetted, 1 subnets
O       33.33.33.33 [110/65] via 1.0.0.3, 00:01:22, Serial0/0
     22.0.0.0/32 is subnetted, 1 subnets
C       22.22.22.22 is directly connected, Loopback0
R2#

__________________________________________________R3 Configuration___________________________________

R3#sh run
Building configuration...

!
interface Loopback0
ip address 33.33.33.33 255.255.255.255
!
interface Serial0/1
ip address 1.0.0.3 255.0.0.0
encapsulation frame-relay
serial restart_delay 0
!

router ospf 1
log-adjacency-changes
network 1.0.0.0 0.255.255.255 area 0
network 33.0.0.0 0.255.255.255 area 0
neighbor 1.0.0.1 priority 1

!
end

                                        __________________________________________

R3#sh ip ospf n

Neighbor ID     Pri   State           Dead Time   Address         Interface
22.22.22.22       1   FULL/BDR        00:01:51    1.0.0.1         Serial0/1
      

R3#sh ip route
Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, Serial0/1
     33.0.0.0/32 is subnetted, 1 subnets
C       33.33.33.33 is directly connected, Loopback0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/65] via 1.0.0.1, 00:00:31, Serial0/1
R3#

Re: OSPF on Frame-Relay

Yet another helpful link:

http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080094054.shtml#backinfo

Regarding your config:

On R2 you have used a frame-relay map command pointing to R3.

On R3 there is a neighbor pointing to R2.

This is all a bit inconsistent; typically you would configure both sides in a similar way.

By choosing ospf network-type point-to-point you can avoid DR/BDR election and reduce memory and processing requirements.

regards,

Leo

New Member

Re: OSPF on Frame-Relay

Dear Leo,

Here is the new configuration but the results are the same. I am wondering why OSPF is exchanging updates if i have not used the "broadcast" keyword with the frame-relay map command??

__________________R2 Configuration ________________

R2#sh run
Building configuration...

!
interface Loopback0
ip address 22.22.22.22 255.255.255.255
!        
interface Serial0/0
ip address 1.0.0.2 255.0.0.0
encapsulation frame-relay
serial restart_delay 0
frame-relay map ip 1.0.0.3 103
no frame-relay inverse-arp
!

router ospf 1
log-adjacency-changes
network 1.0.0.0 0.255.255.255 area 0
network 22.0.0.0 0.255.255.255 area 0
neighbor 1.0.0.3

!

end

                    ***********************************

R2#sh ip ospf n

Neighbor ID     Pri   State           Dead Time   Address         Interface
33.33.33.33       1   FULL/DR         00:01:51    1.0.0.3         Serial0/0

R2#sh ip route
C    1.0.0.0/8 is directly connected, Serial0/0
     33.0.0.0/32 is subnetted, 1 subnets
O       33.33.33.33 [110/65] via 1.0.0.3, 00:00:56, Serial0/0
     22.0.0.0/32 is subnetted, 1 subnets
C       22.22.22.22 is directly connected, Loopback0

                   

__________________R3 Configuration ________________

R3#sh run

!
interface Loopback0
ip address 33.33.33.33 255.255.255.255
!        

interface Serial0/1
ip address 1.0.0.3 255.0.0.0
encapsulation frame-relay
serial restart_delay 0
frame-relay map ip 1.0.0.2 301
no frame-relay inverse-arp
!

router ospf 1
log-adjacency-changes
network 1.0.0.0 0.255.255.255 area 0
network 33.0.0.0 0.255.255.255 area 0
neighbor 1.0.0.2 priority 1

!
end

                         **********************

R3#sh ip ospf n

Neighbor ID     Pri   State           Dead Time   Address         Interface
22.22.22.22       1   FULL/BDR        00:01:52    1.0.0.2         Serial0/1

R3#sh ip route
C    1.0.0.0/8 is directly connected, Serial0/1
     33.0.0.0/32 is subnetted, 1 subnets
C       33.33.33.33 is directly connected, Loopback0
     22.0.0.0/32 is subnetted, 1 subnets
O       22.22.22.22 [110/65] via 1.0.0.2, 00:02:12, Serial0/1

Best Regards,

OSPF on Frame-Relay

Daud Parvez wrote:

Dear Leo,

Here is the new configuration but the results are the same. I am wondering why OSPF is exchanging updates if i have not used the "broadcast" keyword with the frame-relay map command??

By using the frame-relay map command, you are introducing a point-point logic to the system: In order to send anything over the link, the router needs to know which dlci to use. The frame-relay map command accomplishes exactly that.

With this knowledge, the router simply assumes all of network 1.0.0.0 can be reached via this path, including the ospf neighbor which you have also specifed using an ospf neighbor command. 

When you have used a frame-relay map command, the broadcast option is no longer required and becomes effectively redundant. Its presence or absence does not make a difference anymore.

regards,

Leo

Cisco Employee

OSPF on Frame-Relay

Daud, Leo,

I see it a little differently. Please discuss this with me and feel welcome to disagree!

On NBMA networks, OSPF refuses to send multicast packets altogether. If you run OSPF over a NBMA network, with or without any mappings with the broadcast flag, you will see nothing. OSPF does not even try to send multicast packets over NBMA networks. This is easily proved by running debug ip packet - if a router tried to send a multicast packet over a NBMA network without any broadcast flags, the router would report "encapsulation failed" messages. However, you will not see any such reports for OSPF running over NBMA. Once again, as soon as OSPF has a NBMA network to run over, it will wait for a neighbor command or for a Hello packet received from other router, but it is not going to try to send multicast packets over a NBMA network type.

As I explained earlier, NBMA networks are unable to replicate broadcasts/multicast but once they have been replicated by the sender himself, they are perfectly capable of carrying them. It is the design of OSPF that decides not to even try to send multicasts over NBMA networks - even if it would work, thanks to the broadcast flag on IP/DLCI mappings.

Daud's configuration contains neighbor commands. That is precisely the reason why the OSPF works in Daud's case: his routers are simply communicating by unicast using addresses used in the static neighbor commands.

Leo, I am afraid I do not understand these comments:

With this knowledge, the router simply assumes all of network 1.0.0.0  can be reached via this path, including the ospf neighbor which you have  also specifed using an ospf neighbor command.  

What do you mean by this statement? Are you suggesting that the existence of a single mapping in IP/DLCI table leads the router to assume something about the reachability of the entire network?

When you have used a frame-relay map command, the broadcast option is no  longer required and becomes effectively redundant. Its presence or  absence does not make a difference anymore. 

I respectfully disagree. The broadcast flag is always significant. The presence of a broadcast flag on a particular mapping simply directs the router to replicate broadcasts and multicasts over a particular DLCI. If a mapping does not have the broadcast flag, broadcast and multicasts sent out that interface will not be replicated onto that particular DLCI.

Best regards,

Peter

730
Views
0
Helpful
10
Replies